AUR package dependency preventing updates - Phython Jaraco & sabnzbd+. Please help a noob? :)


I’m a little new to this and could use some help. When trying to update, I get this error:

could not satisfy dependencies:

  • removing python-jaraco breaks dependency ‘python-jaraco’ required by sabnzbd

I get this from both the GUI and terminal. Checking the page for sabnzbd, I figured out that phython-jaraco is being removed and replaced with a newer version. I think sabnzbd can use this newer version (but not 100% clear on that).

So I think, no big deal. I’ll just remove sabnzbd, update my entire system, and then reinstall sabnzbd (thinking that will maybe force it to use the new phython tools). But I can’t remove sabnzbd - I just go down this rat hole of “can’t remove this because this other thing is dependent on it” Try to remove that one, get the same error about a different dependency. 12 dependencies later, it lists a thing that I can’t even find in the installed software list.

Manjaro has been surprisingly easy to use for years, but this is the first issue I’ve run across where I’m not sure where to go next. I’ll take any advice you got - thanks :slight_smile:

No, it doesn’t. 3.6.0-2 was updated earlier this week to reflect the new jaraco packages.

That’s a good approach in general when encountering dependency issues with AUR packages.

1 Like

Thanks for the reply. Now I’m very confused and potentially this is pilot error? When I first encountered this issue a couple of weeks ago, I thought “give it time - maybe some packages need to be updated” After waiting, and still getting the same results, I thought I’d dig in tonight and solve it. I usually upgrade via the terminal following some instructions I found here some time ago:
pacman-mirrors, ensure enough diskspace via journalctl, clean up pacman cache via paccache, pacman -Syyu, rebuild AUR packages via pamac upgrade -a, then reboot.

Tried that tonight - same error about dependencies. =\ Tried the GUI pamac, same error. Typed the above question.

So now it gets weird. I thought I’d try yay - if I’m understanding this correctly - that shouldn’t make a difference over pamac. But via the GUI I searched for and selected yay to be installed (thinking I’d then go try that way). Much to my surprise, yay was installed as well as my whole system updated!

It’s like I had some kind of cache that needed to be refreshed and selecting yay for an install unstuck the whole thing? Do you see anything wrong with my normal upgrade procedures?

Either way - system is working 100% again and everything is updated. I’m confused, but I’ll take it :slight_smile: Thanks for the help!