`aur.manjaro.org` gives timeout via pamac but not via wget/browser/curl (no SSL error)

Running this command today and getting this output:

[I] sapo@accendino ~ (master)> pamac upgrade -a
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: my name (sapo)
Synchronizing package databases...
https://aur.manjaro.org/packages-meta-ext-v1.json.gz: Socket I/O timed out
Failed to synchronize AUR database
Nothing to do.
Transaction successfully finished.

But wget downloads it correctly (I also tried browser and curl)

[I] sapo@accendino ~ (master)> wget https://aur.manjaro.org/packages-meta-ext-v1.json.gz
--2023-07-31 16:33:06--  https://aur.manjaro.org/packages-meta-ext-v1.json.gz
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving aur.manjaro.org (aur.manjaro.org)..., 2a02:6ea0:d500::7
Connecting to aur.manjaro.org (aur.manjaro.org)||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10474598 (10,0M) [application/octet-stream]
Saving to: ‘packages-meta-ext-v1.json.gz’

packages-meta-ext-v1.json.gz 100%[==============================================>]   9,99M  11,2MB/s    in 0,9s    

2023-07-31 16:33:10 (11,2 MB/s) - ‘packages-meta-ext-v1.json.gz’ saved [10474598/10474598]

Is it possible to use the local copy to update the database while we get this timeout?

Have you tried another aur helper, like yay or paru?

No, but it was likely an issue with the network I was using. From another network it works.