AUR Dropbox: why do we need now to import gpg key manually, why?

I tried to install dropbox like I always do with Manjaro and for some reasons this is no longer working as it used to be, so I’m wondering if there is any issue with that particular AUR package?

[kerryp@kerry-precision5520 ~]$ yay -S dropbox
:: There are 4 providers available for dropbox:
:: Repository AUR
    1) dropbox 2) dropbox-gtk2 3) kfilebox 4) kfilebox-qt5-git 

Enter a number (default=1): 1
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  dropbox-106.4.368-1

  1 dropbox                                  (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
:: Downloaded PKGBUILD (1/1): dropbox
  1 dropbox                                  (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
:: (1/1) Parsing SRCINFO: dropbox

:: PGP keys need importing:
 -> 1C61A2656FB57B7E4DE0F4C1FC918B335044912E, required by: dropbox
==> Import? [Y/n] 
:: Importing keys with gpg...
gpg: keyserver receive failed: General error
problem importing keys

I was like okay importing the key with gpg doesn’t work, so I googled and ended up on another post on this forum hinting me to do:

gpg --keyserver --recv-keys 1C61A2656FB57B7E4DE0F4C1FC918B335044912E

And now it works yay -S dropbox works like a charm!

But I’m wondering why I have to do that manually, while it used to be completely transparent before?

a server “bug” (https certificate expire, server maintenance, …) and here we choose another
before: default server was ok


Thanks, it makes sense!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.