AUR Behaves Like Official Manjaro Repository in Pamac

I got some updates and those seem AUR packages exactly looked like Official Manjaro Packages. When I tried to update them always turn to:

Failed to prepare transaction: invalid or corrupted database

Also when I tried to ignore all updates and install new packages all the time I got same error notification in Pamac.
I tried many times refresh mirrors, keys and other as mentioned Manjaro Wiki didn’t solve the problem.
And this is how my Pamac looked like in those times:

After applying @linux-aarhus 's this post solve the problem.

It would be more helpful to include what errors you are encountering.

I will also note that some most of those are not AUR packages (mhwd-nvidia, snapd).

Something to consider is … are you in a bad sync state or using a bad mirror?

These could contribute to odd or incorrect package status.


A removal might look like (after trimming your list to only include AUR packages);

sudo pacman -Rns krunner5

A programmatic way to remove ‘foreign’ (non-repo, including AUR) packages;

sudo pacman -Rns $(pacman -Qmq)

No, they are not.
In fact only 1 is.
And even then only if you are not on the Stable branch.
If you are on Stable branch … then all of them are repo packages.

(Here I am taking your meaning as ‘AUR package’ to equal ‘not in the repos’ - many of these packages have equivalents in the AUR. Because Manjaro is not Arch)

Feel free to search them all.

I must conclude your system is not in a correct state.

Please sort mirrors and resync;

sudo pacman-mirrors -f && sudo pacman -Syu

It may also signify poor pacman configuration due to unmanaged pacnews.
To print them all;

pacdiff -o


You can also manually check the status of your mirror at the following resource;

All those packages have equals in the AUR with the same name.

Its one of the many reasons some people avoid pamac, and those that use it often disable its AUR functionality.

Such a thing has been a problem for a long time - including meaning people accidentally at times replace the repo versions with the AUR versions.

I thought it might have been fixed … but I dont use pamac.

I also think you still have the repo versions installed. Given the versions.

Maybe to be more sure we can do

sudo pacman -Syu krunner5 snapd thunarx-python v86d xcursor-breeze zsh-theme-powerlevel10k ckbcomp

Which should point at the repo versions, as pacman does not support the AUR directly.

Back in pamac you might also try ‘force refresh’.

I also still suggest checking your pacnews :wink:



only everything

or, to put it into other words:

Why / what for
did you post the contents of /etc/pacman.conf ?

OP still hasn’t shown us the error message. :grin:
This solve the problem.
Thank you @cscs for your caring, understanding and patience!
Thank you for your great explanation @linux-aarhus
You are best!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.