AUR applications not showing in Cinnamon Menu

Hi all, I just moved to the Cinnamon version of Manjaro after having tons of issues with KDE Plasma that spanned various different distros, so far I’m enjoying it but one issue I’ve encountered thus far is AUR applications not showing in the Cinnamon “Start” menu thus making me open them by other means.

I do quite a bit of creative work, one of which is making Doom wads in my spare time, so I like to make use of the ultimate-doom-builder-git package in the AUR, I’ve searched the forum hoping to find an answer but I’ve sadly had no luck with that so I thought I’d ask if anyone knows how to make AUR programs accessible via the menu?

Your using the plural but only mention one program, so it is only this or more?

I’m not a .desktop files expert but that one is missing Categories= fields which should tell in which parts of the menu the entry appear

I mentioned ultimate doom builder as just an example, in case anyone else decided to download and see if they experience the same issue. I have since found out it doesn’t affect all AUR programs however such as goverlay but it’s certainly a big hit or miss.

I’m not quite sure how to check the categories myself, I’d certainly appreciate some pointers on that if it’s not too much hassle.

Aur programs sometimes dont have a launcher. You can create one and place it in /usr/share/applications and it should show in a menu.

I believe I may have found the cause, it seems some AUR packages put their desktop file into a folder in the directory, this doesn’t seem like an issue in KDE Plasma but for the Cinnamon desktop this seems like it’s the culprit for them not showing up in the menu. Having a hard time copying and pasting it back into the previous folder where every other application desktop file is

Ahah! Did it, I just had to rename the folder and then copy the .desktop back into the applications folder, now it shows up in the menu :slight_smile:

This one have

Yes, there is a typo in the pkgbuild (I have emailed the fixes to the maintainer about it) where it use:

    install -D "$srcdir/ultimate-doom-builder.desktop" -t "$pkgdir/usr/share/applications/ultimate-doom-builder.desktop"

need to be:

    install -D "$srcdir/ultimate-doom-builder.desktop" -t "$pkgdir/usr/share/applications/"

(no need to specify ultimate-doom-builder.desktop when using -t option)

1 Like

Ahh typos, I know very well how much of a pain they can be.