Audio Subpanel Stop Auto-Adjustment of Mic?

I have a mic issue where I like the gain at 65% (just perfect), but the audio subpanel auto-adjusts it higher which leads crackeling over the mic and my voice is over exposed in the signal. (the slider for the mic auto adjusts higher than I want it to).

Is there any way to stop it from doing this? I’ve recorded myself in OBS and I sound just fine on 65%, but the system has other plans when it hears me :frowning:

Check if module-echo-cancel is active with pacmd list-modules. This module does such things.

1 Like

pacmd list-modules | grep module-echo returns nothing :slight_smile:

Why don’t you set a limiter in OBS?

It’s not OBS that I’m worried about, it’s happening on Zoom calls :smiley:

1 Like

Ahh oke,

In that case…

In Zoom settings -> audio
just disable automatically adjust microphone

Why didn’t you mention zoom? :grin: Such applications do of course adjust the mic and audio xD

Automatically adjust mic has been disabled for a while :smiley:


Pulseaudio only adjusts the mic is module-echo-cancel is loaded and it is not your saying.
Zoom also adjust the mic but only if auto adjust is enabled, but it is disabled your saying.

So all you can do is kinda force it off. You have to edit some config files for this to disable it for every mic you use or tent to use.

In /usr/share/pulseaudio/alsa-mixer/paths/ you need to edit all configs with mic in it with the exception of analog-input-mic.conf.common
and set volume = merge to volume = zero

Within these configs you need to set this for:
[Element Capture] and [Element Mic Boost] including all variations like [Element Internal Mic Boost]