Audio Profile or Configuration "Make a phone call" not working BETA28

this is my first forum post.
I am using the version BETA28 of Phosh for PinePhonePro.
I have issues in making and receiving calls.
The issue is: I can’t hear anything and the other person also can’t here anything. The call itself seems to be established correctly.

When I open the Settings App, there are 2 configurations: “Make a phone call” and “Play HiFi quality music”. When selecting “Play HiFi quality music” I can test the speaker in the Test Popup successfully. When selecting “Make a phone call” I can open the Test Popup, but I can’t hear anything. I am not sure, if this is related to the call issue, but it might be a hint.
Is it possible to just remove the other profile or how to dig in deeper? I don’t have any other sound issues, only with the gnome-calls app. Or maybe there is an alternative to the gnome-calls app for PinePhonePro with Phosh?

Thanks and BR

Hi! This is how sound works currently:
You have two default configurations “speaker” and “earpiece”
“Speaker aka play hifi quality music” is the default one and it should be active if you are not in phone call (so you can hear incoming call ringtones or alarms or music etc)
When you start a call or answer to call Phosh will switch to “earpiece aka Make a phone call” so the audio will go trough earpiece like in all other phones.
There are no alternatives to Calls if you want something working. Don’t remove profile.

I don’t have Pinephone Pro but I know that there are some major call audio issues as we speak - but I have not heard that there are no sound at all.
Please double check with settings app that are you hearing something with “Make phone call” setup because the sound comes only from earpiece and it is more silent → if it works try to call again and be sure that it is not working before doing anything else.

If earpiece is not working:
I have only Pinephones and I can give you suggestion what works with Pinephones (they might work with PPP also because many things are very similar).
For me this combination of apps/services is most reliable:
pipewire pipewire-media-session pipewire-pulse
and these are packages what you maybe need to remove:
wireplumber pulseaudio
Reboot and try again.

Hope this is helpfull (I have plenty of stories for call audio so I can try to help even after this but as said I have limited opportunities because I don’t have PPP yet)
Merry xmas

Hi alaraajavamma,

thank you very much for your response.
I can confirm, that the internal earpiece is working.
When selecting “Play HiFi” I can switch between internal speaker and earpiece for testing the sound. Both works.
But with the “Make phone call” setup it does not work (both doesn’t).

pulseaudio and wireplumber is not installed and pipewire-pulse and pipewire-media-session is already installed.

Because of this situation, I think there is an issue with my Make phone call setup. But I don’t know where the settings behind are located. Some time ago, it was already possible to do a phone call with correct sound. I think it broke up, when i tried to use a 3.5 inch headset and plugged it in before or while calling, but I am not 100% sure if this was the reason or if it broke before.

Thanks and BR

The issue is fixed now.
I did several things, but after all I do not really know what was causing the problem and what was the solution.

Here is some general information, if somebody gets into a similar situation:
The “Sound Test” in gnome control center does not work in configuration “Make a phone call” but this does not mean, that the sound does not work in a phone call.

If you want to know, where the hardware configuration for “Voice Call” and “HiFi” are located: They are there: /usr/share/alsa/ucm2/PinePhonePro and they are installed via package alsa-ucm-pinephone. The content of the .conf files is originally from this repository: Pine64 / Pine64 ALSA UCM · GitLab.

To get some information about the audio setup, volumes, sources sinks, sound cards etc. use pactl. “pactl -h” and “pactl list cards” are good commands to start with.

The related packages I played around with (reinstalling, removing, installing) are the following:

I hope this helps, maybe the phone was just in an unusual state and I simply didn’t now, that the “Sound Test” in gnome-control-center has no significance.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.