Audio only in games stopped working in the last couple weeks

Sound works fine in KDE & chrome. Wayland or X11 have same behavior.

However, in steam, any native game I have the sounds just has stopped working on launch. Valheim, Vampire Survivor, Hollow Knight, etc. When I launch a game, there is just no sound. The games will not quit correctly anymore either. After trying the game, no sound works at all. I have to restart pipewire to get sound to work again.

I do not see any telling info in dmesg or journalctl --boot.

I was using pipewire. I switched back to pulse, exact same behavior, so I switched back to pipewire again.

No errors or anything print on the console if I launch from console.

Today I found the craziest thing, while the game is open, if I switch to tty3, log in, I’ll hear music from the game. If I log out and go back to tty1, the sound is working in the game. I must actually log in though, just switching ttys does nothing. I found this on accident, but am using as a workaround for now.

Normally I use my HDMI through my AMD Radeon 6750, however I get the exact same behavior out of the motherboard sound output.

I can provide whatever details, I’m not sure what is even helpful at this point. Any help on where to look for what is even going on would be appreciated.

Everything was working fine. It was some update that did something. I just have no idea which update of what it even was.

How about installing qpwgraph and checking if the sound output is correctly connected?

It looks correctly connected.

When I play a sound in KDE, a box comes up wired into HDMI. Sound plays fine. After sound is done playing, box goes away.

When I launch a game, new box shows up wired into same HDMI. No sound is coming out though. Playing another sound in KDE, it’s box comes up wired how it was before, but no sound. When I TTY3, log in, and come back, it’s the same boxes wired but the sound is working.

Maybe it’s a different issue but have you tried creating .asoundrc file on your home directory?

i am experiencing the same thing with valheim. it may be related to last update, as it was working yesterday. after i did upgrade, valheim lost sound. tried couple of other games, surviving mars, cities skylines and all was find. also spotify is working etc.

edit: downgrading pipewire has no effect!

I just updated and tried Valheim natively and sound works like it should.

Have you tried using a comparability layer like Proton-8, experimental or proton-ge?
A tip is to do that anyway in that game, I stopped counting how many times I could not find the cursor in time in battle and almost dying when pressing tab. Natively the cursor does not center when pressing tab, with proton it does. xD

Strange it only happens on some games for you guys. Since switching tty and back makes sound come back it seems to be something with the desktop rather than the game.

are you using pipewire?

edit: windowz version on protonGE is working with audio.

Yes I am.

HI, have the same issue after the last update. And seems like sound problems are related to unity3d games only, other engines are fine.

Update today seems to have fixed all the issues. I’m not going to go through the bisecting what all was updated, but definitely update related.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.