Audio not working only on rear speakers (fine on front speakers)

Hi everyone,
I updated my manjaro installation and sound is only working on front speakers. I tested it with windows so it is not a hardware issue. It was also working before the latest update. I don’t even know where to start debugging. I tried several things from this forum, which were for older issues, but this one seems different.

$ inxi -Fazy
  Kernel: 5.10.13-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=45ce70ae-e979-41fd-8e1b-372b93d8c809 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.3 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: Micro-Star model: MPG Z490 GAMING EDGE WIFI (MS-7C79) 
  v: 1.0 serial: <filter> UEFI: American Megatrends v: 1.30 date: 10/12/2020 
  Info: 10-Core model: Intel Core i9-10850K bits: 64 type: MT MCP 
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 5 microcode: E2 
  L2 cache: 20 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 144040 
  Speed: 1376 MHz min/max: 800/5200 MHz Core speeds (MHz): 1: 1376 2: 1269 
  3: 1193 4: 1286 5: 1260 6: 1295 7: 4438 8: 1240 9: 1333 10: 4092 11: 4723 
  12: 1265 13: 1240 14: 1241 15: 2682 16: 1255 17: 859 18: 1275 19: 1287 
  20: 2959 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GK110B [GeForce GTX 780 Ti] vendor: Gigabyte driver: nvidia 
  v: 460.39 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:100a 
  class ID: 0300 
  Display: x11 server: 1.20.10 compositor: gnome-shell driver: 
  loaded: nvidia resolution: <missing: xdpyinfo> 
  OpenGL: renderer: GeForce GTX 780 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 
  direct render: Yes 
  Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:06c8 class ID: 0403 
  Device-2: NVIDIA GK110 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e1a 
  class ID: 0403 
  Device-3: Ruision UVC Camera type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 1-2:2 chip ID: fefe:4321 class ID: 0102 serial: <filter> 
  Sound Server: ALSA v: k5.10.13-2-MANJARO 
  Device-1: Intel Wireless-AC 9462/9560 driver: iwlwifi v: kernel 
  bus ID: 00:14.3 chip ID: 8086:06f0 class ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 
  v: kernel port: 3000 bus ID: 03:00.0 chip ID: 10ec:8125 class ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  Device-1: Intel type: USB driver: btusb v: 0.8 bus ID: 1-14:6 
  chip ID: 8087:0026 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Local Storage: total: 953.87 GiB used: 250.44 GiB (26.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: TeamGroup model: TM8PS7001T 
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 7B0 
  ID-1: / raw size: 80 GiB size: 78.24 GiB (97.81%) used: 27.71 GiB (35.4%) 
  fs: ext4 dev: /dev/sda6 maj-min: 8:6 
  ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.2 MiB (26.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw size: 80 GiB size: 78.24 GiB (97.81%) used: 8.89 GiB (11.4%) 
  fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-0f482a10-ebf3-4d35-8681-e747d58e68d9 
  ID-4: /var raw size: 35.3 GiB size: 34.5 GiB (97.72%) 
  used: 12.08 GiB (35.0%) fs: ext4 dev: /dev/sda9 maj-min: 8:9 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda8 maj-min: 8:8 
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 43 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 22% 
  Processes: 433 Uptime: 44m wakeups: 0 Memory: 31.28 GiB 
  used: 4.34 GiB (13.9%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1378 lib: 401 flatpak: 0 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.3.00 

Check alsamixer to see if anything is muted.

Yeah, that worked. Why would someone change those settings in an update? :man_facepalming:

Hello Everyone,
How to troubleshoot low audio or no audio from rear sound speakers. So, first of all increase the rear speaker volume/maximize the speaker settings. Try selecting a different size for the rear surround speaker in the menu. Verify that the A / V receiver is set to surround the sound mode.

I hope this solution helps you.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.