Audio doesn't toggle automatically between speaker & earphone


I use a 2009 Dell Studio XPS. For the past several years (with many distros) my laptop speakers hadn’t worked. I was of the opinion that may be the speakers had given up and anyway I use the earphones most of the time.
However today suddenly the audio output came out of the speakers and I was overjoyed. However issue is that when I plug in my earphones, the audio doesn’t automatically switch to the earphones. I have to go into Audio settings and change the output device.

Although I’m happy that the speakers are working fine, I would like to have it in such a way that the audio switches to earphone when plugged in and via speakers when no earphones are plugged in.

What do I need to do to get this sorted?

You probably need to turn on the Auto-Mute Mode setting in ALSA

You can do this with alsamixer in terminal

  • Use F6 to find correct audio device

  • to locate ‘Auto-Mute Mode’

  • to change setting from Disabled to Enabled

  • Esc to exit

and use this command to save changes to ALSA settings

sudo alsactl store

Thanks but this didn’t work.

please post ALSA information

sudo --upload

and PulseAudio information

pacmd list-cards

ALSA information can be found here -

PulseAudio Info
viking@pradhyumna-studioxps1640 ~]$ pacmd list-cards
2 card(s) available.
    index: 0
        name: <alsa_card.pci-0000_01_00.1>
        driver: <module-alsa-card.c>
        owner module: 6
                alsa.card = "1"
                alsa.card_name = "HDA ATI HDMI"
                alsa.long_card_name = "HDA ATI HDMI at 0xcfeec000 irq 33"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:01:00.1"
                sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
                device.bus = "pci"
       = "1002"
       = "Advanced Micro Devices, Inc. [AMD/ATI]"
       = "aa20"
       = "RV635 HDMI Audio [Radeon HD 3650/3730/3750]"
                device.string = "1"
                device.description = "RV635 HDMI Audio [Radeon HD 3650/3730/3750]"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
                output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
                output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
                output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
                off: Off (priority 0, available: unknown)
        active profile: <off>
                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
                                device.icon_name = "video-display"
    index: 1
        name: <alsa_card.pci-0000_00_1b.0>
        driver: <module-alsa-card.c>
        owner module: 7
                alsa.card = "0"
                alsa.card_name = "HDA Intel"
                alsa.long_card_name = "HDA Intel at 0xfc400000 irq 31"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1b.0"
                sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                device.bus = "pci"
       = "8086"
       = "Intel Corporation"
       = "293e"
       = "82801I (ICH9 Family) HD Audio Controller"
                device.form_factor = "internal"
                device.string = "0"
                device.description = "Built-in Audio"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
                input:analog-stereo: Analog Stereo Input (priority 65, available: unknown)
                output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
                output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: unknown)
                output:analog-surround-40: Analog Surround 4.0 Output (priority 1200, available: unknown)
                output:analog-surround-40+input:analog-stereo: Analog Surround 4.0 Output + Analog Stereo Input (priority 1265, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <output:analog-stereo+input:analog-stereo>
                alsa_output.pci-0000_00_1b.0.analog-stereo/#2: Built-in Audio Analog Stereo
                alsa_input.pci-0000_00_1b.0.analog-stereo/#4: Built-in Audio Analog Stereo
                alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#5: Monitor of Built-in Audio Analog Stereo
                analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
                                device.icon_name = "audio-input-microphone"
                analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: no)
                                device.icon_name = "audio-input-microphone"
                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: unknown)
                                device.icon_name = "audio-headphones"
                analog-output-headphones-2: Headphones 2 (priority 9800, latency offset 0 usec, available: unknown)
                                device.icon_name = "audio-headphones"

I’m having a very similar problem. (no past audio issues, but all of a sudden having dual-audio through my headphones and laptop speakers)

Pulse Audio:

Alsa Output:

I’ve tried the Alsamixer adjustment, and even with the alsactl store, what seems to happen is that the Automute flag is automatically set to disable the second I unplug headphones, and does not re-enable when I plug them back in.

hardware summary for forum SEO

Studio XPS 1640

Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] RV635 HDMI Audio [Radeon HD 3650/3730/3750] [1002:aa20]
	Subsystem: Dell Device [1028:0272]

Audio Codec - IDT 92HD73C1X5

The Product ID for this audio device [0272] matches to a Linux kernel patch:

patch_sigmatel.c - sound/pci/hda/patch_sigmatel.c - Linux source code
the model name to call the patch is above the linked patch on Line 1942
{ .id = STAC_DELL_M6_DMIC, .name = "dell-m6-dmic" },

Use this command to add this kernel patch to your system

echo 'options snd_hda_intel model=dell-m6-dmic' | sudo tee -a /etc/modprobe.d/alsa-hda.conf

then reboot system to reload ALSA with the patch

that should get the system to respect the auto-mute setting in ALSA