Audio device not detected in PulseAudio after update

New issue (it was late when I updated so didn’t notice): my (unusual?) PulseAudio setup is now broken. I send audio through the Asus MB Intel audio & HDMI to a receiver, but video via NVIDIA & DP. The NVIDIA HDMI audio is normally switched off.

After the update/reboot pactl list cards no longer shows the Intel device, but it still appears in aplay -l, cat /proc/asound/cards and lpsci -v|grep Audio. I can play files using aplay. I’ve tried a cold boot, but the card is ignored by pulse.

Is there some way to get pulse to re-scan for cards? The Arch wiki doesn’t have much to say about this exactly & every question I’ve seen so far involves either someone installing some other device or laptops that required some kernel voodoo. Unfortunately(?) this setup has been stable for quite a few years so I’m a little vague about how it was setup, but there’s nothing exotic I can see in the pulse config files and resetting to default doesn’t help.

Edit: I’ve managed to force Pulse to use the device with a load-module module-alsa-sink device= line, but it still doesn’t appear as a card.

1 Like

Im not updated yet, but do you have pavucontrol-qt installed?

It may helps to gain control back from your Soundcards.

pavucontrol is useless because PulseAudio doesn’t recognize the ‘card’ anymore, so it doesn’t appear in pavucontrol at all.

Please post more information about devices detected in ALSA

sudo --upload

and more information about PulseAudio configuration

pacmd dump; pulseaudio --dump conf; systemctl --user -l no-pager status pulseaudio.service

I had removed all pulseaudio configuration, but it made no difference, so there wouldn’t have been much point in posting a config I wasn’t using.

I took the opportunity to install pipewire and everything has been working fine since.

This wasn’t as straightforward as I’d hoped ( :: removing jack2 breaks dependency 'jack2=1.9.19' required by lib32-jack2Thread) but I got there.

remove jack2 before installing pipewire-jack. that’s it :v:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.