Audio delays for participants in MS Teams after Manjaro Update beginning of last week

Hi all.

Since 1 week, participants of MS Teams hear themselves delayed with an echo in meetings. The issue has started after an big update update of Manjaro (around the 15th of July). The latest update (22nd of July) could not fix it. Before the update, everything worked fine and I could use the official Teams app without any problems.

Is this issue related to Manjaro (maybe audio drivers) or with MS Teams.

I’m also using VMWare with Windows 11 installed. When I use there my audio interface and microphone as passthrough USB, everything works fine. When I switch back to Manjaro, the delay for participants is back.

Any idea? Thanks for your support.



This program is just really bad.

I’ve had the best experience in Chrome directly rather than this bloat of electron.

A few weeks ago I tested all the different MS Teams packages (repositories and AUR) available. Reason: job interviews. It needed to just work. Flawlessly.

Most of them didn’t work well: some use a browser wrapper and load the web version, which means you will always get the question to “get the app” or “open in the app instead”, even though you are already in an app.

This leads to a user getting confused, especially with the login process (repeats each time). In most cases it simply impossible to join a session from a weblink due to strange loops.

The “official” app for Linux is extremely limited and does not provide a good experience. And the web version for Firefox is not stable yet (mic works, camera fails on multiple devices).

The very best experience that allowed me to use most features: remove all MS Teams apps you ever installed, install MS-Edge-stable-bin (AUR) and go to teams, set it as start page.

I do not expect MS to ever build a proper app for Linux, but they do put in lots of effort to make it work flawlessly in MS Edge.

I only use Edge for Teams, nothing else. It’s the only thing that allows me to join sessions flawlessly with perfectly working mic and camera. As soon as MS fixes their camera issues with Firefox, I hope to only use Edge as backup.

1 Like

I have the same issue when I use Chrome directly. That’s crazy.

Thanks for your feedback. I will try Edge and come back to you with my results.

You could switch to pipewire which might work better.

Are you using any audio improvements like noise canceling, compressors or other audio setup? Or is it Bluetooth?

That’s also a good idea. No bluetooth. I’m using the Steinberg UR44 and the mic of the Aukey webcam. Worked super smooth 2 weeks ago. Super crazy… from one day to another I have these issues.

Pulseaudio or pipewire?

Try pipewire with pamac install manjaro-pipewire

Same issue in Edge. I can also see that the video of the participants is not in sync with the voice. Which maybe results in the echo. So crazy.

It seams that the move to pipewire solved the issue. Echo is gone and the video and sound is synchronized again. Why is pipewire better than pulseaudio?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.