Audio Delay while using external sound interface

A while ago I started to have a sound delay, whenever I use my audio interface (Behringer U-Phoria UMC204HD), which was not there when I set up Manjaro KDE last year.
Whenever I play a video, the sound is usually between 300ms and 500ms behind. However, using the onboard sound card of my motherboard (ROG STRIX X570-E) the audio is completely fine.

This is the output of often requested commands in similar forum posts:

inxi -Fxxxz
inxi -Fxxxz                                                                                                                                                                                         
System:
  Kernel: 5.15.84-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-E GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 3604
    date: 04/14/2021
CPU:
  Info: 12-core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP smt: enabled
    arch: Zen 3 rev: 0 cache: L1: 768 KiB L2: 6 MiB L3: 64 MiB
  Speed (MHz): avg: 2928 high: 3764 min/max: 2200/4950 boost: enabled cores:
    1: 2872 2: 2878 3: 2739 4: 3679 5: 2876 6: 2991 7: 2267 8: 2879 9: 2878
    10: 2872 11: 2830 12: 2851 13: 2878 14: 2879 15: 2881 16: 3579 17: 2879
    18: 2735 19: 3764 20: 2872 21: 2893 22: 2554 23: 2877 24: 2876
    bogomips: 177656
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GA102 [GeForce RTX 3080] driver: nvidia v: 525.60.11
    arch: Ampere pcie: speed: 5 GT/s lanes: 16 bus-ID: 0b:00.0
    chip-ID: 10de:2206 class-ID: 0300
  Device-2: Logitech StreamCam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-2:2
    chip-ID: 046d:0893 class-ID: 0300 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 108 s-size: 1054x342mm (41.50x13.46")
    s-diag: 1108mm (43.63")
  Monitor-1: DP-0 pos: primary,top-right res: 2560x1440 hz: 144 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  Monitor-2: HDMI-0 pos: bottom-l res: 1920x1080 hz: 60 dpi: 92
    size: 531x298mm (20.91x11.73") diag: 609mm (23.97") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce RTX
    3080/PCIe/SSE2 direct render: Yes
Audio:
  Device-1: NVIDIA GA102 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: bus-ID: 1-3:2 speed: 16 GT/s chip-ID: 1397:0508 lanes: 16
    class-ID: fe01 bus-ID: 0b:00.1 chip-ID: 10de:1aef class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 0d:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: BEHRINGER GmbH UMC204HD 192k type: USB driver: snd-usb-audio
  Device-4: Logitech StreamCam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-2:2
    chip-ID: 046d:0893 class-ID: 0300 serial: <filter>
  Sound API: ALSA v: k5.15.84-1-MANJARO running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: speed: 5 GT/s
    lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: speed: 5 GT/s lanes: 1 port: e000 bus-ID: 06:00.0 chip-ID: 10ec:8125
    class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
  Device-3: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 07:00.0 chip-ID: 8086:1539
    class-ID: 0200
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-6:4
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:
  Local Storage: total: 2.27 TiB used: 702.98 GiB (30.2%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 500GB
    size: 465.76 GiB speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QGXA7 temp: 50.9 C scheme: GPT
  ID-2: /dev/nvme1n1 vendor: Crucial model: CT1000P2SSD8 size: 931.51 GiB
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P2CR033
    temp: 48.9 C scheme: GPT
  ID-3: /dev/sda type: USB vendor: Toshiba model: MQ01ABD100
    size: 931.51 GiB type: HDD rpm: 5400 serial: <filter> scheme: MBR
Partition:
  ID-1: / size: 457.09 GiB used: 276.82 GiB (60.6%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 42.4 C mobo: N/A gpu: nvidia temp: 56 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 473 Uptime: 3h 13m wakeups: 0 Memory: 31.25 GiB
  used: 7.28 GiB (23.3%) Init: systemd v: 252 default: graphical Compilers:
  gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: pm: pacman pkgs: 2147 Shell: Zsh
  v: 5.9 running-in: yakuake inxi: 3.3.24
pulseaudio --dump-conf
pulseaudio --dump-conf                                                                                                                                                                            
### Read from configuration file: /home/huebner/.pulse//daemon.conf ###
daemonize = no
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
local-server-type = user
cpu-limit = no
enable-shm = yes
flat-volumes = no
rescue-streams = yes
lock-memory = no
exit-idle-time = -1
scache-idle-time = 20
dl-search-path = /usr/lib/pulseaudio/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = 
log-level = notice
resample-method = auto
avoid-resampling = no
enable-remixing = yes
remixing-use-all-sink-channels = yes
remixing-produce-lfe = no
remixing-consume-lfe = no
lfe-crossover-freq = 0
default-sample-format = float32le
default-sample-rate = 44100
alternate-sample-rate = 48000
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 4
default-fragment-size-msec = 25
enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 8000
deferred-volume-extra-delay-usec = 0
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = -1
pacmd dump
pacmd dump                                                                                                                                                                                          
### Configuration dump generated at Wed Dec 21 16:37:08 2022

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="2" name="usb-BEHRINGER_UMC204HD_192k-00" card_name="alsa_card.usb-BEHRINGER_UMC204HD_192k-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="3" name="usb-046d_Logitech_StreamCam_C1872F45-02" card_name="alsa_card.usb-046d_Logitech_StreamCam_C1872F45-02" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="0" name="pci-0000_0b_00.1" card_name="alsa_card.pci-0000_0b_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="1" name="pci-0000_0d_00.4" card_name="alsa_card.pci-0000_0d_00.4" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-cli-protocol-unix

set-sink-volume alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_2_3__sink 0x10000
set-sink-mute alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_2_3__sink no
suspend-sink alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_2_3__sink yes
set-sink-volume alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink 0x10000
set-sink-mute alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink no
suspend-sink alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink yes
set-sink-volume alsa_output.pci-0000_0b_00.1.hdmi-stereo 0x10000
set-sink-mute alsa_output.pci-0000_0b_00.1.hdmi-stereo no
suspend-sink alsa_output.pci-0000_0b_00.1.hdmi-stereo yes
set-sink-volume alsa_output.pci-0000_0d_00.4.iec958-stereo 0x10000
set-sink-mute alsa_output.pci-0000_0d_00.4.iec958-stereo no
suspend-sink alsa_output.pci-0000_0d_00.4.iec958-stereo yes

set-source-volume alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_2_3__sink.monitor 0x10000
set-source-mute alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_2_3__sink.monitor no
suspend-source alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_2_3__sink.monitor yes
set-source-volume alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink.monitor 0x10000
set-source-mute alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink.monitor no
suspend-source alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink.monitor yes
set-source-volume alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_1__source 0x10000
set-source-mute alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_1__source no
suspend-source alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_1__source yes
set-source-volume alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_0__source 0x10000
set-source-mute alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_0__source no
suspend-source alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_0__source yes
set-source-volume alsa_input.usb-046d_Logitech_StreamCam_C1872F45-02.analog-stereo 0xfffc
set-source-mute alsa_input.usb-046d_Logitech_StreamCam_C1872F45-02.analog-stereo no
suspend-source alsa_input.usb-046d_Logitech_StreamCam_C1872F45-02.analog-stereo yes
set-source-volume alsa_output.pci-0000_0b_00.1.hdmi-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_0b_00.1.hdmi-stereo.monitor no
suspend-source alsa_output.pci-0000_0b_00.1.hdmi-stereo.monitor yes
set-source-volume alsa_input.pci-0000_0d_00.4.analog-stereo 0x10000
set-source-mute alsa_input.pci-0000_0d_00.4.analog-stereo no
suspend-source alsa_input.pci-0000_0d_00.4.analog-stereo yes
set-source-volume alsa_output.pci-0000_0d_00.4.iec958-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_0d_00.4.iec958-stereo.monitor no
suspend-source alsa_output.pci-0000_0d_00.4.iec958-stereo.monitor yes

set-card-profile alsa_card.usb-BEHRINGER_UMC204HD_192k-00 HiFi
set-card-profile alsa_card.usb-046d_Logitech_StreamCam_C1872F45-02 input:analog-stereo
set-card-profile alsa_card.pci-0000_0b_00.1 output:hdmi-stereo
set-card-profile alsa_card.pci-0000_0d_00.4 output:iec958-stereo+input:analog-stereo

set-default-sink alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink
set-default-source alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_0__source

### EOF
pacmd list-cards
pacmd list-cards                                                                                                                                                                                    
4 card(s) available.
    index: 0
        name: <alsa_card.usb-BEHRINGER_UMC204HD_192k-00>
        driver: <module-alsa-card.c>
        owner module: 6
        properties:
                alsa.card = "2"
                alsa.card_name = "UMC204HD 192k"
                alsa.long_card_name = "BEHRINGER UMC204HD 192k at usb-0000:08:00.1-3, high speed"
                alsa.driver_name = "snd_usb_audio"
                device.bus_path = "pci-0000:08:00.1-usb-0:3:1.0"
                sysfs.path = "/devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:08:00.1/usb1/1-3/1-3:1.0/sound/card2"
                udev.id = "usb-BEHRINGER_UMC204HD_192k-00"
                device.bus = "usb"
                device.vendor.id = "1397"
                device.vendor.name = "BEHRINGER International GmbH"
                device.product.id = "0508"
                device.product.name = "UMC204HD 192k"
                device.serial = "BEHRINGER_UMC204HD_192k"
                device.string = "2"
                device.description = "UMC204HD 192k"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-usb"
        profiles:
                Direct: Direct UMC204HD 192k (priority 1, available: unknown)
                HiFi: Default (priority 8000, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <HiFi>
        sinks:
                alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_2_3__sink/#0: UMC204HD 192k Line B
                alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink/#1: UMC204HD 192k Line A
        sources:
                alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_2_3__sink.monitor/#0: Monitor of UMC204HD 192k Line B
                alsa_output.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_stereo_out_U192k_0_0_1__sink.monitor/#1: Monitor of UMC204HD 192k Line A
                alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_1__source/#2: UMC204HD 192k Input 2
                alsa_input.usb-BEHRINGER_UMC204HD_192k-00.HiFi__umc204hd_mono_in_U192k_0_0__source/#3: UMC204HD 192k Input 1
        ports:
                [Out] Direct: Direct UMC204HD 192k (priority 1000, latency offset 0 usec, available: unknown)
                        properties:

                [In] Direct: Direct UMC204HD 192k (priority 1000, latency offset 0 usec, available: unknown)
                        properties:

                [Out] Line2: Line B (priority 100, latency offset 0 usec, available: unknown)
                        properties:

                [Out] Line1: Line A (priority 200, latency offset 0 usec, available: unknown)
                        properties:

                [In] Mic2: Input 2 (priority 100, latency offset 0 usec, available: unknown)
                        properties:

                [In] Mic1: Input 1 (priority 200, latency offset 0 usec, available: unknown)
                        properties:

    index: 1
        name: <alsa_card.usb-046d_Logitech_StreamCam_C1872F45-02>
        driver: <module-alsa-card.c>
        owner module: 7
        properties:
                alsa.card = "3"
                alsa.card_name = "Logitech StreamCam"
                alsa.long_card_name = "Logitech StreamCam at usb-0000:08:00.1-2, super speed"
                alsa.driver_name = "snd_usb_audio"
                device.bus_path = "pci-0000:08:00.1-usb-0:2:1.2"
                sysfs.path = "/devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:08:00.1/usb2/2-2/2-2:1.2/sound/card3"
                udev.id = "usb-046d_Logitech_StreamCam_C1872F45-02"
                device.bus = "usb"
                device.vendor.id = "046d"
                device.vendor.name = "Logitech, Inc."
                device.product.id = "0893"
                device.product.name = "StreamCam"
                device.serial = "046d_Logitech_StreamCam_C1872F45"
                device.form_factor = "webcam"
                device.string = "3"
                device.description = "StreamCam"
                module-udev-detect.discovered = "1"
                device.icon_name = "camera-web-usb"
        profiles:
                input:analog-stereo: Analog Stereo Input (priority 65, available: unknown)
                input:iec958-stereo: Digital Stereo (IEC958) Input (priority 55, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <input:analog-stereo>
        sources:
                alsa_input.usb-046d_Logitech_StreamCam_C1872F45-02.analog-stereo/#4: StreamCam Analog Stereo
        ports:
                analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-input-microphone"
                iec958-stereo-input: Digital Input (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:

    index: 2
        name: <alsa_card.pci-0000_0b_00.1>
        driver: <module-alsa-card.c>
        owner module: 8
        properties:
                alsa.card = "0"
                alsa.card_name = "HDA NVidia"
                alsa.long_card_name = "HDA NVidia at 0xfc080000 irq 131"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:0b:00.1"
                sysfs.path = "/devices/pci0000:00/0000:00:03.1/0000:0b:00.1/sound/card0"
                device.bus = "pci"
                device.vendor.id = "10de"
                device.vendor.name = "NVIDIA Corporation"
                device.product.id = "1aef"
                device.product.name = "GA102 High Definition Audio Controller"
                device.string = "0"
                device.description = "GA102 High Definition Audio Controller"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 38668, available: unknown)
                output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 38468, available: unknown)
                output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
                output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
                output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
                output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
                output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
                output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-stereo-extra5: Digital Stereo (HDMI 6) Output (priority 5700, available: no)
                output:hdmi-surround-extra5: Digital Surround 5.1 (HDMI 6) Output (priority 600, available: no)
                output:hdmi-surround71-extra5: Digital Surround 7.1 (HDMI 6) Output (priority 600, available: no)
                output:hdmi-stereo-extra6: Digital Stereo (HDMI 7) Output (priority 5700, available: no)
                output:hdmi-surround-extra6: Digital Surround 5.1 (HDMI 7) Output (priority 600, available: no)
                output:hdmi-surround71-extra6: Digital Surround 7.1 (HDMI 7) Output (priority 600, available: no)
                off: Off (priority 0, available: unknown)
        active profile: <output:hdmi-stereo>
        sinks:
                alsa_output.pci-0000_0b_00.1.hdmi-stereo/#2: GA102 High Definition Audio Controller Digital Stereo (HDMI)
        sources:
                alsa_output.pci-0000_0b_00.1.hdmi-stereo.monitor/#5: Monitor of GA102 High Definition Audio Controller Digital Stereo (HDMI)
        ports:
                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "video-display"
                                device.product.name = "BenQ GL2450H
"
                hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "video-display"
                                device.product.name = "LG ULTRAGEAR
"
                hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-5: HDMI / DisplayPort 6 (priority 5400, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-6: HDMI / DisplayPort 7 (priority 5300, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
    index: 3
        name: <alsa_card.pci-0000_0d_00.4>
        driver: <module-alsa-card.c>
        owner module: 9
        properties:
                alsa.card = "1"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xfcc00000 irq 133"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:0d:00.4"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:0d:00.4/sound/card1"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "1487"
                device.product.name = "Starship/Matisse HD Audio Controller"
                device.string = "1"
                device.description = "Starship/Matisse HD Audio Controller"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                input:analog-stereo: Analog Stereo Input (priority 65, available: no)
                output:analog-stereo: Analog Stereo Output (priority 6500, available: no)
                output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: no)
                output:analog-surround-21: Analog Surround 2.1 Output (priority 1300, available: no)
                output:analog-surround-21+input:analog-stereo: Analog Surround 2.1 Output + Analog Stereo Input (priority 1365, available: no)
                output:analog-surround-40: Analog Surround 4.0 Output (priority 1200, available: no)
                output:analog-surround-40+input:analog-stereo: Analog Surround 4.0 Output + Analog Stereo Input (priority 1265, available: no)
                output:analog-surround-41: Analog Surround 4.1 Output (priority 1300, available: no)
                output:analog-surround-41+input:analog-stereo: Analog Surround 4.1 Output + Analog Stereo Input (priority 1365, available: no)
                output:analog-surround-50: Analog Surround 5.0 Output (priority 1200, available: no)
                output:analog-surround-50+input:analog-stereo: Analog Surround 5.0 Output + Analog Stereo Input (priority 1265, available: no)
                output:analog-surround-51: Analog Surround 5.1 Output (priority 1300, available: no)
                output:analog-surround-51+input:analog-stereo: Analog Surround 5.1 Output + Analog Stereo Input (priority 1365, available: no)
                output:iec958-stereo: Digital Stereo (IEC958) Output (priority 38268, available: unknown)
                output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (priority 5565, available: unknown)
                output:iec958-ac3-surround-51: Digital Surround 5.1 (IEC958/AC3) Output (priority 300, available: unknown)
                output:iec958-ac3-surround-51+input:analog-stereo: Digital Surround 5.1 (IEC958/AC3) Output + Analog Stereo Input (priority 365, available: no)
                off: Off (priority 0, available: unknown)
        active profile: <output:iec958-stereo+input:analog-stereo>
        sinks:
                alsa_output.pci-0000_0d_00.4.iec958-stereo/#4: Starship/Matisse HD Audio Controller Digital Stereo (IEC958)
        sources:
                alsa_input.pci-0000_0d_00.4.analog-stereo/#7: Starship/Matisse HD Audio Controller Analog Stereo
                alsa_output.pci-0000_0d_00.4.iec958-stereo.monitor/#8: Monitor of Starship/Matisse HD Audio Controller Digital Stereo (IEC958)
        ports:
                analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
                        properties:

                analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
                        properties:

                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
                iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:

I researched about that issue and have been able to identify problems after applying the suggestion given in a related post on this forum (Not allowed to post links but title of post is ‘Audio mini-stop bug’).

After the following steps, the audio delay will be temporarily gone:

  1. Boot System with Headphones plugged into onboard audio controller (and nothing in the external interface)
  2. Plug Headphones from onboard to external interface.
  3. Execute pacmd unload-module module-suspend-on-idle

Playing audio immediately after this command will be in-sync. However, stopping the audio for only a very short amount of time will bring the delay back. So far I could not get it to work again, without having to reboot.
I also tried to disable the suspend-on-idle-module permanently in the config as shown in the linked post, with no success. Booting with the headphones already plugged into the external sound interface will also not work.

Obviously the current solution is not practical and I am forced to use the onboard sound card at the moment. Any idea what the issues might be? I think it might be pulseaudio related (hence the tag) but I’am by no means an expert.
Please let me know if you need further information.