Audio decoder doesn't seem to work

I wanted to use hardware acceleration on Google Chrome, so I followed several tips such as arch wiki’s hardware acceleration article and howto tips on the forum. However, I must do something wrong — videos with audio does not play; both for videos on web and videos in my computer. If I mute the audio or turn off the audio track then the video plays very well. That’s why I think this is an audio decoder problem.

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.17.6-2-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600 6-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1080/PCIe/SSE2

The graphics driver is nonfree NVIDIA driver installed with MHWD.

provide formated output from: inxi -Fazy
and did you checked this link:

  Kernel: 5.17.6-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
    root=UUID=f91c67e7-fb6a-46b5-93b2-1ce147feda0a rw quiet apparmor=1
    security=apparmor udev.log_priority=3 nvidia-drm.modeset=1
  Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux
    base: Arch Linux
  Type: Desktop Mobo: ASRock model: B450M Steel Legend serial: <filter>
    UEFI: American Megatrends v: P2.90 date: 11/27/2019
  Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Device-2: hidpp_battery_1
    model: Logitech G304 Lightspeed Wireless Gaming Mouse serial: <filter>
    charge: 100% (should be ignored) rechargeable: yes status: discharging
  Info: model: AMD Ryzen 5 3600 socket: AM4 bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2433 high: 3600 min/max: 2200/4208 boost: enabled
    base/boost: 3600/4200 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 3600 2: 2200 3: 2200 4: 2200
    5: 2200 6: 2200 7: 3600 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
    bogomips: 86268
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia
    v: 510.68.02 alternate: nouveau,nvidia_drm pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none
    off: DP-1,DP-3 empty: DP-2,DVI-D-1,HDMI-A-1 bus-ID: 07:00.0
    chip-ID: 10de:1b80 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.73x11.85")
    s-diag: 1102mm (43.38")
  Monitor-1: DP-1 mapped: DP-0 note: disabled pos: right model: Dell U2414H
    serial: <filter> built: 2015 res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  Monitor-2: not-matched mapped: DP-4 pos: primary,left res: 1920x1080
    hz: 60 dpi: 93 size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
  Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 07:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.6-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: br-a6cbac740942 state: down mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-3:3 chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 931.52 GiB used: 115.93 GiB (12.4%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 32.9 C scheme: GPT
  SMART: yes health: PASSED on: 5d 6h cycles: 959
    read-units: 5,173,127 [2.64 TB] written-units: 3,659,174 [1.87 TB]
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD4
    family: Micron Client SSDs size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B sata: 3.3 speed: 6.0 Gb/s type: SSD serial: <filter>
    rev: 023 temp: 41 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 113d 12h cycles: 1178
    written: 12.69 TiB
  ID-1: / raw-size: 200.88 GiB size: 196.67 GiB (97.90%)
    used: 115.9 GiB (58.9%) fs: ext4 block-size: 4096 B dev: /dev/sda6
    maj-min: 8:6
  ID-2: /boot/efi raw-size: 99 MiB size: 95 MiB (95.96%)
    used: 27.7 MiB (29.2%) fs: vfat block-size: 512 B dev: /dev/sda2
    maj-min: 8:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda7 maj-min: 8:7
  System Temperatures: cpu: 38.5 C mobo: 37.0 C gpu: nvidia temp: 48 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 1664 fan-3: 0 fan-4: 897 fan-5: 0
    gpu: nvidia fan: 21%
  Power: 12v: N/A 5v: N/A 3.3v: 3.31 vbat: 3.26
  Processes: 319 Uptime: 37m wakeups: 6 Memory: 31.28 GiB
  used: 3.81 GiB (12.2%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1723 lib: 423 flatpak: 0
  Shell: Zsh (sudo) v: 5.8.1 default: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.15

I followed that tutorial to enable the hardware acceleration, but removing created Chrome config file does not solve this problem.

so play a video on your pc and check logs for some possible hints with ksystemlog app
also try running chrome from terminal and play a video and check in terminal

Double click to play a video on my pc makes the following logs:

22. 5. 12. 오전 5:25	plasmashell	kf.kio.core: The recently-used.xbel is not an XBEL file, overwriting.
22. 5. 12. 오전 5:25	kwin_x11	qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 56442, resource id: 39846055, major code: 18 (ChangeProperty), minor code: 0
22. 5. 12. 오전 5:25	systemd	Started mpv Media Player - Multimedia player.
22. 5. 12. 오전 5:26	kernel	[UFW BLOCK] IN=enp5s0 OUT= MAC=01:00:5e:00:00:01:88:36:6c:1b:93:ac:08:00 SRC= DST= LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=58827 DF PROTO=2 

Playing a video on Chrome does not make any message in the terminal.

And I found an interesting fact that pulseaudio -k temporarily solves the problem but only for currently focusing window or Chrome tab.

nothing in logs… also noticed, what kind of a kernel are you running, latest in manjaro stable is 5.17.1-3 …

I use 5.17.6-2-MANJARO (64-bit)

yes i can see that, but are you on stable branch? did you downloaded the kernel from system settings/ kernels … you could try switching to 5.15 LTS kernel… also you could install pipewire by installing manjaro-pipewire package… if you get any pulse dependencies, uninstall them first, install pipewire, reboot and check audio

Yes I downloaded kernel from System Settings and am on unstable branch. I’ll try pipewire

manjaro-pipewire works perfectly! Thank you for your advice.

you can try this to completely get rid of pulseaudio :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.