Attempting to Setup TP-Link Archer T3U Plus, Discovered USB Not Working (!) [SOLVED, (with T3U Driver Info)]

Relative newbie here. I was looking around the forums looking for a solution to setting up my new Archer T3U Plus and nothing was working. Getting ready to post and ask for help, I noticed that my inxi output showed:

  Message: No USB data found. Server? 

Confused, I checked to see if my laptop could even see my new wifi dongle at all:

[zak@server47 ~]$ lsusb
lsusb: error while loading shared libraries: wrong ELF class: ELFCLASS32

Checking around again, I could see that this problem pops up in relation to installing certain pieces of software, and so the fix usually involves tweaking that software installation process. But that’s not what I’m doing, my usb just seems to have blinked out on me, so, I’m not sure what to do — help!

[zak@server47 ~]$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.10.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=aeb29178-6fae-4767-924e-fe86c54b9abc rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 usbcore.autosuspend=-1 
  Desktop: Budgie 10.5.3 info: budgie-panel wm: budgie-wm dm: LightDM 1.30.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Acer product: Aspire E5-576G v: V1.49 serial: <filter> 
  Mobo: KBL model: Ironman_SK v: V1.49 serial: <filter> UEFI: Insyde v: 1.49 
  date: 12/11/2018 
  ID-1: BAT1 charge: 35.8 Wh (100.0%) condition: 35.8/62.2 Wh (57.7%) 
  volts: 12.6 min: 11.1 model: PANASONIC AS16B5J type: Li-ion serial: <filter> 
  status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse B330/M330/M331 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  RAM: total: 7.65 GiB used: 2.25 GiB (29.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: EA cache: L2: 6 MiB bogomips: 28808 
  Speed: 646 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 646 2: 653 3: 648 
  4: 647 5: 651 6: 638 7: 638 8: 650 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300 
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1d10 class-ID: 0302 
  Display: x11 server: 1.20.13 compositor: budgie-wm driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.6 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d71 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.59-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
  v: kernel port: 4000 bus-ID: 03:00.0 chip-ID: 8086:24fb class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus-ID: 04:00.1 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp4s0f1 state: down mac: <filter> 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 238.47 GiB used: 76.43 GiB (32.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Micron model: 1100 MTFDDAV256TBN 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: A020 scheme: GPT 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GUE1N rev: 1.00 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 78.12 GiB size: 76.35 GiB (97.73%) used: 25.88 GiB (33.9%) 
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: aeb29178-6fae-4767-924e-fe86c54b9abc 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: C206-C2A6 
  ID-3: /home raw-size: 151.25 GiB size: 147.87 GiB (97.77%) 
  used: 50.55 GiB (34.2%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 label: N/A 
  uuid: e28ae277-227a-4c04-97c3-e674637f1bd4 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 8d995362-9998-40cd-8fe5-76c32fca21ad 
  Message: No unmounted partitions found. 
  Message: No USB data found. Server? 
  System Temperatures: cpu: 44.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 278 Uptime: 12m wakeups: 3 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: 1421 pacman: 1407 lib: 336 snap: 14 
  Shell: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.06 

This should not be necessary - Manjaro uses tlp

I understand the confusion - care to explain how did that happen on a 64-bit system?

It would be interesting to see the pacman.log - could you post the log on a pastebin site? It is easily done using e.g. the package pastebinit then do

pastebinit -b -i /var/log/pacman.log

Ok, I fixed the usbcore.autosuspend, thank you.

Not sure how I got for a 32 bit system…how do I fix that?

And here’s my pacman.log that you asked for.

Thanks for the help!

TL:DR - > Reinstall the package

As one would think that libusb would be something found on every system - I checked the databases - using pacman -F libusb - and there is no trace of libusb.

Then I checked your pacman.log → no trace either (because the pacman.log is your log - not the ISO log) - the package is registered in the file /rootfs-pkgs.txt

Then I checked Package - libusb - Discover Packages On Manjaro Linux → libusb is v1.0.24-2

Then I tried this and this shows the package content

pacman -Fl libusb

Then a check on the file

➜  ~ file /usr/lib/
/usr/lib/ symbolic link to
➜  ~ file /usr/lib/ 
/usr/lib/ ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=a06af3fb394423604e1ab1e0c6d7e85c228ffce1, stripped

It seems the discover site is slightly out of sync with branch-compare - I think that is going to adjust itself at some point @codesardine

  • branch-compare has v1.0.24-2
  • discover has v1.0.23-2

I did a libusb reinstall, and it worked – my USB is back – thank you!

For anyone interested, I was then able to get my TP-Link Archer T3U Plus working by installing the rtl88x2bu-dkms-git driver from the AUR repos. I also installed dkms (of course) & the linux headers for my kernel. I did a reboot and the T3U was recognized.

I’d also like to share a link to this archived post on how to identify the driver you need and go about installing it. The OP is right that it too often happens that we newbies will willy-nilly try different methods from old posts without checking our hardware/system first (Lord knows I have). But I know I’ll be following the advice in this post from now on. :wink:

Thanks again for the USB help, @linux-aarhus!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.