ASUS X751N laptop: touchpad lost


Manjaro KDE, just installed. Kernel 6.5.5-1. Touchpad works with BIOS screen, but no further. KDE System Settings > Input Devices > Touchpad just says No touchpad found. There’s a number of similar questions on this forum, but all of them look very model-specific, mostly solved by kernel update.

I’ve found a number of articles on boot options, like this and this. To me, it boils down to the simple message that you should know beforehand the magic words to add to
the GRUB_CMDLINE_LINUX_DEFAULT variable in /etc/default/grub. I tried to add acpi_osi=Linux, nothing changed. Now it looks like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux ... "

What do I have to do?

Have you read this already?

1 Like

Yes, I did. I discovered the F9 key which indeed shows a crossed touchpad sign. it doesn’t change anything. Otherwise the ASUS support article talks only about Windows, unless I miss something. xinput list doesn’t show any touchpad. KDE System Settings also can’t see any touchpad, disabled or no. I also tried to check BIOS, but I couldn’t find any mention of touchpad there.

The kernel upgraded to 6.6.0, no difference.

The laptop is at least five years old. Shouldn’t be a kernel problem.