ASUS FA506IV AMD integrated graphics with Nvidia 2060 hybrid

Hi everyone, I have an issue with my recently purchased laptop that is using the hybrid combo AMD iGPU and Nvidia dGPU. I have installed the proprietary drivers and the HDMI port is working with AMD graphic card and I tried to connect another monitor through the Displayport USB Type C which is supposedly to work with the Nvidia dGPU (this laptop only works with iGPU on the HDMI and dGPU on the Displayport Type C) but I only get a black screen. The system recognize the monitor but there is no image, Any idea about this? sorry I’m kind of noob with this type of setup.

this is the output of the glxinfo -B

name of display: :1
display: :1 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: X.Org (0x1002)
Device: AMD RENOIR (DRM 3.38.0, 5.8.16-2-MANJARO, LLVM 10.0.1) (0x1636)
Version: 20.1.8
Accelerated: yes
Video memory: 512MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 4.6
Max compat profile version: 4.6
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.2
Memory info (GL_ATI_meminfo):
VBO free memory - total: 164 MB, largest block: 164 MB
VBO free aux. memory - total: 2556 MB, largest block: 2556 MB
Texture free memory - total: 164 MB, largest block: 164 MB
Texture free aux. memory - total: 2556 MB, largest block: 2556 MB
Renderbuffer free memory - total: 164 MB, largest block: 164 MB
Renderbuffer free aux. memory - total: 2556 MB, largest block: 2556 MB
Memory info (GL_NVX_gpu_memory_info):
Dedicated video memory: 512 MB
Total available memory: 3584 MB
Currently available dedicated video memory: 164 MB
OpenGL vendor string: X.Org
OpenGL renderer string: AMD RENOIR (DRM 3.38.0, 5.8.16-2-MANJARO, LLVM 10.0.1)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.1.8
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.1.8
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.1.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20


Because of limitations in the current nvidia driver, the only way to get that output working is to run the X server on the nvidia gpu. For that, I suggest you install optimus-manager. The guide is dated, so please ignore the

So if you have AMD-Nvidia, stop reading futher as the guide below is only for Intel-Nvidia and you don’t need any of this.

part. Furthermore, you should install optimus-manager-git, not simply optimus-manager since only the git version supports AMD integrated chips at the moment (pamac build optimus-manager-git). The second step can be entirely ignored since you don’t have intel+nvidia configuration, and you also probably don’t have bumblebee installed.

After successful installation, and after running optimus-manager --switch nvidia, you should be able to access all outputs.

Hey pobrn, thanks for the reply, I tried what you suggested but, it’s working kinda glitchy since it works sometimes and other it doesn’t so now I’m looking to disable the entire Nvidia as I won’t be playing video games on this OS and it’s consuming a lot of power even the Nvidia card is not being used.

If you’re lucky, D3 power management might work. Please confirm that the file /etc/modprobe.d/mhwd-gpu.conf exists, and contains the line options nvidia "NVreg_DynamicPowerManagement=0x02", check if /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules exists as well. Then either leave optimus-manager in “hybrid” mode or remove it altogether. After that, confirm that nvidia-smi shows only Xorg in the list of processes that use the GPU. Then wait some time, and run cat "/sys/bus/pci/devices/<PCI bus ID of the nvidia GPU>/power/runtime_status", if it says “suspended”, then the GPU should consume little to no energy.

If that doesn’t work, you could try bbswitch.

Thanks for the quick reply, I have checked and it was already set up in that way, In fact I tried that before your reply and with the steps you provided me, I can see that is already applied but it remains “active” on the runtime_status. Should I uninstall Nvidia drivers instead? I was working with the laptop before installing the Nvidia drivers and I had almost 4 hrs of battery life but I was having issues with Chrome and Brave browser running laggy with wayland session so I thought it was the Nvidia drivers missing so I installed them (after I tried the optimus-manager I did a clean installation without installing the nvidia drivers) but since it enabled Xorg, I was able to identify that the actual issue was Wayland and after I installed the Nvidia drivers the battery life is now 2 hours. I guess the problem is that the Nvidia gpu is connected to the USB type C keeping it active, but base on the Nvidia documentation it will cause to disable the sound on the HDMI and Type C ports apply the work around, that is why I’m asking if it will be better to uninstall the Nvidia drivers and just use the AMD gpu. Thanks!