Asrock A300 dead after AUR-Update

Hello folks,
yesterday I installed the due updates on my Asrock A300 (Ryzen 4650G, KDE, 2 x 8 GB RAM). I was also offered an update for the graphics drivers via bauh (if I remember correctly). After I finished the installation, I got severe image errors. Then I wanted to restart the computer. But it won’t boot at all - not even into the bios. The fan starts up and the LED briefly lights up orange - that’s it. I’ve already tried another CPU because I suspected it was defective. But even with a new CPU, the computer no longer starts. Could it be that the update destroyed the motherboard?

Hi @mattias,

Although nothing is impossible, I highly doubt it. Not that the motherboard is toast - I mean you mentioned it doesn’t even load the BIOS/UEFI - but that it was the update was the cause.

Have you already tried to reset the bios on the motherboard ?

(As described in the manual ?)

I have been around computers for decades - I have never seen a computer die from an update.

It is quite possible to brick a system with a firmware update - but that is a completely different task.

I am however a bit puzzled with the following statement

If sounds an awful lot like a firmware update as AMD has kernel support for the graphics which should elimate the need to specifically update graphics.

Linux has the fwupdmgr tool. That tool is not implemented as part of neither pacman nor pamac.

Not yet, will give it a try

Disconnect Battery and cleared CMOS (Jumper) - still not working. But thanks for the hint.