[ARM Testing Update] 2024-04-24 - Plasma, KDE Gear, KDE Frameworks, Firefox, Pipewire

Hello ARM community.

We updated kernels, renewed KDE Plasma, KDE Gear and offer other related goodies for you. Pamac is now fully adaptive and we have a new release of Phosh. Systemd offers now the Blue Screen of Death!

Update Announcement

Some highlights:

  • Some Kernels got updated
    • Mostly RasberryPi 4 & 5
  • Plasma updated to 6.0.4
  • KDE Frameworks got renewed to 6.1.0
  • KDE Gear got updated to 24.02.2
  • Firefox is at 125.0.2 and Thunderbird at 115.10.1
  • Pipewire got renewed to 1.0.5

Tips And Tricks

Error about missing openssl 1.1 library

Since the update to the new OpenSSL 3.0, some applications might still be looking for version 1.1 og openssl.
Fortunately Arch Linux created a compatability package for such events called openssl-1.1.
So if you encounter any such errors, please install the above mentioned package.
Applications currently known to specifically look for 1.1 is silver. We have not been able to rebuild it yet. So if you are on our Gnome or Sway editions, please install openssl-1.1 as part of this update.

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Older notifications

The PHP package has been updated to 8.2. If you still need 8.1, use php-legacy packages.
Arch Linux - News: PHP 8.2 update and introduction of legacy branch

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss package requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package Changes (Wed Apr 24 09:23:49 CEST 2024)

  • arm-testing core aarch64: 34 new and 34 removed package(s)
  • arm-testing extra aarch64: 1216 new and 1219 removed package(s)

A full list of all package changes can be found here.

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in Testing Updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!

1 Like

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

:arrow_right: 2024-04-24

Calendar does not launch
  • If you have gnome-calendar-mobile installed, please run the following to replace it:
    • sudo pacamn -S gnome-calendar
Pinephone Pro: Phosh: App windows not rendered correctly
  • Problem: After updating gtk4 to 1:4.14.3-1, if you open an app (like settings), then go to a submenu (i.e. Mobile Network → Acess Point Names), somewhere during that process you will get either a black screen, or partially rendered windows, making the interface unusable.
  • Workaround: downgrade gtk4 to 1:4.12.5-1
Chatty >=0.8.2 No longer notifies on receiving a text message
  • Problem: Notifications are not generated on PinephonePro (bisected, issue reported upstream)
  • Workaround: make sure there is at least one contact in your contacts list, or downgrade to 0.8.1


Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon

In some cases, however it is better to keep the legacy way. Here are some examples: Dbus-broker warnings

Firefox no longer honors gtk font size settings in user interface. Solved by setting about:config browser.display.os-zoom-behavior to 0 (zero)


Pinephone Pro: Phosh: volume constantly changes
  • Problem: PKGBUILD for uboot-pinephonepro introduced a number of regressions, the most noticeable of which is constant volume changes. Issue reported here.


Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention


Display doesn't load on PinePhone Pro running KDE Plasma
  • Problem: Failed to start Simple Desktop Display Manager
  • Workaround: (none known yet)


Docker 23 not starting

Since the update to Docker 23, upstream is now inforcing new paths for apparmor related stuff. But there has been changes to dependencies yet. So Docker 23 will error on start.
Fix: Install apparmor from the repositories.


Reduced video playback performance in mpv

There has been reports of video playback performance in mpv has regressed since an update to mpv.
Fix: MPV now needs a vd-lavc-dr=no parameter to play hw acceleration supported 1080p videos smoothly.

Touch input on Firefox with Phosh not working in Firefox 108

Since the update to Firefox 108, the touch input does not work. Seems to be an issue with a couple of the changes the mobile-config brings in.
Fix Fixed in version 4.0.0-1 of mobile-config-firefox released with Manjaro testing on April 14, 2023


OpenSSL 1.1 library not found

Some applications might still be looking for openssl 1.1.
Solution: Install openssl-1.1 package with sudo pacman -S openssl-1.1.


Plasma Mobile Dialer seems to be unreliable

Plasma Dialer 22.09 seems to have issues switching audio profiles and as such might require manual switching. Sometimes audio is completely missing.

Reduced video performance on youtube

Some may encounter reduced video playback performance on YouTube in Firefox with the new Mesa 22.2 drivers.
No workaround at this time.

Old Issues

Phosh crashes when closing apps
An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Mouse cursor is slow on Raspberry Pi
Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

[Waydroid container cannot access internet
Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell

Previous testing threads:

Device: GT King Pro
DE: KDE Plasma
Kernel: linux-aml-6.1.79-1

Upgraded successfully on Unstable Branch. But still cannot boot up to Plasma-Wayland. Can boot up to Plasma-X11.

It has bee like this since updated to KDE-Plasma 6.0. Tried downgrading to Arm-Testin and also to Arm-Stable branch but unfortunately still could not boot up to Plasma-Wayland.

Would have expected when I downgrade to Stable Branch with

sudo pacman-mirrors -aS stable && sudo pacman -Syyu

With KD-Plasma 5.27.10 Plasma-Wayland should work just like before upraded to KDE Plasma-6.0 but for whatever reason it could NOT boot into Plasma-Wayland.


gnome-calendar-mobile needs to be rebuilt on both testing and unstable (@Yochanan )

chatty 0.8.2-1 and later (tested up to latest pkgbuild for 0.8.3-1) no longer generates a notification upon receiving a text message. downgrading to 0.8.1-2 works around the issue for now

I’ll rebuild it for now, however in the meantime, install gnome-calendar 46.1-2. We will be dropping the mobile version as it’s no longer necessary.

Have you checked upstream issues?

1 Like

Thanks, added instructions in wiki post for the calendar.

There were no issues upstream that I could find for that. I bisected it to this commit - will create an issue shortly.

There’s another issue I’m looking into that prevents app windows from being properly rendered. Will update the wiki as I continue down this rabbit hole…