[ARM Testing Update] 2023-09-28 - Kernels, Firefox, Thunderbird, Plasma, KDE Gear, LibreOffice, Systemd

Hello ARM community.

Archlinux ARM finalized migrating the community to extra repository.We updated kernels, KDE and other mobile related goodies for you.

Update Announcement

Some highlights:

  • Most of the Kernels got updated
  • Systemd is at 254.5
  • KDE gear got renewed to 23.08.1
  • KDE Plasma got updated to 5.27.8
  • Firefox is at 118
  • LibreOffice got renewed to 7.5.7 and 7.6.2
  • Pipewire is at 0.3.80
  • Thunderbird is at 115.2.3
  • The usual KDE-git updates which moved to Qt6

End Of Life kernels (will be removed from repo soon):

  • linux60 (EOL on 2023-01-12) (removed from repository)

Tips And Tricks

Error about missing openssl 1.1 library

Since the update to the new OpenSSL 3.0, some applications might still be looking for version 1.1 og openssl.
Fortunately Arch Linux created a compatability package for such events called openssl-1.1.
So if you encounter any such errors, please install the above mentioned package.
Applications currently known to specifically look for 1.1 is silver. We have not been able to rebuild it yet. So if you are on our Gnome or Sway editions, please install openssl-1.1 as part of this update.

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Older notifications

The PHP package has been updated to 8.2. If you still need 8.1, use php-legacy packages.
Arch Linux - News: PHP 8.2 update and introduction of legacy branch

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss package requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package Changes (Thu Sep 28 11:17:11 CEST 2023)

  • arm-testing core aarch64: 74 new and 73 removed package(s)
  • arm-testing extra aarch64: 2528 new and 2537 removed package(s)
  • arm-testing kde-unstable aarch64: 320 new and 285 removed package(s)

A full list of all package changes can be found here.

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in Testing Updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

:arrow_right: 2023-08-19

Pinephone Pro doesn't boot (fixed in latest update)
  • Problem: The Pinephone Pro will fail to boot after updating linux-pinephonepro 6.3.11-1 to 6.4.4-1
  • Workaround: Either wait for a non-broken kernel, or temporarily add linux-pinephonepro to the IgnorePkg line in /etc/pacman.conf to update the rest of the packages


Docker 23 not starting

Since the update to Docker 23, upstream is now inforcing new paths for apparmor related stuff. But there has been changes to dependencies yet. So Docker 23 will error on start.
Fix: Install apparmor from the repositories.


Ethernet and Wifi not working right on kernel 6.1.2+ on some devices

Some devices have been reported to not have properly working ethernet and wifi after the update to kernel 6.1.2 and above.
Fix: Kernel 6.1.5-2 and above should have working ethernet and wifi again.

Reduced video playback performance in mpv

There has been reports of video playback performance in mpv has regressed since an update to mpv.
Fix: MPV now needs a vd-lavc-dr=no parameter to play hw acceleration supported 1080p videos smoothly.

Touch input on Firefox with Phosh not working in Firefox 108

Since the update to Firefox 108, the touch input does not work. Seems to be an issue with a couple of the changes the mobile-config brings in.
Fix Fixed in version 4.0.0-1 of mobile-config-firefox released with Manjaro testing on April 14, 2023


OpenSSL 1.1 library not found

Some applications might still be looking for openssl 1.1.
Solution: Install openssl-1.1 package with sudo pacman -S openssl-1.1.


Firefox shows wrong colors when playing video on Raspberry Pi 4

Since Mesa 22.2, Firefox has been showing weird colors when playing video on the Raspberry Pi 4. This is caused by an issue in upstream mesa, which was recently fixed.
Fix: Update to mesa 22.2.3-0.1 in the repository, which includes this fix.

Chromium in Wayland crashes with --in-process-gpu

Since Mesa 22.2.0, Chromium running in wayland sessions seems to crash when running with the --in-process-gpu option. Running in X11 seems fine, although it’s slow.
Fix: Update to Mesa 22.3.2 was reported to work here.


Plasma Mobile Dialer seems to be unreliable

Plasma Dialer 22.09 seems to have issues switching audio profiles and as such might require manual switching. Sometimes audio is completely missing.

Reduced video performance on youtube

Some may encounter reduced video playback performance on YouTube in Firefox with the new Mesa 22.2 drivers.
No workaround at this time.

Old Issues

Phosh crashes when closing apps
An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Mouse cursor is slow on Raspberry Pi
Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

[Waydroid container cannot access internet
Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell

Some more package updates ( Sat Sep 30 04:31:22 CEST 2023 ):

:: Different sync package(s) in repository extra aarch64

                             PACKAGE           2023-09-28           2023-09-30
                        ansible-lint             6.20.0-1             6.20.1-2
                            arp-scan             1.10.0-2             1.10.0-3
                              awxkit             23.1.0-1             23.2.0-1
                          cargo-deny             0.14.2-1             0.14.3-1
                          cargo-dist              0.3.0-1              0.3.1-1
                        cargo-update             13.0.4-1             13.1.0-1
                            chromium      117.0.5938.92-2     117.0.5938.132-1
                                crun              1.9.1-1              1.9.2-1
                                dolt             1.16.5-1             1.17.1-1
                             esbuild             0.19.3-1             0.19.4-1
                           fcitx-qt5             1.2.7-15             1.2.7-16
                           fcitx-qt6             1.2.7-15             1.2.7-16
                           fcitx5-qt              5.1.0-1              5.1.0-2
                             firefox              118.0-1            118.0.1-1
                    firefox-i18n-ach              118.0-1            118.0.1-1
                     firefox-i18n-af              118.0-1            118.0.1-1
                     firefox-i18n-an              118.0-1            118.0.1-1
                     firefox-i18n-ar              118.0-1            118.0.1-1
                    firefox-i18n-ast              118.0-1            118.0.1-1
                     firefox-i18n-az              118.0-1            118.0.1-1
                     firefox-i18n-be              118.0-1            118.0.1-1
                     firefox-i18n-bg              118.0-1            118.0.1-1
                     firefox-i18n-bn              118.0-1            118.0.1-1
                     firefox-i18n-br              118.0-1            118.0.1-1
                     firefox-i18n-bs              118.0-1            118.0.1-1
                     firefox-i18n-ca              118.0-1            118.0.1-1
            firefox-i18n-ca-valencia              118.0-1            118.0.1-1
                    firefox-i18n-cak              118.0-1            118.0.1-1
                     firefox-i18n-cs              118.0-1            118.0.1-1
                     firefox-i18n-cy              118.0-1            118.0.1-1
                     firefox-i18n-da              118.0-1            118.0.1-1
                     firefox-i18n-de              118.0-1            118.0.1-1
                    firefox-i18n-dsb              118.0-1            118.0.1-1
                     firefox-i18n-el              118.0-1            118.0.1-1
                  firefox-i18n-en-ca              118.0-1            118.0.1-1
                  firefox-i18n-en-gb              118.0-1            118.0.1-1
                  firefox-i18n-en-us              118.0-1            118.0.1-1
                     firefox-i18n-eo              118.0-1            118.0.1-1
                  firefox-i18n-es-ar              118.0-1            118.0.1-1
                  firefox-i18n-es-cl              118.0-1            118.0.1-1
                  firefox-i18n-es-es              118.0-1            118.0.1-1
                  firefox-i18n-es-mx              118.0-1            118.0.1-1
                     firefox-i18n-et              118.0-1            118.0.1-1
                     firefox-i18n-eu              118.0-1            118.0.1-1
                     firefox-i18n-fa              118.0-1            118.0.1-1
                     firefox-i18n-ff              118.0-1            118.0.1-1
                     firefox-i18n-fi              118.0-1            118.0.1-1
                     firefox-i18n-fr              118.0-1            118.0.1-1
                  firefox-i18n-fy-nl              118.0-1            118.0.1-1
                  firefox-i18n-ga-ie              118.0-1            118.0.1-1
                     firefox-i18n-gd              118.0-1            118.0.1-1
                     firefox-i18n-gl              118.0-1            118.0.1-1
                     firefox-i18n-gn              118.0-1            118.0.1-1
                  firefox-i18n-gu-in              118.0-1            118.0.1-1
                     firefox-i18n-he              118.0-1            118.0.1-1
                  firefox-i18n-hi-in              118.0-1            118.0.1-1
                     firefox-i18n-hr              118.0-1            118.0.1-1
                    firefox-i18n-hsb              118.0-1            118.0.1-1
                     firefox-i18n-hu              118.0-1            118.0.1-1
                  firefox-i18n-hy-am              118.0-1            118.0.1-1
                     firefox-i18n-ia              118.0-1            118.0.1-1
                     firefox-i18n-id              118.0-1            118.0.1-1
                     firefox-i18n-is              118.0-1            118.0.1-1
                     firefox-i18n-it              118.0-1            118.0.1-1
                     firefox-i18n-ja              118.0-1            118.0.1-1
                     firefox-i18n-ka              118.0-1            118.0.1-1
                    firefox-i18n-kab              118.0-1            118.0.1-1
                     firefox-i18n-kk              118.0-1            118.0.1-1
                     firefox-i18n-km              118.0-1            118.0.1-1
                     firefox-i18n-kn              118.0-1            118.0.1-1
                     firefox-i18n-ko              118.0-1            118.0.1-1
                    firefox-i18n-lij              118.0-1            118.0.1-1
                     firefox-i18n-lt              118.0-1            118.0.1-1
                     firefox-i18n-lv              118.0-1            118.0.1-1
                     firefox-i18n-mk              118.0-1            118.0.1-1
                     firefox-i18n-mr              118.0-1            118.0.1-1
                     firefox-i18n-ms              118.0-1            118.0.1-1
                     firefox-i18n-my              118.0-1            118.0.1-1
                  firefox-i18n-nb-no              118.0-1            118.0.1-1
                  firefox-i18n-ne-np              118.0-1            118.0.1-1
                     firefox-i18n-nl              118.0-1            118.0.1-1
                  firefox-i18n-nn-no              118.0-1            118.0.1-1
                     firefox-i18n-oc              118.0-1            118.0.1-1
                  firefox-i18n-pa-in              118.0-1            118.0.1-1
                     firefox-i18n-pl              118.0-1            118.0.1-1
                  firefox-i18n-pt-br              118.0-1            118.0.1-1
                  firefox-i18n-pt-pt              118.0-1            118.0.1-1
                     firefox-i18n-rm              118.0-1            118.0.1-1
                     firefox-i18n-ro              118.0-1            118.0.1-1
                     firefox-i18n-ru              118.0-1            118.0.1-1
                    firefox-i18n-sco              118.0-1            118.0.1-1
                     firefox-i18n-si              118.0-1            118.0.1-1
                     firefox-i18n-sk              118.0-1            118.0.1-1
                     firefox-i18n-sl              118.0-1            118.0.1-1
                    firefox-i18n-son              118.0-1            118.0.1-1
                     firefox-i18n-sq              118.0-1            118.0.1-1
                     firefox-i18n-sr              118.0-1            118.0.1-1
                  firefox-i18n-sv-se              118.0-1            118.0.1-1
                    firefox-i18n-szl              118.0-1            118.0.1-1
                     firefox-i18n-ta              118.0-1            118.0.1-1
                     firefox-i18n-te              118.0-1            118.0.1-1
                     firefox-i18n-th              118.0-1            118.0.1-1
                     firefox-i18n-tl              118.0-1            118.0.1-1
                     firefox-i18n-tr              118.0-1            118.0.1-1
                    firefox-i18n-trs              118.0-1            118.0.1-1
                     firefox-i18n-uk              118.0-1            118.0.1-1
                     firefox-i18n-ur              118.0-1            118.0.1-1
                     firefox-i18n-uz              118.0-1            118.0.1-1
                     firefox-i18n-vi              118.0-1            118.0.1-1
                     firefox-i18n-xh              118.0-1            118.0.1-1
                  firefox-i18n-zh-cn              118.0-1            118.0.1-1
                  firefox-i18n-zh-tw              118.0-1            118.0.1-1
                         go-ethereum             1.13.1-1             1.13.2-1
               gtk-update-icon-cache           1:4.12.2-1           1:4.12.3-1
                                gtk4           1:4.12.2-1           1:4.12.3-1
                          gtk4-demos           1:4.12.2-1           1:4.12.3-1
                           gtk4-docs           1:4.12.2-1           1:4.12.3-1
                           heaptrack              1.4.0-4              1.5.0-1
                    libdbusmenu-glib       16.04.0.r498-1       16.04.0.r498-2
                    libdbusmenu-gtk2       16.04.0.r498-1       16.04.0.r498-2
                    libdbusmenu-gtk3       16.04.0.r498-1       16.04.0.r498-2
                          libetebase              0.5.5-1              0.5.6-1
                              libvpx             1.13.0-1             1.13.0-2
                              limine       5.20230924.0-1       5.20230928.2-1
                                mame              0.258-1              0.259-1
                          mame-tools              0.258-1              0.259-1
                               meson              1.2.1-1              1.2.2-1
                               minio         2023.09.23-1         2023.09.27-1
                        minio-client         2023.09.22-1         2023.09.28-1
                              mpg123             1.32.1-2             1.32.2-1
                               pappl              1.3.4-1              1.4.0-1
                           partclone             0.3.25-1             0.3.26-1
                  php-legacy-mongodb             1.15.3-2             1.16.2-1
                         php-mongodb             1.15.3-2             1.16.2-1
                            protobuf               24.2-2               24.3-1
           python-aws-sam-translator             1.75.0-1             1.76.0-1
                      python-dulwich             0.21.6-2                    -
                    python-fonttools             4.42.1-1             4.43.0-1
                 python-jupyter-ydoc              1.1.0-1              1.1.1-1
                 python-magic-filter              1.0.9-3             1.0.12-1
                         python-moto              4.2.2-1              4.2.4-1
                     python-protobuf               24.2-2               24.3-1
                   python-weasyprint               60.0-1               60.1-1
                                 qbs              2.1.1-1              2.1.2-1
                            qt5-base   5.15.10+kde+r158-1   5.15.10+kde+r162-1
                         qt5-wayland    5.15.10+kde+r58-1    5.15.10+kde+r62-1
             qt5-xcb-private-headers   5.15.10+kde+r158-1   5.15.10+kde+r162-1
                              qt6-3d              6.5.2-1              6.5.3-1
                         qt6-5compat              6.5.2-1              6.5.3-1
                            qt6-base              6.5.2-1              6.5.3-1
                          qt6-charts              6.5.2-1              6.5.3-1
                    qt6-connectivity              6.5.2-1              6.5.3-1
                       qt6-datavis3d              6.5.2-1              6.5.3-1
                     qt6-declarative              6.5.2-2              6.5.3-1
                             qt6-doc              6.5.1-2              6.5.3-1
                        qt6-examples              6.5.1-2              6.5.3-1
                            qt6-grpc              6.5.2-4              6.5.3-1
                      qt6-httpserver              6.5.2-1              6.5.3-1
                    qt6-imageformats              6.5.2-2              6.5.3-1
                  qt6-languageserver              6.5.2-1              6.5.3-1
                        qt6-location              6.5.2-1              6.5.3-1
                          qt6-lottie              6.5.2-1              6.5.3-1
                      qt6-multimedia              6.5.2-1              6.5.3-1
               qt6-multimedia-ffmpeg              6.5.2-1              6.5.3-1
            qt6-multimedia-gstreamer              6.5.2-1              6.5.3-1
                     qt6-networkauth              6.5.2-1              6.5.3-1
                     qt6-positioning              6.5.2-1              6.5.3-1
                         qt6-quick3d              6.5.2-1              6.5.3-1
                  qt6-quick3dphysics              6.5.2-1              6.5.3-1
                qt6-quickeffectmaker              6.5.2-1              6.5.3-1
                   qt6-quicktimeline              6.5.2-1              6.5.3-1
                   qt6-remoteobjects              6.5.2-1              6.5.3-1
                           qt6-scxml              6.5.2-1              6.5.3-1
                         qt6-sensors              6.5.2-1              6.5.3-1
                       qt6-serialbus              6.5.2-1              6.5.3-1
                      qt6-serialport              6.5.2-1              6.5.3-1
                     qt6-shadertools              6.5.2-1              6.5.3-1
                          qt6-speech              6.5.2-1              6.5.3-1
                             qt6-svg              6.5.2-1              6.5.3-1
                           qt6-tools              6.5.2-2              6.5.3-1
                    qt6-translations              6.5.2-1              6.5.3-1
                 qt6-virtualkeyboard              6.5.2-1              6.5.3-1
                         qt6-wayland              6.5.2-2              6.5.3-1
                      qt6-webchannel              6.5.2-1              6.5.3-1
                       qt6-webengine              6.5.2-3              6.5.3-1
                      qt6-websockets              6.5.2-1              6.5.3-1
                         qt6-webview              6.5.2-1              6.5.3-1
                               qt6ct                0.9-1                0.9-2
                           qtcreator             11.0.2-2             11.0.3-1
                     qtcreator-devel             11.0.2-2             11.0.3-1
                                qtqr                2.1-4                2.1-5
                         sweethome3d                7.1-3                7.2-1
                    telegram-desktop             4.10.1-1             4.10.1-2
                     tracker3-miners              3.6.0-1              3.6.1-1
                                 vtk              9.2.6-8              9.2.6-9
                            waycheck              0.1.3-1              0.2.0-1
                           wpewebkit             2.42.0-1             2.42.1-1
                      wpewebkit-docs             2.42.0-1             2.42.1-1
                xfce4-clipman-plugin              1.6.4-1              1.6.5-1
                           xorg-xman              1.1.5-3              1.1.6-1

:: Different overlay package(s) in repository kde-unstable aarch64

                             PACKAGE           2023-09-28           2023-09-30
1 Like

Hi All,
I hope this is the right place for this post, please let me know if it is not.

So I built the latest version of ARM KDE-Plasma today using this command:

sudo buildarmimg -d gtking-pro -e kde-plasma -v 2023.09.30 -b testing n

For reference I have a Sunvell (probably a clone) T95U Pro with the S912 chip, 2Gb Ram, 16Gb storage.

For the last few days I have been trying to run Manjaro (Arm stable, both KDE and XFCE) on this little Android box but keep running into the issue of no internet or painfully slow Ethernet (to the point where it is not usable) and no wifi.

So today I tried the Testing branch and the Ethernet seems to be working, but still no wifi.

I have run into one issue with the KDE version that I have not experienced with the XFCE version, that is when I try to install a program using pamac, it asks me for an Authentication password but it does not accept the password that I created when I first set up the OS.

Does anyone know what the password is or why it isn’t accepting the password that I created?

I’ve rebooted and recreated the password, being careful to check for Cap-locks, etc. but still run into the same problem.

Please note that I did not run into this issue with the stable version of either KDE or XFCE, or the testing version of XFCE.

Once I get that figured out, I’ll see if I can get my wifi working and then figure out how to install this to the emmc of the Android box.
I plan on using this to run pi-hole or adguard.

Edit: I forgot to mention that in every instance Firefox was not working properly. It does not display properly (you can’t see anything, it is a jumbled, garbled mess). That is why I need to use pamac to install a different web browser.

Edit 2: I forgot to mention that I tried several dtb’s and the result is always the same.

Since it had broken in the last upgrade on my Pinephone Pro, I reinstalled beta15-rc4, and then upgraded after making the change to pacman.conf as described above. This failed, and I ended up again with a broken system. However, I realised that I had neglected to switch the branch to arm-testing.

I noticed the note that the issue was fixed in the latest update. So, I reinstalled Manjaro, switched to the testing branch, and upgraded (without changing pacman.conf). This failed.

It seems I should simply wait before attempting to reinstall and upgrade again.

The issue is the same as it was previously (see link).

Upgrade applied successfully on my Pinebook Pro with LxQT desktop.

Many thanks to the Arch, ALARM, and Manjaro teams!

1 Like