[ARM Testing Update] 2023-01-10 - GreetD, Wayfire, QT5, Plasma and kernels

Hello ARM community!

Some small updates to a lot of things!

wayfire


Some highlights:

  • Most of our kernels got updated
  • GreetD updated to 0.9.0
  • Wayfire updated to 0.7.5
  • QT5 updated to 5.15.8
  • Plasma updated to 5.26.5
  • KDE Gear applications updated to 22.12.1
  • Firefox updated to 108.0.2
  • More Gnome 43.3 packages
  • QT6 updated to 6.4.2
  • Lots of Mobile specific packages got updated
  • Many python packages got updated

Tips And Tricks

Error about missing openssl 1.1 library

Since the update to the new OpenSSL 3.0, some applications might still be looking for version 1.1 og openssl.
Fortunately Arch Linux created a compatability package for such events called openssl-1.1.
So if you encounter any such errors, please install the above mentioned package.
Applications currently known to specifically look for 1.1 is silver. We have not been able to rebuild it yet. So if you are on our Gnome or Sway editions, please install openssl-1.1 as part of this update.

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

over_voltage=5
arm_freq=2000
#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
disable_overscan=1

#enable sound
dtparam=audio=on
hdmi_drive=2

#enable vc4
dtoverlay=vc4-kms-v3d,cma-512
#max_framebuffers=2    #disable cause kodi uses more
disable_fw_kms_setup=1

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.


Upstream Notifications:

Older notifications

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss package requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention


Package Changes

(Tue Jan 10 19:32:29 CET 2023)

  • arm-testing community aarch64: 565 new and 547 removed package(s)
  • arm-testing core aarch64: 50 new and 52 removed package(s)
  • arm-testing extra aarch64: 698 new and 695 removed package(s)
  • arm-testing kde-unstable aarch64: 404 new and 404 removed package(s)

See the full package list here


Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #arm:testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

2 Likes

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered
2023-01-03

Ethernet and Wifi not working right on kernel 6.1.2+ on some devices

Some devices have been reported to not have properly working ethernet and wifi after the update to kernel 6.1.2 and above.
Fix: Correctly no working fix found.

Touch input on Firefox with Phosh not working in Firefox 108

Since the update to Firefox 108, the touch input does not work. Seems to be an issue with a couple of the changes the mobile-config brings in. PostMarketOS likely won’t fix this in their source, so we might need to carry a patch for this.

2022-11-20

OpenSSL 1.1 library not found

Some applications might still be looking for openssl 1.1.
Solution: Install openssl-1.1 package with sudo pacman -S openssl-1.1.

2022-10-31

Firefox shows wrong colors when playing video on Raspberry Pi 4

Since Mesa 22.2, Firefox has been showing weird colors when playing video on the Raspberry Pi 4. This is caused by an issue in upstream mesa, which was recently fixed.
Fix: Update to mesa 22.2.3-0.1 in the repository, which includes this fix.

Chromium in Wayland crashes with --in-process-gpu

Since Mesa 22.2.0, Chromium running in wayland sessions seems to crash when running with the --in-process-gpu option. Running in X11 seems fine, although it’s slow.
Fix: Update to Mesa 22.3.2 was reported to work here.

2022-10-21

Plasma Mobile Dialer seems to be unreliable

Plasma Dialer 22.09 seems to have issues switching audio profiles and as such might require manual switching. Sometimes audio is completely missing.

Reduced video performance on youtube

Some may encounter reduced video playback performance on YouTube in Firefox with the new Mesa 22.2 drivers.
No workaround at this time.

Old Issues

Phosh crashes when closing apps
An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Mouse cursor is slow on Raspberry Pi
Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

[Waydroid container cannot access internet
Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    }
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
    }
}
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via 192.168.250.1" |sudo waydroid shell

Beelink GT King Pro - Manjaro-Arm-Gnome-linux-aml-6.0.17-1 up to date with Arm-Testing-2023-01-10. No issue with Wifi on linux-aml-6.0.17-1 or linux-odroid-6.0.16-1.

Had WIFI issue and system stability issue on linux-6.1.4-3 (or earlier linux-6.1.2)

2 Likes

Hello, same here, If someone can tell me if the latest kernel version Linux6.0.y is still available online? (I use it because I don’t like the frequencies to be at the maximum all the time)

Isn’t it possible to change CPU Governor from “performance” to “ondemand” or “schedutil” using “cpupower” config? Manjaro arm on Amlogic Tv box? - #168 by TheMojoMan

you are the best
thank a lot
:+1:

Hi,

Odroid c2 kernel 6 and kernel 5 up to date.

issue

Issue with amule, crash on start.

missed wayfire-plugins-extra update?

1 Like

Filezilla no longer opens on my Pi4.
filezilla: error while loading shared libraries: libtiff.so.5: cannot open shared object file: No such file or directory
Tried downgrading both filezilla and libfilezilla to no avail.

My Pi3+ running arch has the same issue.

Updated. Thanks.

This looks like libtiff was updated to 4.5.0 by upstream, without rebuilding filezilla to link against it.
Especially since you mentioned Arch having the same issue.

Hi,

Is the issue with Filezilla solve ? if you solve it, how did you do it?
I forgot to test Filezilla after the last update, I hope it is working…

A post was split to a new topic: How do I build a generic image with a specific DE?

PinebookPro won’t boot from emmc after the update and writing the uboot, which came with it, to the emmc.

Hi @Strit & @spikerguy,

The latest kernel linux-6.1.6-1 from @spikerguy Artifacts · package (#11407) · Jobs · manjaro-arm / packages / core / linux · GitLab seems to have solved the WIFI issue on GT King Pro.

Thank you.

1 Like

Everything updated fine. I did have a problem a couple of months ago after a large update, where the GUI would no longer boot up. I just fixed this now with an upgrade via the command line (Fn-Ctrl-Alt-F2, with the keyboard), and it’s properly booting up again. I have Manjaro Plasma Testing.