[ARM Testing Update] 2022-11-20 - OpenSSL, Firefox, Thunderbird, Plasma, SystemD and kernels

Hello ARM community.

It’s been a couple of weeks since the last update, but this one is a big one.

Big update of OpenSSL resulted in thousands of packages being rebuilt and updated

Some highlights:

  • Most of our kernels got updated
  • OpenSSL updated to 3.0.7! Did we miss any rebuilds?
  • Firefox updated to 107.0
  • Thunderbird updated to 102.5.0
  • Plasma updated to 5.26.3
  • KDE Frameworks updated to 5.100
  • SystemD updated to 252.1
  • QT6 updated to 6.4.1
  • Box64 updated to 0.2.0
  • Lots of Mobile specific packages got updated
  • Many python packages got updated

Tips And Tricks

Error about missing openssl 1.1 library

Since the update to the new OpenSSL 3.0, some applications might still be looking for version 1.1 og openssl.
Fortunately Arch Linux created a compatability package for such events called openssl-1.1.
So if you encounter any such errors, please install the above mentioned package.
Applications currently known to specifically look for 1.1 is silver. We have not been able to rebuild it yet. So if you are on our Gnome or Sway editions, please install openssl-1.1 as part of this update.

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Older notifications

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss package requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package Changes

(Sun Nov 20 19:09:38 CET 2022)

  • arm-testing community aarch64: 1445 new and 1406 removed package(s)
  • arm-testing core aarch64: 105 new and 104 removed package(s)
  • arm-testing extra aarch64: 789 new and 786 removed package(s)
  • arm-testing kde-unstable aarch64: 348 new and 348 removed package(s)

See the full package list here

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #arm:testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered


OpenSSL 1.1 library not found

Some applications might still be looking for openssl 1.1.
Solution: Install openssl-1.1 package with sudo pacman -S openssl-1.1.


Firefox shows wrong colors when playing video on Raspberry Pi 4

Since Mesa 22.2, Firefox has been showing weird colors when playing video on the Raspberry Pi 4. This is caused by an issue in upstream mesa, which was recently fixed.
Fix: Update to mesa 22.2.3-0.1 in the repository, which includes this fix.

Chromium in Wayland crashes with --in-process-gpu

Since Mesa 22.2.0, Chromium running in wayland sessions seems to crash when running with the --in-process-gpu option. Running in X11 seems fine, although it’s slow.
Workaround: Downgrade to mesa 22.1.7 from cache with sudo pacman -U /var/cache/pacman/pkg/mesa-22.1.7-*, until the issue is fixed upstream.


Plasma Mobile Dialer seems to be unreliable

Plasma Dialer 22.09 seems to have issues switching audio profiles and as such might require manual switching. Sometimes audio is completely missing.

Reduced video performance on youtube

Some may encounter reduced video playback performance on YouTube in Firefox with the new Mesa 22.2 drivers.
No workaround at this time.

Old Issues

Phosh crashes when closing apps
An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Mouse cursor is slow on Raspberry Pi
Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

[Waydroid container cannot access internet
Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell

The update went fine, thank you.

Is there a way to disable this new “favourites” screen?
It is always there after closing an app, which wouldnt be so bad if it remembered the favourites you added to it.

1 Like

You can change to the old homescreen layout, by holding down on homescreen and choosing “Configure Wallpaper” (I know, it needs to be renamed). You can switch to the other Homescreen there. I think it’s called Folio, where the new one is Halygon.

1 Like

thanks that worked, until I reboot, then holcyon is back.
i’m having some scaling issues as well, ~10% of the left hand side of apps are rendered off screen, and no amount of playing with the scale makes it right.
Maybe i will do a reflash to see if the correct screen size gets picked up.,

Update is OK after finding eth0 had been renamed end0 on raspberry Pi 4 64


Since update panels crash repeatedly- KDE edition, on Pinebook Pro, Wayland session. The panels do not crash on X11.

If you find out what causes this, please let us know. I saw it in Unstable yesterday, but didn’t see it before the weekend.

After this update Firefox crashes when I click on the Bitwarden or uBlock Origin extensions. Chromium doesn’t, but the menus (e.g. settings or bookmark folders) there don’t appear when they should. This is in GNOME-Wayland on a Pinebook Pro.

Starting Firefox from terminal, it shows this (before the crash, everything above the first “Exiting due to…” was shown in the terminal):

(firefox:2831): Gtk-WARNING **: 07:43:51.219: Theme parsing error: gtk.css:1:45: Expected a valid selector
Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: DRM render node not clearly detectable. Falling back to using the only one that was found. (t=1.42425) [GFX1-]: glxtest: DRM render node not clearly detectable. Falling back to using the only one that was found.
Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: DRM render node not clearly detectable. Falling back to using the only one that was found. (t=1.42425) |[1][GFX1-]: glxtest: VA-API test failed: failed to initialise VAAPI connection. (t=1.42435) [GFX1-]: glxtest: VA-API test failed: failed to initialise VAAPI connection.
[2022-11-22T12:43:59Z ERROR glean_core::metrics::ping] Invalid reason code startup for ping newtab
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Segmentation fault (core dumped)

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

I have the same issue on Pinebook Pro on Wayland

@doug and @gabeeg I think I found the issue with Wayland.

It’s a regression in Mesa that was reported to them a few days ago.

The reporter mentioned the commit that might have introduced the issue, so I built our Mesa package with this commit reverted and it worked in my tests.

So I uploaded 22.2.4-0.2, which includes the fix, to Unstable and Testing branches. Let me know if it also fixes the issue for you.

I had this same issue and 22.2.4-0.2 fixes it for me. Thanks for finding the issue and releasing a new package!

1 Like

I currently use the unstable branch of plasma mobile(without kde-unstable repo)

about two days ago qt5-es2-base was updated to version 5.15.7+kde+r175-1 which seems to cause the lockscreen of plasma-mobile to break.

a downgrade to version 5.15.7+kde+r174-1 seems to fix the issue.

That did the trick @Strit Thanks for finding and fixing for the Testing branch!


Not sure why that is.

The commit that was added seems to be this one: Scale BMP color samples with periodic bit expansion (!220) · Merge requests · Qt Project / qt / qtbase · GitLab

I wonder if the PlaMo devs knows what about it causes the issue.

Have you tried updating to the new Mesa package (22.2.4-0.2) to see if that changes it?
Because I just updated my PlaMo with broken lockscreen to that package and it now works again.

The update to Mesa also fixed the Firefox and Chromium issues I mentioned.


This fixed it for me! Thank you for all the work you do!