[ARM Testing Update] 2022-10-15 - Plasma 5.26, DFL, DesQ and kernels

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Before 2022-08-23

Phosh crashes when closing apps

An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Before 2022-07-22

Mouse cursor is slow on Raspberry Pi

Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

Waydroid container cannot access internet

Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell
Old Issues
Plasma Dialer cannot answer calls

Sadly Plasma Dialer 22.02 has a serious regression with no known workaround. It’s not possible to accept incoming calls. Very sorry about this. Follow the upstream bug report. We will patch the package as soon as a solution is found.

Plasma Mobile - Black screen after update

We are seeing some reports about Plasma Mobile on the PinePhone only showing a black screen after entering the PIN after this update.
Workaround: Downgrade qt5-es2-wayland to 5.15.2+kde+r41 which is now back in Stable and Testing branch repositories.

New Breath theme not applying correctly

With the update to the new Breath theme, a migration package tries to apply the new theme correctly.
However this is not getting done for Plasma’s Lockscreen and the SDDM theme.
So please go through your settings after updating to make sure the themes are correctly applied.
Fix: manjaro-system should take care of this for you.

Plasma Mobile switch to ModemManager

With the PlaMo Gear 21.12 release, Plasma Mobile is now using ModemManager as the telephony stack. So in order to use SIM capabilities, you need to switch from using oFono to ModemManager.
Fix: Run sudo systemctl disable --now ofono ofonoctl && sudo systemctl enable --now ModemManager. You might have to reboot your phone for Plasma Mobile to pick up this change.

Plasma Mobile has does not launch after update
This was caused by an error in kwin 5.23.2 which only affects installs based on openGLES (qt5-es2).
Fix: Update to kwin 5.23.2-1.2 or above.

No ethernet on rk3399 boards
A recent kernel regression has resulted in built in ethernet on rk3399 based boards, such as RockPro64 and Rock Pi 4’s, no longer works on kernel 5.14. This is an upstream issue that has not been fixed yet.
Fix: Update to linux-5.14.1-2 or newer.

Vivaldi no longer working
The issue is present in all chrome based browser (except Chromium that got a patch for it).
It’s an issue with systemd-resolved and has been reported in the Arch Linux Bug Tracker.
Needs to be fixed by Vivaldi updates in the future.
Fix: Vivaldi 4.1.2369.21 fixed this issue.

Modemmanager-pp dependency issue
modemmanager-pp 1.16.10 depends on libqmi-pp and libmbim-pp, but they are no longer found in the repo.
Fixed by updated to modemmanager-pp 1.18rc1+2+ga20f2c05-2.

systemd-hook unsuccesful after pacman 6 update
After the pacman 6 update, updates will create this message in the post-transation hooks part:

Running the command manually works and there has been no issues reported as the result of this. This will either get fixed at some point in Pacman or SystemD.
Should be fixed with pacman-6.0.0-4

Keyring issues
If you have some gpg keyring issues, you can run sudo systemctl start pacman-init.service which will regenerate your keyring. Will take a few minutes to complete.
Should be fixed with manjaro-system-20210716-1

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login.
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-3.1 and qt5-es2-declarative-5.15.2+kde+r28-3.1.

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

1 Like

i had a couple of timeouts from mirror.moson.org but it seemed fine when updating mirror list.

██████████████████  ████████   al@manjaro-arm 
██████████████████  ████████   -------------- 
██████████████████  ████████   OS: Manjaro ARM Linux aarch64 
██████████████████  ████████   Host: Pine64 PinePhone (1.2) 
████████            ████████   Kernel: 6.0.0-1-MANJARO-ARM 
████████  ████████  ████████   Uptime: 8 mins 
████████  ████████  ████████   Packages: 803 (pacman) 
████████  ████████  ████████   Shell: bash 5.1.16 
████████  ████████  ████████   Resolution: 720x1440 
████████  ████████  ████████   Terminal: /dev/pts/0 
████████  ████████  ████████   CPU: (4) @ 1.1GHz 
████████  ████████  ████████   Memory: 1041MiB / 2994MiB 
████████  ████████  ████████
████████  ████████  ████████                           


The upgrade went smoothly. I find the altered splash-screen and the new sideswipe to reach the programs a bit odd (since it’s new).

Just regarding Megapixels, I cannot get it to work. It simply crashes when I try to open it. The most recent October Update site claims,

  • Starting with kernel 5.19 PinePhone Pro’s cameras will work with Megapixels

But, that has not been my experience. The megapixels program does nothing when I try to use it. I get the following feedback:

[mark@manjaro-arm ~]$ megapixels
/usr/share/megpixels/config/pine64.pinephone-pro.ini not found
Could not find any config file

I tried the camera test program (using “rkisp1” as the camera name → not sure if that’s correct, but I think it is) and I got the following:

megapixels-camera-test rkisp1
Finding the device took 1.518965ms
Opening the device took 0.462055ms
Segmentation fault (core dumped)

as reported earlier, firefox/youtube/video/color issue with mesa-git & mesa-22.2.1 still exist.
mesa-2.1.7 doing well.

You need to switch to the megapixels-ppp package, because the PinePhone Pro support is still not in upstream Megapixels:

sudo pacman -S megapixels-ppp




There’s not much we can do about this, as it seems to be an upstream mesa issue. I’ve heard people having issues with Ozone on Chromium too.

So far the upgrade seems OK, except for the loss of my desktop background settings, that reverted back to the defaults.
It’s an issue that I noticed several times with KDE updates : the bacgkground settings reverting to defaults, either desktop background, screen lock background, or sddm background.

This time the desktop background was reverted, screen lock not, and sddm I think but I’m not 100% sure.


Is the kernel 6.0.2-1 available for the Odroid m1 ?

Yes. The odroid m1 uses our main kernel, which got updated to 6.0.2.

1 Like

Thanks for your reply.

Is the device ok with the sata and m2 sata ?

I’m going to build an image for the Odroid m1 => emmc.

sudo buildarmimg -d om1 -e lxqt -v 2022.10.16 -b testing -n

linux-6.0.2-1-aarch64 downloading…

See you later with my feedback.

I don’t have any SATA device to check with. So I don’t know. I don’t think so, as the DTS is missing sata nodes.
I’m currently testing a new version of the patch set, which does have sata nodes. If it works, I’ll push it repo.

EDIT: The test kernel does seem to have working SATA, as I get some sata related messages in dmesg with it. So hopefully we can update our patches soon.

The Odroid m1 is working well with the kernel 6.0.2-1, I hope for a long time.
emmc module running the device.
Nice the rocket during the os install.

The USB 3 slot on the top is now working, not on the bottom.

I wrote this feedback with the Odroid m1 :-)

[nls@m1 ~]$ date -u
dim. 16 oct. 2022 13:09:27 UTC
[nls@m1 ~]$ screenfetch
                             OS: Manjaro-ARM 22.10
                             Kernel: aarch64 Linux 6.0.2-1-MANJARO-ARM
         #####               Uptime: 7m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.1.16
        #######              Resolution: 1920x1080
      ###########            DE: LXQt 1.1.0
     #############           WM: OpenBox
    ###############          WM Theme: Mikachu
    ################         GTK Theme: Matcha-light-azul [GTK2/3]
   #################         Icon Theme: Papirus-Dark
 #####################       Font: Noto Sans 11
 #####################       Disk: 
   #################         CPU: Unknown @ 4x 1.992GHz
                             GPU: Mali-G52 r1 (Panfrost)
                             RAM: 1645MiB / 7450MiB
[nls@m1 ~]$ uname -a
Linux m1 6.0.2-1-MANJARO-ARM #1 SMP PREEMPT Sat Oct 15 08:40:15 UTC 2022 aarch64 GNU/Linux
[nls@m1 ~]$ 

Yeah, the bottom USB3 port is something we need to figure out. :slight_smile:


An Odroid m1 user report the nvme is working…

 Re: Manjaro Arm Linux - Dev Edition

Post by exceeder » Thu Oct 13, 2022 11:44 pm
Dev 20221003 https://github.com/manjaro-arm/om1-imag ... g/20221003
nvme boot works :-)
no audio and gpu acceleration :-(

GPU acceleration does work and pretty sure we have some kind of audio.

Although video acceleration do not (as with most ARM boards on mainline).

The audio jack output is working on the Odroid m1, tested just now.

Patrick Hernandez - Born to Be Alive - Official Video (Clip Officiel) - YouTube

Deliverance - Dueling Banjos (HQ) - YouTube

Climb Dance - 1988 Pikes Peak Hill Climb, Ari Vatanen - YouTube

I’m finding that the screen keyboard is not popping up as readily as before the upgrade. By “screen keyboard”, I’m referring to the virtual keyboard, rather than a plugged in physical one (fortunately I have a physical one which I can plug in if need be, but I’d rather it be out of choice rather than necessity).

Some details from the Odroid forum, exceeder wrote it about the Odroid m1.

Re: Manjaro Arm Linux - Dev Edition

Post by exceeder » Mon Oct 17, 2022 2:13 pm
Thanks, I have updated with pacman -Syu, and can confirm 6.0.2-3-MANJARO-ARM both analog RK817 and HDMI are working. Sound card is so powerful for passive 8Ω speakers, no amp is necessary for basic usage.
Despite I am using as zigbee2mqtt gateway / Home Assistant, Panfrost gpu driver also works, but unable to set up more than 1080p. Needs digging.
My current goal is get root filesystem on BTRFS :-)

Code: Select all

glmark-es2-wayland --fullscreen

glmark2 Score: 289

regarding the 1080p issue. That is a current limit in mainline linux. Rockchip DRM has no support for bigger than 1080p, so that’s what it’s locked at for HiDPI screens at this point. Although there is work being done to enable more resolutions, they currently present regressions in other areas.

BTRFS on root can be done when installing with Manjaro ARM Installer.