[ARM Testing Update] 2021-07-07 - Plasma, Mesa, KDE-Git, Python

Hello ARM community.

A rather small update, nothing fancy.


What is needed to get the Pinephone more secure. Find out


Some highlights:

  • Lots of Mobile specific packages got updated
  • Some python packages got updated

How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker linux-rpi4 xf86-video-fbturbo-git

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

over_voltage=5
arm_freq=2000
#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
disable_overscan=1

#enable sound
dtparam=audio=on
hdmi_drive=2

#enable vc4
dtoverlay=vc4-kms-v3d,cma-512
#max_framebuffers=2    #disable cause kodi uses more
dtoverlay=rpivid-v4l2
disable_fw_kms_setup=1

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.


Upstream Notifications:

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
https://archlinux.org/news/sorting-out-old-password-hashes/

Older notifications

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
https://www.archlinux.org/news/ghostpcl9532-2-and-ghostxps9532-2-updates-require-manual-intervention/

The nss package requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/

The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package Changes

( Wed Jul 7 06:45:43 CEST 2021)

  • arm-testing community aarch64: 177 new and 168 removed package(s)
  • arm-testing core aarch64: 6 new and 6 removed package(s)
  • arm-testing extra aarch64: 122 new and 122 removed package(s)
  • arm-testing kde-unstable aarch64: 76 new and 75 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2021-07-02           2021-07-07
-------------------------------------------------------------------------------
                       buttermanager              2.4.1-1              2.4.2-1
                               calls  0.3.4+28+g49c347c-1  0.3.4+31+g9f45e8b-1
                              chatty  0.3.2+18+gdcdf00a-1  0.3.2+23+gd7c04b0-1
                            electron             13.1.5-1             13.1.6-1
              nemo-qml-plugin-models              0.2.1-1              0.2.2-1
                               phosh  0.12.0+2+g40bf03f-1 0.12.0+12+g675a75d-1
                   python-ytmusicapi             0.17.3-1             0.18.0-1
                             vivaldi        4.0.2312.33-1        4.0.2312.38-1
                               box64                    -              0.1.2-1


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2021-07-02           2021-07-07
-------------------------------------------------------------------------------
                          abseil-cpp         20210324.1-2         20210324.2-1
                              ardour                6.7-3                6.8-1
                             blender          17:2.93.1-1          17:2.93.1-2
                         cargo-audit             0.14.1-1             0.15.0-1
                         cargo-bloat             0.10.0-2             0.10.1-1
                       cargo-release            0.13.11-1             0.16.0-1
                       cataclysm-dda              0.E.3-2                0.F-1
                 cataclysm-dda-tiles              0.E.3-2                0.F-1
                        cgit-archweb              1.2.3-1              1.2.3-2
                         cgit-aurweb              1.2.3-1              1.2.3-2
                             chezmoi             2.0.16-1              2.1.0-1
                            cinnamon              5.0.3-1              5.0.4-1
                               clash              1.6.0-1              1.6.5-1
                      cockpit-podman                 31-1                 32-1
                   containers-common             0.40.1-1             0.40.1-2
                                deno             1.10.1-1             1.11.5-1
                  dovecot-fts-xapian             1.4.10-2             1.4.11-1
                                dune              2.8.5-1              2.9.0-1
                             e-antic              0.1.9-1              1.0.1-2
                              eslint             7.29.0-1             7.30.0-1
                               fceux              2.3.0-1              2.4.0-1
                fcitx5-pinyin-zhwiki   1:0.2.3.20210625-1   1:0.2.3.20210704-1
              firefox-tree-style-tab              3.8.4-1              3.8.5-1
                           freeimage             3.18.0-9            3.18.0-10
                                giac           1.7.0.13-2           1.7.0.17-1
                    gimp-plugin-gmic              2.9.7-4              2.9.7-5
                          github-cli             1.12.0-1             1.12.1-1
                                gmic              2.9.7-4              2.9.7-5
                              gopass             1.12.6-1             1.12.7-1
                                haxe              4.2.2-1              4.2.3-1
                            heimdall              1.4.2-5              1.4.2-6
                               hugin           2020.0.0-4           2020.0.0-5
                          hyperkitty              1.3.4-1              1.3.4-2
                                 jad             1.5.8e-8             1.5.8e-9
                             jenkins              2.300-1              2.301-1
                                 k9s            0.24.12-1            0.24.13-1
                              kotlin             1.5.10-1             1.5.20-1
                         kphotoalbum              5.7.0-3              5.8.1-1
                   krita-plugin-gmic              2.9.7-4              2.9.7-5
                             lazygit             0.28.1-1             0.28.2-1
                               lcalc              1.23-21              2.0.2-1
                             liblscp              0.9.3-1              0.9.4-1
                             libvips             8.11.0-1             8.11.1-2
                        luminancehdr              2.6.1-3              2.6.1-4
                               lynis              3.0.4-1              3.0.5-1
                            mailman3              3.3.4-1              3.3.4-3
                               mdcat             0.22.4-2             0.23.0-1
                             mellite              3.5.5-1              3.5.7-1
                             menyoki              1.4.0-1              1.5.1-1
                               mixxx              2.3.0-1              2.3.0-2
                                ncdu             1.15.1-2               1.16-1
                                nemo              5.0.2-1              5.0.3-1
                              neovim              0.4.4-2              0.5.0-1
                  nextcloud-app-news             15.4.5-1             16.0.0-2
                      nginx-mainline             1.21.0-1             1.21.1-1
                  nginx-mainline-src             1.21.0-1             1.21.1-1
                                 nix             2.3.13-2             2.3.14-1
                              nodejs             16.4.1-1             16.4.2-1
                            normaliz             3.8.10-1              3.9.0-1
                   npm-check-updates             11.7.1-1             11.8.0-1
                              nuitka             0.6.16-1           0.6.16.2-1
                           nvchecker                2.3-3                2.3-4
                            onefetch              2.9.1-1             2.10.2-1
                         openimageio           2.2.15.1-3           2.2.15.1-4
                      openscenegraph              3.6.5-6              3.6.5-7
                           planarity            3.0.1.0-1            3.0.1.1-1
                             plantri                5.0-3                5.2-1
                                poco             1.10.1-1             1.11.0-1
                            polymake                4.4-3                4.4-4
                           postorius              1.3.4-1              1.3.4-2
                              povray          2:3.7.0.9-1          2:3.7.0.9-2
                   powerdns-recursor              4.5.2-1              4.5.4-1
                 profile-sync-daemon               6.44-1               6.44-2
                              pwndbg         2020.07.23-2         2021.06.22-1
                               pyenv              2.0.2-1              2.0.3-1
                             pyright            1.1.154-1            1.1.155-1
                         python-acme             1.16.0-1             1.17.0-1
                      python-aiogram               2.13-1               2.14-1
                      python-alembic              1.6.2-2              1.6.5-1
              python-django-mailman3              1.3.5-1              1.3.5-2
                        python-faker              8.9.0-1              8.9.1-1
               python-flask-security              3.0.0-4              3.0.0-5
                         python-gast              0.4.0-3              0.5.0-1
                       python-gitlab              2.8.0-1              2.9.0-1
                       python-gssapi             1.6.12-2             1.6.14-1
                   python-hypothesis             6.14.0-1             6.14.1-1
          python-importlib_resources              5.2.0-1              5.2.0-2
            python-jupyter_packaging             0.10.3-1             0.10.4-1
                         python-milc              1.3.0-1              1.4.2-1
                      python-osc-lib              2.4.0-2              2.4.1-1
                         python-path             15.1.2-1             16.0.0-1
                       python-pg8000             1.19.5-1             1.20.0-1
                      python-pikepdf             2.13.0-1             2.14.0-1
                       python-pillow              8.2.0-2              8.3.0-1
                   python-pynormaliz               2.14-1               2.15-1
                   python-pyrsistent             0.17.3-3             0.18.0-1
         python-pytest-rerunfailures               10.0-1               10.1-1
             python-pytest-testinfra              6.3.0-1              6.4.0-1
                       python-qasync             0.16.0-1             0.17.0-1
                    python-qtconsole              5.0.3-1              5.1.1-1
                        python-regex           2021.7.1-1           2021.7.6-1
                         python-rich             10.4.0-1             10.5.0-1
                       python-sphinx              4.0.2-1              4.0.3-1
                      python-trustme              0.7.0-1              0.8.0-1
                         python-xlib               0.30-1               0.31-1
                    python2-pathlib2              2.3.5-1              2.3.6-1
                            qjackctl              0.9.3-1              0.9.4-1
                            qmidictl              0.9.3-1              0.9.4-1
                            qmidinet              0.9.3-1              0.9.4-1
                              qsynth              0.9.3-1              0.9.4-1
                             qxgedit              0.9.3-1              0.9.4-1
                            rabbitmq             3.8.16-1             3.8.19-1
                       rabbitmqadmin             3.8.16-1             3.8.19-1
                           retroarch              1.9.6-1              1.9.6-2
                  rime-pinyin-zhwiki   1:0.2.3.20210625-1   1:0.2.3.20210704-1
                           ropgadget                6.5-1                6.6-1
                    ruby-addressable              2.7.0-3              2.8.0-1
                       rust-analyzer           20210628-1           20210705-1
                           seamonkey           2.53.7.1-1             2.53.8-1
                           skk-jisyo           20210627-1           20210704-1
                                  sx              2.1.6-1              2.1.7-1
                           tailscale             1.10.0-1             1.10.1-1
                               tanka             0.16.0-1             0.17.0-1
                    telegram-desktop              2.8.3-1              2.8.4-3
                        threejs-sage             1:r124-1             1:r124-3
                              tinygo             0.18.0-1             0.19.0-1
                         ttc-iosevka              7.2.2-2              7.2.6-1
                    ttc-iosevka-aile              7.2.2-2              7.2.6-1
                   ttc-iosevka-curly              7.2.2-2              7.2.6-1
              ttc-iosevka-curly-slab              7.2.2-2              7.2.6-1
                  ttc-iosevka-etoile              7.2.2-2              7.2.6-1
                    ttc-iosevka-slab              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss01              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss02              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss03              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss04              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss05              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss06              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss07              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss08              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss09              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss10              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss11              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss12              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss13              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss14              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss15              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss16              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss17              7.2.2-2              7.2.6-1
                    ttc-iosevka-ss18              7.2.2-2              7.2.6-1
         v2ray-domain-list-community     20210701083009-1     20210702040554-1
                               vigra            1.11.1-33            1.11.1-34
                           vigra-doc            1.11.1-33            1.11.1-34
                      weechat-matrix              0.2.0-4              0.3.0-2
                         wireplumber              0.4.1-1              0.4.1-2
                    wireplumber-docs              0.4.1-1              0.4.1-2
                                xplr             0.14.3-1             0.14.4-1
                               yaegi             0.9.18-1             0.9.19-1
                           yggdrasil             0.3.16-1              0.4.0-1
                                zart              2.9.7-4              2.9.7-5
                               antic                    -              0.2.4-1
                   python-boolean.py                    -                3.8-3
                       python-debian                    -             0.1.40-2
         python-django-debug-toolbar                    -                3.2-1
           python-license-expression                    -            21.6.14-2
                      python-pymupdf                    -            1.18.14-2
                       python-svglib                    -              1.1.0-2
                               reuse                    -             0.13.0-2


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2021-07-02           2021-07-07
-------------------------------------------------------------------------------
                               linux             5.13.0-1             5.13.0-2
                       linux-headers             5.13.0-1             5.13.0-2
                      linux-quartz64           5.13.0-0.4           5.13.0-0.6
              linux-quartz64-headers           5.13.0-0.4           5.13.0-0.6


:: Different sync package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2021-07-02           2021-07-07
-------------------------------------------------------------------------------
                                nspr               4.31-1               4.32-1
                             texinfo                6.7-3                6.8-1


:: Different overlay package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2021-07-02           2021-07-07
-------------------------------------------------------------------------------
             manjaro-chrootbuild-dev      r198.gf6d6bcb-1                    -
                 manjaro-chrootbuild      r210.gabe0535-1      r212.g63450ad-1
                            mesa-git21.2.0_devel.141748.e74366b18a3-121.2.0_devel.141996.c246af0dd80-1
                    plasma-mobile-nm           5.22.2.1-1             5.22.3-1
                         plasma-nano           5.22.2.1-1             5.22.3-1
             plasma-phone-components           5.22.2.1-1             5.22.3-1
                   qqc2-breeze-style           5.22.2.1-1             5.22.3-1
                       calamares-qml                    -             3.2.40-0


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2021-07-02           2021-07-07
-------------------------------------------------------------------------------
                             abiword              3.0.4-4              3.0.5-1
                           bluedevil         1:5.22.2.1-1           1:5.22.3-1
                              breeze           5.22.2.1-1             5.22.3-1
                         breeze-grub           5.22.2.1-1             5.22.3-1
                          breeze-gtk           5.22.2.1-1             5.22.3-1
                              brltty                6.3-2                6.3-3
                              clamav            0.103.2-1            0.103.3-1
                             digikam              7.2.0-4              7.2.0-5
                            discover           5.22.2.1-1             5.22.3-1
                             drkonqi           5.22.2.1-1             5.22.3-1
                                gegl             0.4.30-3             0.4.30-4
                           gi-docgen2021.2+113+gc633261-1             2021.6-1
                                gimp            2.10.24-4            2.10.24-5
                             glslang             11.4.0-1             11.5.0-1
                   gst-plugin-opencv             1.18.4-7             1.18.4-8
                      gst-plugin-wpe             1.18.4-7             1.18.4-8
                     gst-plugins-bad             1.18.4-7             1.18.4-8
                gst-plugins-bad-libs             1.18.4-7             1.18.4-8
                         imagemagick            7.1.0.2-1            7.1.0.2-2
                     imagemagick-doc            7.1.0.2-1            7.1.0.2-2
                   kactivitymanagerd           5.22.2.1-1             5.22.3-1
                       kde-cli-tools           5.22.2.1-1             5.22.3-1
                      kde-gtk-config           5.22.2.1-1             5.22.3-1
                         kdecoration           5.22.2.1-1             5.22.3-1
                    kdeplasma-addons           5.22.2.1-1             5.22.3-1
                             kgamma5           5.22.2.1-1             5.22.3-1
                            khotkeys           5.22.2.1-1             5.22.3-1
                       kimageformats             5.83.0-3             5.83.0-4
                         kinfocenter           5.22.2.1-1             5.22.3-1
                          kio-extras            21.04.2-2            21.04.2-3
                           kmenuedit           5.22.2.1-1             5.22.3-1
                               krita              4.4.5-1              4.4.5-2
                             kscreen           5.22.2.1-1             5.22.3-1
                       kscreenlocker           5.22.2.1-1             5.22.3-1
                         ksshaskpass           5.22.2.1-1             5.22.3-1
                        ksystemstats           5.22.2.1-1             5.22.3-1
                         kwallet-pam           5.22.2.1-1             5.22.3-1
                kwayland-integration           5.22.2.1-1             5.22.3-1
                     kwayland-server           5.22.2.1-1             5.22.3-1
                                kwin           5.22.2.1-1             5.22.3-1
                             kwrited           5.22.2.1-1             5.22.3-1
                      layer-shell-qt           5.22.2.1-1             5.22.3-1
                              libdrm            2.4.106-1            2.4.107-1
                          libkscreen           5.22.2.1-1             5.22.3-1
                        libksysguard           5.22.2.1-1             5.22.3-1
                          libplacebo            3.120.3-1            3.120.3-2
                   libva-mesa-driver             21.1.3-1             21.1.4-1
                                mesa             21.1.3-1             21.1.4-1
                          mesa-vdpau             21.1.3-1             21.1.4-1
                               milou           5.22.2.1-1             5.22.3-1
                                 mpd             0.22.8-1             0.22.9-1
                         opencl-mesa             21.1.3-1             21.1.4-1
                              opencv              4.5.2-4              4.5.3-1
                      opencv-samples              4.5.2-4              4.5.3-1
                             openexr              3.0.4-1              3.0.5-1
                              oxygen           5.22.2.1-1             5.22.3-1
                               pango           1:1.48.6-1           1:1.48.7-1
                          pango-docs           1:1.48.6-1           1:1.48.7-1
                                php7             7.4.20-1             7.4.21-1
                         php7-apache             7.4.20-1             7.4.21-1
                            php7-cgi             7.4.20-1             7.4.21-1
                          php7-dblib             7.4.20-1             7.4.21-1
                          php7-embed             7.4.20-1             7.4.21-1
                        php7-enchant             7.4.20-1             7.4.21-1
                            php7-fpm             7.4.20-1             7.4.21-1
                             php7-gd             7.4.20-1             7.4.21-1
                           php7-imap             7.4.20-1             7.4.21-1
                           php7-intl             7.4.20-1             7.4.21-1
                           php7-odbc             7.4.20-1             7.4.21-1
                          php7-pgsql             7.4.20-1             7.4.21-1
                         php7-phpdbg             7.4.20-1             7.4.21-1
                         php7-pspell             7.4.20-1             7.4.21-1
                           php7-snmp             7.4.20-1             7.4.21-1
                         php7-sodium             7.4.20-1             7.4.21-1
                         php7-sqlite             7.4.20-1             7.4.21-1
                           php7-tidy             7.4.20-1             7.4.21-1
                            php7-xsl             7.4.20-1             7.4.21-1
          plasma-browser-integration           5.22.2.1-1             5.22.3-1
                      plasma-desktop           5.22.2.1-1             5.22.3-1
                        plasma-disks           5.22.2.1-1             5.22.3-1
                     plasma-firewall           5.22.2.1-1             5.22.3-1
                  plasma-integration           5.22.2.1-1             5.22.3-1
                           plasma-nm           5.22.2.1-1             5.22.3-1
                           plasma-pa           5.22.2.1-1             5.22.3-1
                          plasma-sdk           5.22.2.1-1             5.22.3-1
                plasma-systemmonitor           5.22.2.1-1             5.22.3-1
                  plasma-thunderbolt           5.22.2.1-1             5.22.3-1
                        plasma-vault           5.22.2.1-1             5.22.3-1
              plasma-wayland-session           5.22.2.1-1             5.22.3-1
                    plasma-workspace           5.22.2.1-1             5.22.3-1
         plasma-workspace-wallpapers           5.22.2.1-1             5.22.3-1
                    polkit-kde-agent           5.22.2.1-1             5.22.3-1
                             poppler            21.06.1-1            21.07.0-1
                        poppler-glib            21.06.1-1            21.07.0-1
                         poppler-qt5            21.06.1-1            21.07.0-1
                         poppler-qt6            21.06.1-1            21.07.0-1
                          powerdevil           5.22.2.1-2             5.22.3-1
                              pyalpm             0.10.5-1             0.10.6-1
                        pyqt-builder             1.10.1-1             1.10.3-1
                              python              3.9.5-3              3.9.6-1
                       python-opencv              4.5.2-4              4.5.3-1
                   python-setuptools           1:57.0.0-2           1:57.1.0-1
                        python-tests              3.9.5-3              3.9.6-1
                      python-urllib3             1.26.5-1             1.26.6-1
                  python-urllib3-doc             1.26.5-1             1.26.6-1
                     python2-urllib3             1.26.5-1             1.26.6-1
                            sddm-kcm           5.22.2.1-1             5.22.3-1
                             shaderc             2021.0-1             2021.1-1
                               spice             0.14.3-3             0.15.0-1
                      systemsettings           5.22.2.1-1             5.22.3-1
                     vulkan-broadcom             21.1.3-1             21.1.4-1
                  vulkan-mesa-layers             21.1.3-1             21.1.4-1
                       vulkan-radeon             21.1.3-1             21.1.4-1
                       vulkan-swrast             21.1.3-1             21.1.4-1
              xdg-desktop-portal-kde           5.22.2.1-1             5.22.3-1


:: Different overlay package(s) in repository kde-unstable aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2021-07-02           2021-07-07
-------------------------------------------------------------------------------
                           akregator21.04.2.r6167.gbbef7d65-121.04.2.r6168.g0babd287-1
                          artikulate21.04.2.r1384.g9c5d1cd-121.04.2.r1385.g92aea80-1
                                buho 1.2.2.r29.g5cb0188-1 1.2.2.r29.g5cb0188-2
                     calendarsupport21.04.2.r555.g2ac1a78-121.04.2.r558.g2215dc3-1
                           calindori  21.06.r4.g2b9bfcc-1  21.06.r5.gd655e21-1
                            discover5.22.2.1.r8214.gb4be338e-15.22.2.1.r8215.g725ae1f2-1
                             dolphin21.04.2.r6624.gcc962cae4-121.04.2.r6627.g902e8ee07-1
                     dolphin-plugins21.04.2.r584.gf9309d9-121.04.2.r586.g18cabb0-1
                             drkonqi5.22.2.1.r657.g8d7ff484-15.22.2.1.r658.g29546781-1
                 extra-cmake-modules5.83.0.r3330.g58731b0-25.83.0.r3331.gf776d39-1
                           filelight21.04.2.r975.ge6664ed-121.04.2.r976.g1702097-1
                     incidenceeditor21.04.2.r728.gfd12b98-121.04.2.r733.gc4304cf-1
                            index-fm 1.2.2.r76.g4985fd8-1 1.2.2.r77.gd9d681e-2
                           itinerary21.04.2.r1339.g6d444ee-121.04.2.r1343.gfab4b91-1
                                 k3b1:21.04.2.r6644.gcaa29afe2-11:21.04.2.r6646.gb203c9e12-1
                            kanagram21.04.2.r1277.g1c064a6-121.04.2.r1278.gd2d336b-1
                               kasts 21.06.r33.gacef37f-1 21.06.r34.gd0bc5b2-1
                                kate21.04.2.r18252.g1cea8a677-121.04.2.r18261.g53e83185a-1
                       kcalendarcore5.83.0.r1216.gdd6cfda70-25.83.0.r1217.gcf903ae1d-1
                              kclock 21.06.r12.g33407ad-1 21.06.r13.g5b8cf12-1
                         kcoreaddons5.83.0.r1237.g200239c1-25.83.0.r1238.g718ec693-1
                              kcrash5.83.0.r389.ge536b60-25.83.0.r398.g6077f47-1
                     kde-dev-scripts21.04.2.r4136.g0d347b0-121.04.2.r4137.g8f98b13-1
                          kdeconnect21.04.2.r3269.g0d2a15c4-121.04.2.r3272.gea8ed5c4-1
                                kded5.83.0.r406.g1dadf7a-25.83.0.r407.g4eda499-1
                       kdepim-addons21.04.2.r4182.g56a89c3c-121.04.2.r4191.gb6b41223-1
                    kdeplasma-addons5.22.2.1.r8547.g8a8ba22a2-15.22.2.1.r8549.g0b660afd1-1
                               kdesu5.83.0.r466.g1980f27-25.83.0.r467.g050de94-1
                         kgoldrunner21.04.2.r1226.gb5325c0-121.04.2.r1228.gd0a5276-1
                            khangman21.04.2.r1558.gd42fff7-121.04.2.r1560.ge45af9d-1
                               ki18n5.83.0.r468.g0826840-25.83.0.r469.gd181a83-1
                                kigo21.04.2.r513.gb11bf39-121.04.2.r515.g8701c1b-1
                                 kio5.83.0.r4820.g44d9f763-25.83.0.r4822.gfb9bbb6f-1
                            klettres21.04.2.r909.g40e40d4-121.04.2.r910.gffbe82f-1
                           knewstuff5.83.0.r1178.gc1c9e09d-25.83.0.r1179.gc1301e0f-1
                         kolourpaint21.04.2.r2345.g13caa156-121.04.2.r2346.g32ab2886-1
                             konsole21.04.2.r7862.g7cbbc88c-121.04.2.r7867.gd468bbab-1
                        konversation21.04.2.r8980.g179805d3-121.04.2.r8982.g4be5cb00-1
                              kparts5.83.0.r510.g577607c-25.83.0.r511.g0a39505-1
                    kpublictransport21.04.2.r1688.g1c5cf816-121.04.2.r1689.g558a5b5a-1
                          ksnakeduel21.04.2.r792.g4240078-121.04.2.r794.g6dad1da-1
                           ksysguard5.22.2.1.r3506.g93c4b8e4-15.22.2.1.r3507.g9bc6de87-1
                         ktexteditor5.83.0.r2896.ge3c373a6-25.83.0.r2897.g0194c22d-1
                               ktrip 21.06.r21.g7d13e51-1 21.06.r22.g1c9b25a-1
                                kwin5.22.2.1.r19597.gf54d7a269-15.22.2.1.r19600.g8386a8bb6-1
                              kwinft5.22.0.r18962.gedc9640a2-15.22.0.r18970.g15ebb3fb5-1
                           kwordquiz21.04.2.r1136.ged21a88-121.04.2.r1137.gae54e22-1
                              kwrite21.04.2.r18252.g1cea8a677-121.04.2.r18261.g53e83185a-1
                           libksieve21.04.2.r1533.gefe5c81a-121.04.2.r1534.g7716481f-1
                        libksysguard5.22.2.1.r2241.g2660f2d-15.22.2.1.r2245.g402b521-1
                         libquotient     r2002.gac8a448-1     r2006.g74dda96-1
                              marble21.04.2.r13314.g227816388-121.04.2.r13315.g446a2e579-1
                       marble-common21.04.2.r13314.g227816388-121.04.2.r13315.g446a2e579-1
                           marble-qt21.04.2.r13314.g227816388-121.04.2.r13315.g446a2e579-1
                           maui-clip  1.1.1.r8.gb3d9db9-1  1.1.1.r8.gb3d9db9-2
                           maui-nota 1.2.2.r44.g82927e9-1 1.2.2.r44.g82927e9-2
                            maui-pix 1.2.2.r50.g7b5b00d-1 1.2.2.r52.g153b4f4-1
                    mauikit-accounts         r6.8f01110-1         r6.8f01110-2
                mauikit-filebrowsing 1.2.2.r57.g0134185-1 1.2.2.r59.gbb9ca4c-2
                  mauikit-imagetools 1.2.2.r14.g3d4db50-1 1.2.2.r16.g9f9e1a4-1
                             neochat    r1779.g6bbb4b49-1    r1780.g53741635-1
                              okular21.04.2.r9382.gd8845025f-121.04.2.r9385.g7c9322ad7-1
                              parley21.04.2.r4410.g5f463910-121.04.2.r4412.g77e052c7-1
                      plasma-desktop5.22.2.1.r8531.gf3e9dbf86-15.22.2.1.r8533.g28723b62f-1
                    plasma-framework5.83.0.r15899.gd809e9e4d-15.83.0.r15902.g2ad8174b4-1
                           plasma-nm5.22.2.1.r3060.g1f6b9980-15.22.2.1.r3061.gf6e45d40-1
                           plasma-pa5.22.2.1.r948.ga6d63ee-15.22.2.1.r949.g5a0d555-1
             plasma-phone-components5.22.2.1.r1422.g844be837-15.22.2.1.r1423.g7c8fc779-1
              plasma-wayland-session5.22.2.1.r10417.g211897b07-15.22.2.1.r10422.gfce72eea0-1
                    plasma-workspace5.22.2.1.r10417.g211897b07-15.22.2.1.r10422.gfce72eea0-1
         plasma-workspace-wallpapers5.22.2.1.r276.gdadaf13-15.22.2.1.r278.g90dc1bd-1
                       pulseaudio-qt  1.3.0.r0.g204f0ca-1  1.3.0.r1.gb035878-1
                  qqc2-desktop-style5.83.0.r492.g5a1561c-25.83.0.r493.ge224a1d-1
                      systemsettings5.22.2.1.r2446.g45956103-15.22.2.1.r2447.gda1ff253-1
                               vvave 1.2.2.r40.gd794531-1 1.2.2.r40.gd794531-2
                  mauikit-texteditor                    -  1.2.2.r7.gaa0d310-2



Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #arm:testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Keyring issues
If you have some gpg keyring issues, you can run sudo systemctl start pacman-init.service which will regenerate your keyring. Will take a few minutes to complete.

Old Issues

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login.
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-3.1 and qt5-es2-declarative-5.15.2+kde+r28-3.1.

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Neovim 0.5.0 :heart_eyes:

Hi,

Odroid C4 kde up to date.

Enjoy !

866f49bce2e10f77f01d27a83a79aa5279cd2417_2_666x500