[ARM Testing Update] 2020-10-25 - Manjaro ARM Tools and Installer and kernels

Hello ARM community.

Small update this time.


Some highlights:

  • A couple of our kernels got updated
  • Manjaro ARM Tools got updated to 2.9.2
  • Our Manjaro ARM Installer also got updated to 1.3.6
  • Some python packages got updated

Upstream Notifications:

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
https://www.archlinux.org/news/ghostpcl9532-2-and-ghostxps9532-2-updates-require-manual-intervention/

Older notifications

The nss package requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention
The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention


Package Changes

(Sun Oct 25 16:13:56 CET 2020)

  • arm-testing community aarch64: 272 new and 269 removed package(s)
  • arm-testing core aarch64: 7 new and 7 removed package(s)
  • arm-testing extra aarch64: 35 new and 33 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-10-21         2020-10-25
-------------------------------------------------------------------------------
                          attica-git5.76.0.r768.g62f7183-15.76.0.r769.g99b7f83-1
                           baloo-git5.76.0.r2856.gbc336aaa-15.76.0.r2857.gbb79363b-1
                       bluedevil-git5.20.80.r2176.g88274907-15.20.80.r2179.ga0d8abb1-1
                        bluez-qt-git5.76.0.r613.g81ff058-15.76.0.r614.g2c4c506-1
                          breeze-git5.20.80.r2070.g6c98f256-15.20.80.r2076.g94ec8340-1
                        discover-git5.20.80.r7852.gea7edc4d-15.20.80.r7855.g4c302ab3-1
                         drkonqi-git5.20.80.r545.ge3b9a511-15.20.80.r552.ged18a6be-1
                            electron             10.1.4-1             10.1.5-1
                        geary-mobile             3.36.2-13.36.3.1+1+g2617191c-2
               kactivities-stats-git5.76.0.r303.gdac6ad5-15.76.0.r304.gade3c40-1
               kactivitymanagerd-git5.15.80.r1309.g02f92d5-15.15.80.r1310.g048acb7-1
                           kauth-git5.76.0.r387.ga4b3e2c-15.76.0.r388.gd5ab456-1
                      kbookmarks-git5.76.0.r361.g6c9ddda-15.76.0.r362.gcc34763-1
                        kcmutils-git5.76.0.r444.g088e502-15.76.0.r448.g23569b2-1
                         kcodecs-git5.76.0.r325.g09fb37e-15.76.0.r326.gff4ba4a-1
                     kcompletion-git5.76.0.r389.gaacaace-15.76.0.r390.gefd6ff3-1
                         kconfig-git5.76.0.r738.gc81dfc9-15.76.0.r740.g637775d-1
                  kconfigwidgets-git5.76.0.r510.g52ea807-15.76.0.r511.g97b8f85-1
                     kcoreaddons-git5.76.0.r1043.g1374358-15.76.0.r1050.g378c217-1
                   kde-cli-tools-git5.20.80.r1810.g8ff56c1-15.20.80.r1813.g84fda4b-1
                  kde-gtk-config-git5.20.80.r861.g1b77d9e-15.20.80.r862.gba0d3f4-1
                    kdeclarative-git5.76.0.r817.g6f23459-15.76.0.r819.g16f95bd-1
                     kdecoration-git5.20.80.r238.g46b7027-15.20.80.r239.gf6367b9-1
                            kded-git5.76.0.r354.g8fe52a2-15.76.0.r355.g5e1b7f3-1
                 kdelibs4support-git5.76.0.r964.g339f4152-15.76.0.r965.gc96452e0-1
                kdeplasma-addons-git5.20.80.r8410.g44c803b46-15.20.80.r8413.g2ce2e554c-1
                           kdesu-git5.76.0.r418.g816ccba-15.76.0.r419.g47e503d-1
                   kfilemetadata-git5.76.0.r721.g7c90edd-15.76.0.r722.g7bd0cde-1
                         kgamma5-git5.20.80.r431.gf316a75-15.20.80.r433.gc290f5a-1
                    kglobalaccel-git5.76.0.r386.gba1ad2c-15.76.0.r388.g3b9a6ba-1
                        khotkeys-git5.20.80.r2028.gac43af9-15.20.80.r2032.g18fc848-1
                           khtml-git5.76.0.r510.gb0d8241-15.76.0.r511.g076ccad-1
                     kiconthemes-git5.76.0.r446.g3ce54ad-15.76.0.r447.gdd64753-1
                     kinfocenter-git5.20.80.r1758.gc87bdc9-15.20.80.r1761.g228160a-1
                           kinit-git5.76.0.r362.ga47bfcd-15.76.0.r363.ga160762-1
                      kio-extras-git    r6889.g7b9bd6fd-1    r6890.g81aed75e-1
                             kio-git5.76.0.r4255.gc02ce902-15.76.0.r4271.g13ef93f0-1
                       kirigami2-git5.76.0.r2463.g4c0a099b-15.76.0.r2465.g17cada70-1
                     kitemmodels-git5.76.0.r479.g03e22f3-15.76.0.r483.g4fe2763-1
                      kitemviews-git5.76.0.r284.gddd6d49-15.76.0.r285.g49f3184-1
                             kjs-git5.76.0.r296.ga3fa2de-15.76.0.r297.g44a89bb-1
                        kjsembed-git5.76.0.r259.g8b742aa-15.76.0.r260.gb06fe7d-1
                       kmenuedit-git5.20.80.r934.g92f41ee-15.20.80.r935.g331cd60-1
                      knetattach-git5.20.80.r7934.gc416ec4f8-15.20.80.r7947.gbdb719b3b-1
                       knewstuff-git5.76.0.r955.g36a5cfed-15.76.0.r958.ga95e5037-1
                  knotifications-git5.76.0.r574.gc58ac88-15.76.0.r575.g8365ca9-1
                        kpackage-git5.76.0.r606.g1ed1937-15.76.0.r607.ga21708c-1
                          kparts-git5.76.0.r442.g2811bca-15.76.0.r444.ge02d98f-1
                         kpeople-git5.76.0.r1272.g7a3fa53-15.76.0.r1273.g147cb4e-1
                           kross-git5.76.0.r293.gffbafef-15.76.0.r294.g98705da-1
                         krunner-git5.76.0.r519.gb11fba3-15.76.0.r520.g5e9789d-1
                         kscreen-git5.20.80.r1275.g49c5d9c-15.20.80.r1278.ge028473-1
                   kscreenlocker-git5.20.80.r804.g7243941-15.20.80.r806.g243ff3a-1
                        kservice-git5.76.0.r824.g0112e08-15.76.0.r826.g167aee0-1
                       ksysguard-git5.20.80.r3406.geecb2abc-15.20.80.r3408.gb3812a30-1
                     ktexteditor-git5.76.0.r2527.ge0fa5660-15.76.0.r2528.g5295e3c8-1
                   kuserfeedback-git       r703.4e8cbbe-1       r704.83982f1-1
                         kwallet-git5.76.0.r1012.g47a7d17-15.76.0.r1013.gf69c0ac-1
                        kwayland-git5.76.0.r1030.g7ae2c2e-15.76.0.r1031.g8150884-1
            kwayland-integration-git5.20.80.r156.g1d9b99d-15.20.80.r157.g7632cc5-1
                 kwayland-server-git5.20.80.r1153.g2e2441b-15.20.80.r1154.g044aff7-1
                  kwidgetsaddons-git5.76.0.r722.g4f998260-15.76.0.r724.gec9881cd-1
                            kwin-git5.20.80.r18523.g733692f43-15.20.80.r18530.g6b940c128-1
                   kwindowsystem-git5.76.0.r536.g64d189a-15.76.0.r537.ge08735d-1
                         kxmlgui-git5.76.0.r672.g253e033-15.76.0.r673.g66a9b22-1
                        libkgapi-git      r1208.17da335-1      r1211.6fa8198-1
                      libkscreen-git5.20.80.r1532.gcad5bd7-15.20.80.r1536.gbe83b5d-1
                    libksysguard-git5.20.80.r1997.g77ec100-15.20.80.r1999.ge5f0f06-1
               manjaro-arm-installer              1.3.5-1              1.3.6-1
                           milou-git5.20.80.r711.gebe7051-15.20.80.r712.g766e0d6-1
                 modemmanager-qt-git5.76.0.r470.gfd95527-15.76.0.r471.gf59358f-1
               networkmanager-qt-git5.76.0.r1066.g68bb082-15.76.0.r1067.g625c3a5-1
                          oxygen-git5.20.80.r4394.g101cc7d9-15.20.80.r4395.gfb1d2c2f-1
                                phoc              0.4.3-4   0.4.3+8+gf153f89-2
                               phosh  0.4.5+10+gb8e666b-2  0.4.5+13+gd0be671-3
              pinephone-post-install           20201009-1           20201022-1
      plasma-browser-integration-git5.20.80.r1143.gf58536fd-15.20.80.r1144.ge826dd21-1
                  plasma-desktop-git5.20.80.r7934.gc416ec4f8-15.20.80.r7947.gbdb719b3b-1
                plasma-framework-git5.76.0.r15616.gfa06d610d-15.76.0.r15624.gd578c2a15-1
              plasma-integration-git5.20.80.r484.g2984a40-15.20.80.r490.g6e81914-1
                       plasma-nm-git5.20.80.r2959.g1b52b812-15.20.80.r2963.gd5c06dfd-1
                       plasma-pa-git5.20.80.r853.gecbdf39-15.20.80.r859.g04ac96d-1
         plasma-phone-components-git      r1219.dbcbf21-1      r1228.d6dd1c1-1
                      plasma-sdk-git5.20.80.r2218.gcd100d23-15.20.80.r2219.gb85f7fab-1
                 plasma-settings-git       r789.73eaade-1       r790.7c887bd-1
                    plasma-vault-git5.20.80.r301.gc744953-15.20.80.r302.g4375903-1
          plasma-wayland-session-git5.20.80.r9546.g4915766bb-15.20.80.r9558.gdc509cfd5-1
                plasma-workspace-git5.20.80.r9546.g4915766bb-15.20.80.r9558.gdc509cfd5-1
                polkit-kde-agent-git5.20.80.r467.g2f70fe3-15.20.80.r469.g728e2f9-1
                      powerdevil-git5.20.80.r2369.g15b92adb-15.20.80.r2372.g13059717-1
                          prison-git5.76.0.r272.gc36407d-15.76.0.r273.gc863ebf-1
                         purpose-git5.76.0.r794.ge9f956c-15.76.0.r796.g920a693-1
                        sddm-kcm-git5.20.80.r544.g74f0560-15.20.80.r545.g9f0a6cc-1
                           solid-git5.76.0.r614.g158dcd5-15.76.0.r616.ga41ce6a-1
                          sonnet-git5.76.0.r559.g50cf998-15.76.0.r560.g40d1c87-1
                         squeekboard  1.9.3+72+g65425ff-1  1.10.0+1+g17ce0b6-1
                     syndication-git5.76.0.r786.g6f63774-15.76.0.r787.g1524ab9-1
             syntax-highlighting-git5.76.0.r1346.g9a9faa4c-15.76.0.r1351.g544c5773-1
                  systemsettings-git5.20.80.r2298.gf946d9da-15.20.80.r2301.gc6c1155e-1
                    threadweaver-git5.76.0.r454.gabe37fe-15.76.0.r455.g99f6e9e-1
                    user-manager-git5.19.90.r499.g36dfbff-15.19.90.r501.g1b71858-1
          xdg-desktop-portal-kde-git5.20.80.r321.g5094b7e-15.20.80.r323.g4bb5086-1
                          bmap-tools                    -                3.5-1


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-10-21         2020-10-25
-------------------------------------------------------------------------------
                            adriconf                1.7-1                2.4-1
                 archlinux-wallpaper                1.4-7              1.6.1-1
                             aws-cli           1.18.152-1           1.18.162-1
                              awxkit             15.0.0-1             15.0.1-2
                            birdfont             2.29.0-2             2.29.1-1
                                 bpf                5.7-1                5.9-1
                               broot              1.0.2-1              1.0.4-1
                             buildah             1.16.4-1             1.16.5-1
                             cawbird              1.1.0-1              1.2.1-1
                           celluloid               0.19-1               0.20-1
               cgroup_event_listener                5.7-1                5.9-1
                               clash              1.1.0-1              1.2.0-1
                             clojure            1.10.1-11            1.10.1-12
                            cppcheck                2.1-1                2.2-1
                            cpupower                5.7-1                5.9-1
                                croc              8.5.2-1              8.6.4-1
                            deja-dup               42.4-2               42.5-1
                          disomaster              5.0.1-1              5.0.3-1
                             drawing             0.4.13-1              0.6.2-1
                               eolie             0.9.99-1            0.9.100-1
                              eslint             7.11.0-1             7.12.0-1
                            firejail          0.9.64rc1-2             0.9.64-1
                           flowblade                2.6-1              2.6.2-1
                                 fzf             0.23.1-1             0.23.1-2
                              glider             0.12.0-1             0.12.1-1
                           glusterfs              1:8.1-1              1:8.2-1
                       gnome-applets             3.36.4-2             3.38.0-1
                     gnome-flashback             3.36.5-1             3.38.0-1
                 gnome-initial-setup             3.36.4-1             3.38.1-1
                         gnome-panel             3.36.2-1             3.38.0-1
                             gnubiff             2.2.17-6             2.2.17-7
                          gpio-utils                5.7-1                5.9-1
                              gpxsee               7.31-1               7.34-1
                            griffith               0.15-4               0.16-1
                          grub-btrfs                4.6-1              4.7.1-1
                gst-editing-services             1.16.2-1             1.18.0-1
                     gtk-layer-shell              0.3.0-1              0.4.0-2
                              hyperv                5.7-1                5.9-1
                             i3-gaps             4.18.2-2             4.18.3-1
                           iio-utils                5.7-1                5.9-1
                         jami-daemon           20200925-1           20201023-1
                          jami-gnome           20200921-1           20201019-1
                             jenkins              2.262-1              2.263-1
                          jupyterlab              2.2.8-1              2.2.9-1
                           kdiskmark              1.6.2-1              2.0.0-1
                           keepassxc              2.6.1-2              2.6.2-1
                               kicad              5.1.7-1              5.1.7-2
                       kodi-platform  20190726.809c5e9-15  20190726.809c5e9-17
                              kupfer                319-4                320-1
                             libavif              0.8.1-3              0.8.2-1
                           libinsane              1.0.4-1              1.0.8-1
                       libjamiclient           20200921-1           20201021-1
                          libmanette              0.2.4-1              0.2.5-1
                          librdkafka              1.5.0-1              1.5.2-1
                            libressl              3.2.1-1              3.2.2-1
                 libretro-beetle-pce               1044-1               1047-1
            libretro-beetle-pce-fast               1075-1               1076-1
                 libretro-beetle-psx               2467-1               2469-1
              libretro-beetle-psx-hw               2467-1               2469-1
                    libretro-dolphin              32962-1              32964-1
                    libretro-flycast               4213-1               4227-1
                   libretro-gambatte                846-1                849-1
                       libretro-mgba               6826-1               6830-1
                        libsecp256k120200919+1172+gd7838ba-120201021+1209+gac05f61-1
                       libtraceevent                5.7-1                5.9-1
                          libxmlbird             1.2.11-2             1.2.12-1
                    linux-tools-meta                5.7-1                5.9-1
                             liteide               37.2-2               37.3-1
                           lostfiles               4.05-1               4.07-2
                 mailnag-gnome-shell             3.36.0-1             3.38.0-1
                              marked              1.2.0-1              1.2.2-1
                        matterbridge             1.18.3-1             1.19.0-1
                       mediastreamer              4.4.3-1              4.4.6-1
                            metacity             3.36.1-1             3.38.0-1
                              minder              1.9.0-1             1.11.3-1
                   modem-manager-gui           0.0.19.1-5             0.0.20-1
                            molecule              3.1.3-1              3.1.4-1
                           nextcloud             20.0.0-1             20.0.1-1
                nextcloud-app-spreed           1:10.0.0-1           1:10.0.1-1
                             ngspice                 32-1                 33-1
                   npm-check-updates              9.1.0-1              9.2.2-1
                            nvme-cli               1.12-2               1.13-1
                            openlibm              0.7.1-1              0.7.2-1
                           osinfo-db           20200529-1           20201015-1
                                perf                5.7-1                5.9-1
                   perl-file-homedir              1.004-3              1.006-1
                    perl-test-simple           1.302182-1           1.302183-1
                    perl-test2-suite           0.000136-1           0.000138-1
                           perl-tidy           20200619-1           20201001-1
                            perlbrew               0.87-2               0.89-1
                              phodav                2.4-1                2.5-1
                           php-redis              5.3.1-1              5.3.2-1
                              picard              2.4.4-1                2.5-1
                              pitivi              0.999-4          2020.09.1-1
                     python-atpublic                2.0-1                2.1-1
                        python-boto3            1.15.11-1             1.16.2-1
                     python-botocore            1.18.11-1             1.19.2-1
                      python-breathe             4.22.1-1             4.23.0-1
                     python-cfn-lint             0.38.0-1             0.39.0-1
                    python-databases              0.3.2-1              0.4.0-1
                     python-dominate              2.5.2-1              2.6.0-1
                   python-flufl-lock              5.0.1-1              5.0.2-1
                   python-flufl.i18n              3.0.1-1              3.1.2-1
                       python-fsspec              0.8.3-1              0.8.4-1
                          python-fxa              0.7.6-1              0.7.7-1
                        python-gdspy                1.6-1              1.6.1-1
                     python-graphene            3.0.0b5-1            3.0.0b6-1
                       python-hunter              3.2.2-1              3.3.1-1
                   python-hypothesis             5.36.1-1             5.37.4-1
           python-importlib-metadata              1.6.1-1              2.0.0-1
          python-importlib_resources              3.0.0-1              3.1.1-1
                         python-ipdb             0.13.3-1             0.13.4-1
                  python-jack-client              0.5.2-1              0.5.3-1
               python-logilab-common              1.7.3-1              1.8.0-1
       python-marshmallow-sqlalchemy             0.23.1-1             0.24.0-1
                         python-milc              1.0.8-1              1.0.9-1
                     python-pdfminer           20200726-1           20201018-1
                      python-pkginfo            1.5.0.1-4              1.6.0-1
                     python-pygments              2.7.1-1              2.7.2-1
                    python-pykeepass              3.2.0-1              3.2.1-1
                python-pytest-django              4.0.0-1              4.1.0-1
                       python-pytrie              0.3.1-4              0.4.0-1
                    python-rapidjson              0.9.1-1              0.9.2-1
              python-readme-renderer               27.0-1               28.0-1
                         python-rich              8.0.0-1              9.0.1-2
                       python-semver             2.12.0-1             2.13.0-1
                           python-sh             1.14.0-2             1.14.1-1
                   python-tldextract              2.2.3-1              3.0.1-1
                     python-zeroconf             0.25.1-1             0.28.6-1
                         python-zipp              3.3.1-1              3.3.2-1
          python2-importlib-metadata              1.6.1-1              2.0.0-1
                                pyzo             4.10.2-1             4.11.0-1
                                qcad           3.25.2.0-1           3.25.2.1-1
                            qxmledit             0.9.15-2             0.9.16-1
                         rednotebook               2.19-2               2.20-1
                            restinio             0.6.10-1             0.6.11-1
               retroarch-assets-glui              1:341-1              1:343-1
              retroarch-assets-ozone              1:341-1              1:343-1
                retroarch-assets-xmb              1:341-1              1:343-1
                        ruby-faraday              1.0.1-1              1.1.0-1
                         ruby-reline              0.1.5-1              0.1.6-1
                      sensors-applet  3.0.0+13+g0728426-3  3.0.0+13+g0728426-4
                             sha3sum              1.1.5-3                1.2-1
                           simutrans              121.0-1              122.0-1
                     simutrans-pak64              121.0-1              122.0-1
                                skim              0.9.1-1              0.9.2-1
                              solaar              1.0.3-1              1.0.4-1
                              stella              6.2.1-1                6.3-1
                          strawberry              0.8.2-1              0.8.3-1
                          streamlink              1.6.0-1              1.7.0-1
                             superlu             5.2.1-10              5.2.2-1
                                tmon                5.7-1                5.9-1
                               toxic              0.8.3-3              0.8.4-1
                  ttf-jetbrains-mono              2.002-1              2.200-1
                   ttf-sarasa-gothic             0.14.3-1             0.14.4-1
                            tupitube             0.2.15-2             0.2.16-1
                 ukui-control-center              3.0.1-1              3.0.1-2
                               usbip                5.7-1                5.9-1
                               v2ray             4.31.2-1             4.31.3-1
         v2ray-domain-list-community     20201017062631-1     20201022051534-1
                         v2ray-geoip       202010191346-1       202010220018-1
                           verilator              4.036-1              4.102-1
                          wanderlust           20191018-2           20201022-1
                  webp-pixbuf-loader              0.0.1-4              0.0.2-1
                            workrave            1.10.44-1            1.10.44-2
                           xournalpp             1.0.18-2             1.0.19-1
                                 yad                7.2-1                7.3-1
                             plocate                    -              1.0.5-1
                     python-filetype                    -              1.0.7-1


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-10-21         2020-10-25
-------------------------------------------------------------------------------
                               linux              5.9.1-1              5.9.1-3
                       linux-headers              5.9.1-1              5.9.1-3
                         uboot-vim3l                    -            2020.10-1


:: Different sync package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-10-21         2020-10-25
-------------------------------------------------------------------------------
                               expat              2.2.9-3             2.2.10-2
                                grep                3.4-1                3.5-1
                             libpcap              1.9.1-2              1.9.1-4
                              libusb             1.0.23-2             1.0.23-3
                              xinetd             2.3.15-6                    -


:: Different overlay package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-10-21         2020-10-25
-------------------------------------------------------------------------------
                   manjaro-arm-tools              2.9.1-1              2.9.2-1


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-10-21         2020-10-25
-------------------------------------------------------------------------------
                       alsa-firmware              1.2.4-1              1.2.4-2
                            alsa-lib              1.2.4-2              1.2.4-3
                  alsa-topology-conf              1.2.4-1              1.2.4-2
                       alsa-ucm-conf              1.2.4-1              1.2.4-2
                          alsa-utils              1.2.4-1              1.2.4-2
                                bind             9.16.7-1             9.16.8-1
                              brltty               6.0-11                6.1-2
                            chromium       86.0.4240.75-1      86.0.4240.111-2
                            composer            1.10.15-1            1.10.16-1
                             enchant             2.2.10-1             2.2.11-1
                                 git             2.29.0-1             2.29.1-1
                             libnice             0.1.17-1             0.1.18-1
                            libunrar            1:5.9.4-1            1:6.0.1-1
                             liferea             1.13.2-1             1.13.3-1
                                 mpd               0.22-1             0.22.1-1
                             ocl-icd             2.2.12-4             2.2.13-1
                      opencl-headers     2:2.2.20170516-3       2:2020.06.16-1
                        perl-net-dns               1.27-1               1.28-1
                        python-isort              5.6.3-1              5.6.4-1
                   python-virtualenv            20.0.29-1            20.0.32-1
                  python2-virtualenv            20.0.29-1            20.0.32-1
                                qemu              5.1.0-1              5.1.0-2
                     qemu-arch-extra              5.1.0-1              5.1.0-2
                  qemu-block-gluster              5.1.0-1              5.1.0-2
                    qemu-block-iscsi              5.1.0-1              5.1.0-2
                    qemu-guest-agent              5.1.0-1              5.1.0-2
                       qemu-headless              5.1.0-1              5.1.0-2
            qemu-headless-arch-extra              5.1.0-1              5.1.0-2
                                 rcs              5.9.4-3             5.10.0-1
                               sushi 3.34.0+19+g331d9b7-1             3.38.0-1
                               unrar            1:5.9.4-1            1:6.0.1-1
                          webkit2gtk             2.30.1-1             2.30.2-1
                        opencl-clhpp                    -             2.0.12-1
                              xinetd                    -           2.3.15.4-1

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #arm:testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.

Old Issues

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

After this update plasma UI does not start anymore.
Rpi4 boots and shows login manager. But after login it ends in a black screen with curser only.

The only plasma related packages updated in this update, is the -git ones, which you shouldn’t be running.

Hi,

@turux

Odroid c4 kde up to date, it works. no issue with the gui or cli to reboot the device.

[nlc4@c4 ~]$ sudo pacman -Syyuu
[sudo] password for nlc4: 
:: Synchronising package databases...
 core                                   222,9 KiB   398 KiB/s 00:01 [######################################] 100%
 extra                                    2,4 MiB   465 KiB/s 00:05 [######################################] 100%
 community                                5,5 MiB   523 KiB/s 00:11 [######################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (10) alsa-lib-1.2.4-3  alsa-topology-conf-1.2.4-2  alsa-ucm-conf-1.2.4-2  alsa-utils-1.2.4-2
              expat-2.2.10-2  git-2.29.1-1  grep-3.5-1  libpcap-1.9.1-4  libusb-1.0.23-3  linux-5.9.1-3

Total Download Size:    67,09 MiB
Total Installed Size:  161,77 MiB
Net Upgrade Size:      -11,60 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 expat-2.2.10-2-aarch64                  93,8 KiB   586 KiB/s 00:00 [######################################] 100%
 grep-3.5-1-aarch64                     194,3 KiB   555 KiB/s 00:00 [######################################] 100%
 libpcap-1.9.1-4-aarch64                254,7 KiB   456 KiB/s 00:01 [######################################] 100%
 libusb-1.0.23-3-aarch64                 62,9 KiB   370 KiB/s 00:00 [######################################] 100%
 linux-5.9.1-3-aarch64                   59,6 MiB   406 KiB/s 02:30 [######################################] 100%
 alsa-topology-conf-1.2.4-2-any          13,3 KiB  0,00   B/s 00:00 [######################################] 100%
 alsa-ucm-conf-1.2.4-2-any               37,5 KiB  3,67 MiB/s 00:00 [######################################] 100%
 alsa-lib-1.2.4-3-aarch64               409,2 KiB   397 KiB/s 00:01 [######################################] 100%
 alsa-utils-1.2.4-2-aarch64            1003,1 KiB   383 KiB/s 00:03 [######################################] 100%
 git-2.29.1-1-aarch64                     5,5 MiB   433 KiB/s 00:13 [######################################] 100%
(10/10) checking keys in keyring                                    [######################################] 100%
(10/10) checking package integrity                                  [######################################] 100%
(10/10) loading package files                                       [######################################] 100%
(10/10) checking for file conflicts                                 [######################################] 100%
(10/10) checking available disk space                               [######################################] 100%
:: Processing package changes...
( 1/10) upgrading alsa-topology-conf                                [######################################] 100%
( 2/10) upgrading alsa-ucm-conf                                     [######################################] 100%
( 3/10) upgrading alsa-lib                                          [######################################] 100%
( 4/10) upgrading alsa-utils                                        [######################################] 100%
( 5/10) upgrading expat                                             [######################################] 100%
( 6/10) upgrading grep                                              [######################################] 100%
( 7/10) upgrading git                                               [######################################] 100%
( 8/10) upgrading libpcap                                           [######################################] 100%
( 9/10) upgrading libusb                                            [######################################] 100%
(10/10) upgrading linux                                             [######################################] 100%
:: Running post-transaction hooks...
(1/9) Creating system user accounts...
(2/9) Reloading system manager configuration...
(3/9) Reloading device manager configuration...
(4/9) Arming ConditionNeedsUpdate...
(5/9) Updating module dependencies...
(6/9) Updating linux module dependencies...
(7/9) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k 5.9.1-3-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.9.1-3-MANJARO-ARM
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(8/9) Updating uimg initcpios...
Image Name:   Ramdisk Image
Created:      Sun Oct 25 19:43:32 2020
Image Type:   AArch64 Linux RAMDisk Image (uncompressed)
Data Size:    8442089 Bytes = 8244.23 KiB = 8.05 MiB
Load Address: 00000000
Entry Point:  00000000
(9/9) Updating the info directory file...
[nlc4@c4 ~]$ reboot


[nlc4@c4 ~]$ screenfetch
                             nlc4@c4.test.2020.05.14
                             OS: Manjaro-ARM 20.10
                             Kernel: aarch64 Linux 5.9.1-3-MANJARO-ARM
         #####               Uptime: 0m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.0.18
        #######              Resolution: 1920x1080
      ###########            DE: KDE 5.75.0 / Plasma 5.20.1
     #############           WM: KWin
    ###############          GTK Theme: Breeze [GTK2/3]
    ################         Icon Theme: oxygen
   #################         Disk: 18G / 59G (31%)
 #####################       CPU: Unknown @ 4x 1.908GHz
 #####################       GPU: 
   #################         RAM: 546MiB / 3627MiB
                            
                            
                            
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.9.1-3-MANJARO-ARM #1 SMP Thu Oct 22 12:36:10 CEST 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$ 

git-2.29.0-1 package up date the 21, no issue, I boot the arm devices with the auto login, practice for the vnc…

[nlc4@c4 ~]$ date -u
jeu. 22 oct. 2020 13:56:47 UTC
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.9.0-2-MANJARO-ARM #1 SMP Thu Oct 15 17:43:05 +03 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$ sudo pacman -Syyuu
[sudo] password for nlc4: 
:: Synchronising package databases...
 core                                   223,1 KiB   383 KiB/s 00:01 [######################################] 100%
 extra                                    2,4 MiB   467 KiB/s 00:05 [######################################] 100%
 community                                5,5 MiB   469 KiB/s 00:12 [######################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (61) alsa-lib-1.2.4-2  alsa-topology-conf-1.2.4-1  alsa-ucm-conf-1.2.4-1  alsa-utils-1.2.4-1
              aom-2.0.0-1  bluedevil-1:5.20.1-1  breeze-5.20.1-1  breeze-gtk-5.20.1-1
              ca-certificates-mozilla-3.58-1  drkonqi-5.20.1-1  faad2-2.10.0-1  firefox-82.0-2
              firefox-ublock-origin-1.30.6-1  freetype2-2.10.4-1  git-2.29.0-1  

This latest update looks to be working great. My USB-C adapter is functioning again. Both USB hub and network adapter are working. Thanks.

1 Like

On the PinebookPro everything seems to be fine!

@ Strit, @nl.smart

Hi
I couldn’t analyze what went wrong, so I had to reinstall.
Now everything works again with my rpi4 and manjaro.
Thank you for your support.

1 Like

You’re welcome.

im using sway/wayland for Pi4, but testing did not had kernel-5.9 update.
even PIOS had 5.9 for testing(BRANCH=next), better VC4 upstream supported.

Not sure what you mean?

linux-rpi4-mainline should be at 5.9…
linux-rpi4 will be at 5.4 for a while still, since it’s based on LTS kernels. :slight_smile:

do i need -S linux-rpi4-mainline?
does it build from BRANCH=next github?

The question is, do you need kernel 5.9? Or is 5.4 still working fine for you.

linux-rpi4-mainline is built using this PKGBUILD:

Which seems to be using set commits for the build. I would image it uses this branch to build from:

as i said, 5.9 has tons of VC4 patches.

Yes. Upstream 5.9/5.10 has many vc4 patches, but I would assume that the Raspberry Pi foundation would backport all of those in to their default kernel branch that also Raspberry Pi OS uses, if the patches didn’t originate there.