[ARM Stable Update] 2022-11-12 - Gnome 43, Libcamera, ICU 72.1, QT 5.15.7 and Kernels

Hello ARM community.

So here’s the first major update after our last release. Lots of new stuff here!

Gnome 43 is now here

Some highlights:

  • Most of our kernels got updated
  • Gnome updated to 43.0, some theming might be off
  • ICU updated to 72.1
  • Readline updated to 8.2.001
  • KDE Gear applications updated to 22.08.3
  • Plasma updated to 5.26.2
  • Firefox updated to 106.0.4
  • QT5 updated to 5.15.7
  • Thunderbird updated to 102.4.2
  • Libcamera added to repositories
  • Gnome Console added to repositories
  • Lots of Ruby packages added to repository
  • Lots of updated packages for our Mobile offerings
  • The regular Python updates
  • And regular updates from upstream

Gnome 43 theme changes

Gnome 43 changes how themes are applied to the system, so when upgrading you might notice something is off with the theming.
We have tried to make it easy to get a pretty good theme going when updating, but it does require a few steps.

  1. Install adw-gtk3 and gradience. But you will need to set your own colors in Gradience after it’s installed.
  2. Open Gradience and import this preset and Apply it.
How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installed. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Removing python2 from the repositories

Older notifications

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

Chromium will loose sync support in early March:
Arch Linux - News: Chromium losing Sync support in early March

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss and zn_poly packages requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention
Arch Linux - News: zn_poly 0.9.2-2 update requires manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package changes:

(Sat Nov 12 22:13:29 CET 2022)

  • arm-stable community aarch64: 963 new and 851 removed package(s)
  • arm-stable core aarch64: 54 new and 54 removed package(s)
  • arm-stable extra aarch64: 1017 new and 993 removed package(s)
  • arm-stable kde-unstable aarch64: 412 new and 413 removed package(s)

See the full package list here

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Before 2022-10-31

Firefox shows wrong colors when playing video on Raspberry Pi 4

Since Mesa 22.2, Firefox has been showing weird colors when playing video on the Raspberry Pi 4. This is caused by an issue in upstream mesa, which was recently fixed.
Fix: Update to mesa 22.2.3-0.1 in the repository, which includes this fix.

Chromium in Wayland crashes with --in-process-gpu

Since Mesa 22.2.0, Chromium running in wayland sessions seems to crash when running with the --in-process-gpu option. Running in X11 seems fine, although it’s slow.
Workaround: Downgrade to mesa 22.1.7 from cache with sudo pacman -U /var/cache/pacman/pkg/mesa-22.1.7-*, until the issue is fixed upstream.

Before 2022-10-21

Plasma Mobile Dialer seems to be unreliable

Plasma Dialer 22.09 seems to have issues switching audio profiles and as such might require manual switching. Sometimes audio is completely missing.

Reduced video performance on youtube

Some may encounter reduced video playback performance on YouTube in Firefox with the new Mesa 22.2 drivers.
No workaround at this time.

Before 2022-08-23

Phosh crashes when closing apps

An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Before 2022-07-22

Mouse cursor is slow on Raspberry Pi

Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

Waydroid container cannot access internet

Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell
Old Issues
Plasma Dialer cannot answer calls

Sadly Plasma Dialer 22.02 has a serious regression with no known workaround. It’s not possible to accept incoming calls. Very sorry about this. Follow the upstream bug report. We will patch the package as soon as a solution is found.

Plasma Mobile - Black screen after update

We are seeing some reports about Plasma Mobile on the PinePhone only showing a black screen after entering the PIN after this update.
Workaround: Downgrade qt5-es2-wayland to 5.15.2+kde+r41 which is now back in Stable and Testing branch repositories.

New Breath theme not applying correctly

With the update to the new Breath theme, a migration package tries to apply the new theme correctly.
However this is not getting done for Plasma’s Lockscreen and the SDDM theme.
So please go through your settings after updating to make sure the themes are correctly applied.
Fix: manjaro-system should take care of this for you.

Plasma Mobile switch to ModemManager

With the PlaMo Gear 21.12 release, Plasma Mobile is now using ModemManager as the telephony stack. So in order to use SIM capabilities, you need to switch from using oFono to ModemManager.
Fix: Run sudo systemctl disable --now ofono ofonoctl && sudo systemctl enable --now ModemManager. You might have to reboot your phone for Plasma Mobile to pick up this change.

Plasma Mobile has does not launch after update
This was caused by an error in kwin 5.23.2 which only affects installs based on openGLES (qt5-es2).
Fix: Update to kwin 5.23.2-1.2 or above.

No ethernet on rk3399 boards
A recent kernel regression has resulted in built in ethernet on rk3399 based boards, such as RockPro64 and Rock Pi 4’s, no longer works on kernel 5.14. This is an upstream issue that has not been fixed yet.
Fix: Update to linux-5.14.1-2 or newer.

Vivaldi no longer working
The issue is present in all chrome based browser (except Chromium that got a patch for it).
It’s an issue with systemd-resolved and has been reported in the Arch Linux Bug Tracker.
Needs to be fixed by Vivaldi updates in the future.
Fix: Vivaldi 4.1.2369.21 fixed this issue.

Modemmanager-pp dependency issue
modemmanager-pp 1.16.10 depends on libqmi-pp and libmbim-pp, but they are no longer found in the repo.
Fixed by updated to modemmanager-pp 1.18rc1+2+ga20f2c05-2.

systemd-hook unsuccesful after pacman 6 update
After the pacman 6 update, updates will create this message in the post-transation hooks part:

Running the command manually works and there has been no issues reported as the result of this. This will either get fixed at some point in Pacman or SystemD.
Should be fixed with pacman-6.0.0-4

Keyring issues
If you have some gpg keyring issues, you can run sudo systemctl start pacman-init.service which will regenerate your keyring. Will take a few minutes to complete.
Should be fixed with manjaro-system-20210716-1

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login.
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-3.1 and qt5-es2-declarative-5.15.2+kde+r28-3.1.

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

One thing I have noticed with this update: The phone operator I use, HoT, is a virtual provider (in Austria) on the Magenta/T-Mobile network. Before this update, Plasma Mobile on my PinePhone was reporting that it was connected to “HoT”. Now, it reports that it is connected to “Magenta-T-”, which (aside from the truncation) is technically correct, but I doubt that this is what the operator intends to be displayed.

I guess that this is due to the ModemManager update:

modemmanager-pp            1.18.12-1             1.20.0-1

is it not? Shall I report this to ModemManager upstream?

I also noticed mine changes from “Telenor”, which is the main network it’s on, to “CBB”, which is actually my provider. So I guess you win some and you loose some.

So for you, it changed from the physical operator to the virtual one? For me, it did the opposite. Looks like different operators fill in the SIM card fields differently.

I think I will take this to ModemManager upstream also quoting your comment and see what they say.

Sadly, the update broke the iSCSI boot on my Raspberry Pis.
I’m still unsure what exactly broke, but it appears that the required initramfs iscsi hook isn’t executed anymore as the boot process hangs while waiting for the iSCSI root device to show up.

The iSCSI boot is configured as described in arch-wiki which worked without problems for quite some time now. Building the image with mkinitcpio correctly picks up the hook though.

mkinitcpio hook

run_hook () {
        msg "Mounting iSCSI target"
        iscsistart -i <initiator-iqn> -t <target-iqn> -g 1 -a <portal-ip> -d 1 -P 'node.conn[0].timeo.noop_out_interval=0' -P 'node.conn[0].timeo.noop_out_timeout=0' -P 'node.session.timeo.replacement_timeout=86400'

mkinitcpio install

build () {
        map add_module iscsi_tcp iscsi_ibft libiscsi libiscsi_tcp scsi_transport_iscsi crc32c
        add_checked_modules "/drivers/net"
        add_binary iscsistart

help () {
        This hook allows you to boot from an iSCSI target.


HOOKS="base udev autodetect modconf net iscsi block keyboard keymap resume filesystems fsck"

I have reported the ModemManager issue upstream, also pointing out the discrepancy between what I am seeing and what @Strit is seeing:

GT King Pro Manjaro-Arm-Gnome-linux-6.0.7-2. During upgrading to Arm-Stable-2022-11-12 encountered a System Freeze while scrolling Up and Down the “Gnome Terminal”. Waited for 15 minutes still the system is NOT responsive – Froze. HTOP Froze.

Power cycle, Manjaro-Arm-Gnome attempted to boot but could not boot up to Desktop Environment – Error – LOGOUT. Ctrl+Alt+F1/F2/F3 a few times trying to get into TTY. Finally managed to. Deleted /var/lib/pacman/db.lck". Performed system upgrade in tty:

sudo pacman -Syu

It continue to upgrade the remainder 63 packages.

After the system upgrade completed successfully, Reboot but still cannot boot up to Desktop Environment. Same errors.

Reflash Manjaro-Arm-Gnome 22.10 Release for GT King Pro on USB 3.0 Flash drive. System upgrade to Arm-Stable-2022-11-12 successfully but it takes a long time 75-90 minutes for:

:: Starting full system upgrade...
:: Replace dleyna-connector-dbus with extra/dleyna? [Y/n] Y
:: Replace dleyna-core with extra/dleyna? [Y/n] Y
:: Replace dleyna-renderer with extra/dleyna? [Y/n] Y
:: Replace dleyna-server with extra/dleyna? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
:: pipewire-alsa and pulseaudio-alsa are in conflict. Remove pulseaudio-alsa? [y/N] y

Packages (188) adwaita-icon-theme-43-1  alsa-card-profiles-1:0.3.59-3  alsa-lib-1.2.8-1  alsa-ucm-conf-1.2.8-1
               alsa-utils-1.2.8-1  boost-libs-1.80.0-3  box64-0.1.8-2  curl-7.86.0-1  dleyna-0.8.1-1
               dleyna-connector-dbus-0.4.1-1 [removal]  dleyna-core-0.7.0-3 [removal]

Total Download Size:    310.40 MiB
Total Installed Size:  1561.27 MiB
Net Upgrade Size:       188.50 MiB

Reboot and boot into Gnome-43. Thanks.

When I run rssguard, it immediately terminates with the error “rssguard: error while loading shared libraries: libQt6WebEngineWidgets.so.6: cannot open shared object file: No such file or directory”
When I looked at the qt6-webengine package, I see that it doesn’t include any .so files, whereas the aur package contains the following files:
qt6-webengine /usr/lib/libQt6WebEngineWidgets.prl
qt6-webengine /usr/lib/libQt6WebEngineWidgets.so
qt6-webengine /usr/lib/libQt6WebEngineWidgets.so.6
qt6-webengine /usr/lib/libQt6WebEngineWidgets.so.6.4.0

For some reason Arch Linux ARMs build system has issues building the qtwebengine packages sometimes. It seems to happen a lot. :frowning:

Is there a way I can fix it locally? Or is that something the Manjaro team has to take care of? Or will take care of?

Well you can build it locally, but that’s going to take a long while as you are essentially compiling a complete browser on your device.

Yeah that sounds sub-optimal. Is there any possibility of this bug being fixed in the near future?