[ARM Stable Update] 2021-09-28 - Firefox, Thunderbird, LibreOffice, Electron, Element and Kernels

The first issue is known, and will be dealt with in the next update. It’s just a key in our keyring that no longer exists.

The second “issue” could be related to the missing vivaldi-ffmpeg-codecs package. Try seeing if installing vivaldi-codecs-ffmpeg-extra-bin from the AUR solves it.

I tried you suggestion to install vivaldi-codecs-ffmpeg-extra-bin and here is the results

What do I do now?

Looks like you need to run the update_pkg.sh script to get the newest versions.

How do I do that?

Do like they say on the AUR page. This can’t be done with Pamac though, so you need to do it “the Arch way”.

I’m totally lost. The only thing I see is a pinned comment that says

lucifermstar commented on 2019-04-18 08:41

IF/WHEN the package goes out of date. Just download this repo and run ./update_pkg.sh and then build the package manually with makepkg. That should work until the version is updated on the AUR.

I still don’t know what to do

Hey, good ppl from Manjaro! :slight_smile:

My mouse cursor is jumping around the screen since the update. Both using the TP and an USB mouse. I can move it somewhat smoothly, when I move the cursor really-really slow. Is there anything I can do, to stop this?


In your PKGBUILD try changing:




My test download using wget using the variables from the PKGBUILD:

[ray@ray-pc Desktop]$ export pkgver=93.0.4577.63
[ray@ray-pc Desktop]$ export _ubuver=0ubuntu0
[ray@ray-pc Desktop]$ export _ubudist=18.04.1
[ray@ray-pc Desktop]$ wget http://security.ubuntu.com/ubuntu/pool/universe/c/chromium-browser/chromium-codecs-ffmpeg-extra_${pkgver}-${_ubuver}.${_ubudist}_amd64.deb
--2021-09-30 09:16:48--  http://security.ubuntu.com/ubuntu/pool/universe/c/chromium-browser/chromium-codecs-ffmpeg-extra_93.0.4577.63-0ubuntu0.18.04.1_amd64.deb
Resolving security.ubuntu.com (security.ubuntu.com)...,, 2001:67c:1562::15, ...
Connecting to security.ubuntu.com (security.ubuntu.com)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1134804 (1.1M) [application/x-debian-package]
Saving to: ‘chromium-codecs-ffmpeg-extra_93.0.4577.63-0ubuntu0.18.04.1_amd64.deb’
chromium-codecs-ffmpeg-extra_93.0.4577.63 100%[===================================================================================>]   1.08M  1.27MB/s    in 0.9s    
2021-09-30 09:16:49 (1.27 MB/s) - ‘chromium-codecs-ffmpeg-extra_93.0.4577.63-0ubuntu0.18.04.1_amd64.deb’ saved [1134804/1134804]
[ray@ray-pc Desktop]$

Thank you for the info. I was able to reproduce your test with no problems. I then changed


in the PKGBUILD .

After saving I went ahead and completed the build and got these results.Failed to build

What do I do now?

Sorry. I forgot to tell you to change the checksum in the PKGBUILD. Hold on will update in this post…

Change what is in bold in your PKGBUILD.


I changed the checksum as per your instructions.

After completing the build here are the results.

Download this package and install it:

sudo pacman -U vivaldi-codecs-ffmpeg-extra-bin-93.0.4577.63-1-aarch64.pkg.tar.zst


I had my pi3b+ testing the latest upstream linux-rc kernel fired up so tested on it with a mp4 movie and it worked surprising good.

Thank you! It works well. Here is a screenshot from a video in my favorites on my YouTube account.

Also here is a screenshot from my Twitch account.

I will be directing people on the Vivaldi Raspberry Pi forum to here so they can get the fix.

Unfortunately, running Waydroid suceeds with the first start only. After app exit or phone reboot - not anymore. I’m on manjaro-arm phosh on the PinePhone and still experience this issue after reflashing Manjaro. Any suggestions?

EDIT: It is working again with the following workaround.
Missing user permissions to r/w waydroid.log was the root of evil. For brief instructions, please see

Well it happened again, Strit. This update killed my NVMe SSD boot, just like before.

Because the updated system will no longer boot from NVMe, I booted from an SD card and copied the NVMe boot partition files over to my eMMC memory and changed extlinux.conf and /etc/fstab to boot from eMMC. It now boots from eMMC (/ is on NVMe and /boot is on eMMC) but I’m frustrated that these Manjaro updates have twice broken my NVMe boot! The cause is still unknown but last time I had to fully install a new release image to get NVMe boot back.

From my /var/cache/pacman/pkg/ contents, it appears that I have successfully updated this system twice with new kernels:


but 5.14.8-1 seems to have created a problem with NVMe boot.

I’ll try regressing back to the 5.14.2-1 kernel and switch the files back to NVMe boot and see what happens but I might not have time to do it for a day or two.

Regression back to the 5.14.2-1 kernel did not restore NVMe boot that was previously working after installing a recent Manjaro XFCE release.

Booting the NVMe system (NVMe /) from eMMC (eMMC /boot) continues to work but when I move the /boot files from eMMC to NVMe and change /etc/fstab to mount /boot on NVMe, it still fails to boot after the regression.

I might try regressing to 5.14.1-1 next or I might just live with eMMC boot, though I’d like to remove my eMMC entirely, if NVMe boot ever becomes sufficiently reliably for me to risk flashing U-boot to SPI.

I’ve noticed that initramfs varies in size considerably between linux versions. Why?

8410175 Oct 2 09:56 initramfs-linux.img
30624256 Sep 8 02:43 Image


13213087 Aug 22 10:50 initramfs-linux.img
31205888 Aug 18 00:33 Image

Sorry to comeback with that, but 3D slicers like Cura or PrusaSlicer still cannot launch. They used to work like a charm, but since about this summer, I tried what I could (not much) to fix it. I got the same problem as here described
[ray@pi4 ~]$ cura
Traceback (most recent call last):
File “/usr/bin/cura”, line 25, in
import pynest2d # @UnusedImport
ValueError: PyCapsule_GetPointer called with incorrect name

Any ideas?
Thank you

For some reason Arch Linux ARM does not seem to have been able to build the recent releases of both Cura and PrusaSlicer.

Their PKGBUILD is updated (because they get it directly from Arch x64, but the package is not in the repo, so I assume it is failing to be built.

Edit 1
Test building both Cura and Prusa-Slicer now.
Cura just built without issues. So will upload that to unstable branch later.
Prusa-Slicer was missing a dependency, since one of it’s dependencies dropped it recently. But it’s building after adding that. If/When it finishes, I will upload that to unstable branch as well.

Edit 2
Both packages built, just uploaded them to our unstable branch. No idea if they work or not, haven’t tested them. So if you can test them, @Ada, that would be awesome!

1 Like

Do you have any problems with WiFi on Pinebook Pro after “cold” boot when the device was charged using USB-C (when the device was turned off)? By the “problems” I mean WiFi working extremely slow or not working at all. Turning off and on “fixes” it.