[ARM Stable Update] 2021-02-21 - KDE Frameworks, Firefox, Plymouth and Kernels

Hello ARM community.

A big update this time. It’s taken some time to get this ready for you guys!


Plymouth is now available on Manjaro ARM, so you can theme your bootsplash, just the way you like it!


Some highlights:

  • Most of our kernels got updated
  • KDE Frameworks is now at version 5.79
  • We updated Firefox to 85.0
  • Plymouth is now in the repository
  • Lots of updated packages for our Mobile offerings

Upstream Notifications:

Older notifications

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
https://www.archlinux.org/news/ghostpcl9532-2-and-ghostxps9532-2-updates-require-manual-intervention/

The nss and zn_poly packages requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/
https://www.archlinux.org/news/zn_poly-092-2-update-requires-manual-intervention/

The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package changes:

(Sun Feb 21 20:39:00 CET 2021)

  • arm-stable kde-unstable aarch64: 404 new and 0 removed package(s)
  • arm-stable community aarch64: 933 new and 1011 removed package(s)
  • arm-stable core aarch64: 82 new and 80 removed package(s)
  • arm-stable extra aarch64: 1079 new and 1060 removed package(s)
  • arm-stable mobile aarch64: 78 new and 74 removed package(s)

See the entire package list here.


Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Donation

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

Poll

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Old Issues

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Only thing I noticed: the new plymouth is not activated by default. What do I have to do (beside installing the packages) to get plymouth shown at boot time?

You need to “activate” the theme. And maybe add display to your initramfs, if you want it shown early.

To activate theme, you add plymouth to the HOOKS in mkinitcpio.conf after base and udev and do sudo plymouth-set-default-theme -R materia-manjaro.

Also add quiet splash plymouth.ignore-serial-consoles to your extlinux.conf instead of the bootsplash thing.

2 Likes

Updated successfully on Beelink GT King Pro but on linux 5.11.0-3 and mesa-git from Unstable.

LibreOffice 7.1 Impress still crashes on Slide Show mode when Xfce Compositor is “Enabled”.

Edit:
dmesg has this error:

[ 0.673769] bootsplash bootsplash.0: Direct firmware load for bootsplash-themes/manjaro/bootsplash failed with error -2
[ 0.673780] bootsplash: Failed to initialize.

Should it be a concerned?

Hi,

Odroid C2 and N2 KDE up to date, so far it works.

[nln2@n2 ~]$ date -u
lun. 22 févr. 2021 15:41:25 UTC
[nln2@n2 ~]$ screenfetch
                             nln2@n2.20.06
                             OS: Manjaro-ARM 21.02
                             Kernel: aarch64 Linux 5.10.8-1-MANJARO-ARM
         #####               Uptime: 1m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.1.4
        #######              Resolution: 1920x1080
      ###########            DE: KDE 5.79.0 / Plasma 5.20.5
     #############           WM: KWin
    ###############          GTK Theme: Breeze [GTK2/3]
    ################         Icon Theme: oxygen
   #################         Disk:
 #####################       CPU: Unknown @ 6x 1.992GHz
 #####################       GPU: 
   #################         RAM: 627MiB / 3627MiB
                            
                            
                            
[nln2@n2 ~]$ uname -a
Linux n2.20.06 5.10.8-1-MANJARO-ARM #1 SMP PREEMPT Fri Jan 22 01:57:45 +03 2021 aarch64 GNU/Linux
[nln2@n2 ~]$ 

Enjoy !

Just in case, plymouth works for the Raspberry Pi 4B as well, with the similar configuration (materia-manjaro as theme, quiet splash plymouth.ignore-serial-consoles in the cmdline.txt).

EDIT: I’ve also added a delay to /etc/plymouth/plymouthd, as I needed to do that on Raspbery Pi OS to make bootsplash working as well:

# Distribution defaults. Changes to this file will get overwritten during
# upgrades.
[Daemon]
Theme=materia-manjaro
ShowDelay=3
DeviceTimeout=8

Yup, works on Pinebook Pro. Will this be the default in newer releases?

I will have to do some testing, but it’s the plan.

1 Like

No succes with plymouth.When i try to enable lightdm-plymouth.service on pi4 with xfce

systemctl disable lightdm
systemctl enable lightdm-plymouth
systemctl status lightdm-plymouth

I have

manjaro systemd[1]: Two services allocated for the same bus name org.freedesktop.DisplayManager

I finished reversing all changes.
My cmdline.txt (with plymouth.enable=0 deleted):

 root=LABEL=ROOT_MNJRO rw rootwait console=serial0,115200 console=tty1 selinux=0 quiet splash plymouth.ignore-serial-consoles smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=serial0,115200 elevator=noop usbhid.mousepoll=8 snd-bcm2835.enable_compat_alsa=0 audit=0

First the bootsplash does not work if you are using kms instead of fkms in /boot/config.txt

Don’t do this:

cmdline.txt:

root=LABEL=ROOT_MNJRO rw rootwait console=serial0,115200 console=tty3 selinux=0 quiet splash plymouth.ignore-serial-consoles smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=serial0,115200 elevator=noop usbhid.mousepoll=8 snd-bcm2835.enable_compat_alsa=0 audit=0

config.txt add this line at the bottom:

disable_splash=1

/etc/mkinitcpio.conf

#MODULES=(usb-storage dwc2 xhci-hcd xhci-pci pcie-brcmstb)
MODULES=(vc4)
#BINARIES


HOOKS=(base udev plymouth autodetect modconf block filesystems keyboard fsck)

Depending on what your kernel is run mkinitcpio and reboot

Mine:

[ray@pi4 ~]$ ls /etc/mkinitcpio.d/
linux-rpi4.preset

sudo mkinitcpio -p  linux-rpi4
sudo reboot

fkms /kms is the key point.
So what is the advantage or the disadvantage if manjaro arm enables plymouth with fkms mandatory ?

Had fkms set ever since upstream broke VC4 V3D kms @1 1/2 years ago and the pi4 came out which presented it’s own set of problems with kms. The RPi folks have been working on kms and has basically been under construction for a while. It is now starting to come up to speed but has a way to go.

I do not know that a decision has been made yet to have plymouth installed in the next image due to kms not working but fkms is still more stable at this time as far as a image release is concerned so a user can use with no underlining issues.

On RPI3B, the wlan0 interface doesn’t show up after the update.

Feb 23 15:51:12 neptune2 kernel: brcmfmac: F1 signature read @0x18000000=0x1541a9a6
Feb 23 15:51:12 neptune2 kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
Feb 23 15:51:12 neptune2 kernel: usbcore: registered new interface driver brcmfmac
Feb 23 15:51:12 neptune2 kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
Feb 23 15:51:12 neptune2 kernel: ieee80211 phy2: brcmf_c_process_clm_blob: clmload (4733 byte file) failed (-52)
Feb 23 15:51:12 neptune2 kernel: ieee80211 phy2: brcmf_c_preinit_dcmds: download CLM blob file failed, -5
Feb 23 15:51:12 neptune2 kernel: ieee80211 phy2: brcmf_bus_started: failed: -5
Feb 23 15:51:12 neptune2 kernel: ieee80211 phy2: brcmf_attach: dongle is not responding: err=-5
Feb 23 15:51:12 neptune2 kernel: brcmfmac: brcmf_sdio_firmware_callback: brcmf_attach failed

Downgrading to linux-firmware-20201218.646f159-1 helped, at least the wlan interface is back.
It seems to be related to “brcmfmac43430-sdio.raspberrypi,3-model-b.txt” which is not in the newer package version.

I installed a new kde image today to test on my pi3b and actually the issue is in /usr/lib/firmware/updates/brcm (not /usr/lib/firmware/brcm) with some bad files. I do not have time to make a new firmware package right now as today is grocery day for me.

If any one else has this issue a temp fix:

sudo rm /usr/lib/firmware/updates/brcm/{brcmfmac43430-sdio.bin,brcmfmac43430-sdio.txt}

Then reboot

Side note:

I was really surprised how plasma ran with the pi3b with overclocking.

1 Like

Mine is on Thursdays (the grocery day).
The fix works.
I admit I was hoping for a quick reply, pretty spoiled by your excellent support. :grinning: :smiley: :smile:

2 Likes

Bluetooth seems to start up successfully but finally there is no controller. “systemctl start brcm 43438” starts well but finally fails:

Feb 23 19:26:48 neptune2 systemd[1]: Started Broadcom BCM43438 bluetooth HCI.
Feb 23 19:26:48 neptune2 kernel: Bluetooth: Core ver 2.22
Feb 23 19:26:48 neptune2 kernel: NET: Registered protocol family 31
Feb 23 19:26:48 neptune2 kernel: Bluetooth: HCI device and connection manager initialized
Feb 23 19:26:48 neptune2 kernel: Bluetooth: HCI socket layer initialized
Feb 23 19:26:48 neptune2 kernel: Bluetooth: L2CAP socket layer initialized
Feb 23 19:26:48 neptune2 kernel: Bluetooth: SCO socket layer initialized
Feb 23 19:26:48 neptune2 kernel: Bluetooth: HCI UART driver ver 2.3
Feb 23 19:26:48 neptune2 kernel: Bluetooth: HCI UART protocol H4 registered
Feb 23 19:26:48 neptune2 kernel: Bluetooth: HCI UART protocol Three-wire (H5) registered
Feb 23 19:26:48 neptune2 kernel: Bluetooth: HCI UART protocol Broadcom registered
Feb 23 19:26:48 neptune2 systemd[1]: Starting Load/Save RF Kill Switch Status...
Feb 23 19:26:48 neptune2 systemd[362]: Reached target Bluetooth.
Feb 23 19:26:48 neptune2 systemd[1]: Reached target Bluetooth.
Feb 23 19:26:48 neptune2 systemd[1]: Started Load/Save RF Kill Switch Status.
Feb 23 19:26:50 neptune2 kernel: Bluetooth: hci0: command 0x0c03 tx timeout
Feb 23 19:26:53 neptune2 systemd[1]: systemd-rfkill.service: Succeeded.
Feb 23 19:26:58 neptune2 kernel: Bluetooth: hci0: BCM: Reset failed (-110)
Feb 23 19:27:14 neptune2 systemd[1]: Starting Bluetooth service...

“systemctl start bluetooth” seems to succeed, rfkill shows the device hci0. But “bluetoothctl list” shows no controller.
Btw, brcmfmac and brcmutil are blacklisted (as on my not yet upgraded RPi3B).

You have the wrong bluetooth .service package installed. It has not been in the repo for months.

sudo systemctl disable brcm43438.service
sudo pacman -S -dd  brcm-patchram-plus
sudo systemctl enable attach-bluetooth.service
sudo reboot

Also guessing you have not seen this post to fix an issue with the new raspberrypi-bootloader:

https://forum.manjaro.org/t/new-raspberry-pi-kernels-related-packages/4721/344