[arm kde] does redshift/'night color' works for you?

Good evening fellas,
Beginner manjaro arm kde user here (raspberry pi 4).

For those who don’t know, there are studies that shows reducing the blue of the screens at night helps the body sleep etc. This felt important to me, as our usage of PC during the pandemic rised up.

I’ve failed in many ways to activate ‘night color’ / redshift in the system*:

First, i tried the easy ‘night color’ mode on plasma’s configuration. Tried in both x11 and wayland (i guess it came x11 by default, i installed wayland from the pamac). After, i tried searching online and tried manually instaling gnome - it didn’t worked there as well.
The folder is: /usr/share/kpackage/kcms/kcm_nightcolor/

After it, i’ve tried using the app redshift: as i suspected it had problems in geolocation, the -help from terminal or github sugested forcing the always on with command “redshift -O 3000k”. The github also sugested creating a config file manually, but it didn’t seem to help. Archwiki have a redshift page as well.

Lastly, i began using the app ‘gnome clocks’ to make the pomodoro tecnique. I rest my eyes a little from 5 to 5 minutes, and take a 5min or more break each 40min.

*I’m trying not to mess with the monitor buttons, because ive made a
diy monitor with an old screen and a chinese control board lol. The menu is badly translated, but it could be another solution.

My post is because i imagined it would happen with you guys too. So… can you use the night color / redshift ? or my problem could be a fresh system install?

FAQs from the redshift site:
Why doesn’t Redshift work on my Chromebook/Raspberry Pi?

Certain video drivers do not support adjustable gamma ramps. In some cases Redshift will fail with an error message, but other drivers silently ignore adjustments to the gamma ramp.

Why doesn’t Redshift work on Wayland (e.g. Fedora 25)?

The Wayland protocol does not support Redshift. There is currently no way for Redshift to adjust the color temperature in Wayland.

Instead, you can use night color in gnome or plasma.

Hi,

Nice post, thanks a lot for the night colour question, no problem with kde on the x86 but the arm…

Odroid devices on my side, with kde.

I’m curious to read more explanation on this malfunction on the arm devices.

Odroid N2 KDE

Night Color or Red Shift is not currently supported on must ARM hardware, because the DRM driver they use, does not have the functionality that it uses.
Not GPU driver, but DRM driver.

So those drivers would be:
Raspberry Pi = vc4
Amlogic = meson_drm
Rockchip = rockchipdrm
Allwinner = sun4i_drm

My guess is that these drivers do not support it, because they where really never designed to be used as a desktop. They are designed for embedded purposes, and what embedded systems really need Night Color or Red Shift? :wink:

Thanks a lot for your answer.

Thanks Strit. Where can we flag the missing feature? Here shows yore in the arm team, so i imagine it is already kinda flagged… but i guess in a update the ‘night color’ could be hidden in the config menu and the redshift from the repo, because it may lead someone to lose time searching a solution like i did yesterday lol. If anyone find some similar app or workarounds, please let us know. It matters for us that uses it as our main pc. Anyway, thanks and congratulations for this aweasome system!

We don’t develop those drivers. The upstream SoC vendors do. So Allwinner, Amlogic, Rockchip and Raspberry Pi/Broadcom respectively.

But night color does work on some devices, like the PinePhone, so we can’t just remove it.