ARK wont extract RAR file

When i try to extract a file from a rar to a folder ARK gets an error. (Could not move the extracted file to the destination directory.)

I am using the Dolphin file manger.
I have tried searching around on the forum and subreddit yet Ive found nothing similar to my problem.

Can you extract from the terminal using unrar x and your file?

i just tried it but it says unrar is not a command and asks if i ment unar.

Then you should install unrar with pamac install unrar

1 Like

If you don’t have unrar installed, Ark won’t be able to extract any rar archive. Ark is just a graphical frontend over the corresponding archive format CLI tools. It doesn’t have any (de)compression code on its own.

See “Optional Deps” part of this command output:

$ pacman -Qi ark
Name            : ark
Version         : 22.12.2-1
Description     : Archiving Tool
Architecture    : x86_64
URL             :
Licenses        : GPL
Groups          : kde-applications  kde-utilities
Provides        : None
Depends On      : kparts  kpty  libarchive  libzip  kitemmodels  hicolor-icon-theme
Optional Deps   : p7zip: 7Z format support [installed]
                  unrar: RAR decompression support [installed]
                  unarchiver: RAR format support [installed]
                  lzop: LZO format support [installed]
                  lrzip: LRZ format support [installed]
                  arj: ARJ format support
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 4,60 MiB
Packager        : Antonio Rojas <>
Build Date      : Rab 01 Feb 2023 01:40:58 
Install Date    : Sen 13 Feb 2023 08:39:33 
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
1 Like

Thanks so much. I to extract it by dragging it like in Windows with 7Zip, but i figured out i had press the extract button and choose witch folder to extract to.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.