Ark stopped working, no compressing possible in Plasma

I needed to create zip packages from the folders, the way I used to do all the time: right-click on the folder or file, from the menu: compress here using zip/tar.gz.

This time, I tried many times and no zip files were created. I tried tar.gz files, the same. So I launched the Ark UI and saw this:

On the right, it says “Archive was not loaded” and ALL BUTTONS ARE GRAYED OUT AND NOT CLICKABLE.

My guess is, archive libraries haven’t loaded properly. In the Ark settings, all plugins with various archive capabilities seems to be connected.

Any idea how to debug this, so I could solve it?

If you right click above the grayed menu, can you activate the Main Toolbar ?

If i load the Ark app, i also have the No archive loaded, but i can right click in Dolphin and archive folders …

In Settings > Configure Ark i have this Plugins enabled

As mentioned earlier, all looks all right:

Wait a moment! It works in other places, but when I try to compress some folders in .config, nothing happens! What gives?

Also, buttons not being active is still an abnormal behavior. I can’t add files to compress or search, which should be possible at all times.

EDIT: When I copied the folders to other location, then I could archive them as usual.

It works on my end (tested on 2 main installs, different branches) but the resulting archive is

Ah, the archives are hidden! They don’t have . in my case but still are somehow hidden. I forgot that although I had “show hidden files” setting on the main user folder, in the subfolder I have to enable it again.

So the Ark is working. The only issue is that add and search buttons are not active from some reason. Since I don’t use them too often, it’s not a big problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.