Ark cannot open *pkg.tar.zst files

Hi folks,

I’m wondering if it’s my system only or everyone’s experiencing this when opening some file from /var/cache/pacman/pkg/ too?


Latest Ark of course, v 20.12.0.
It opens regular *tar.zst and *zstd files without any problems, it’s only software packages cause the above error.

The only discussion related to this problem I found so far is dated almost 1 year ago, and what’s interesting is that it was held by @oberon and one of KDE devs who used Arch where there was no such an issue.

Happens to me too with Ark 20.08.

Either we are missing a plugin, or the Ark PKGBUILD is missing a build option.

yes. I reported the issue but it seems it was never resolved as they claim it is a manjaro only issue

1 Like

That sounds like the usual friendly Arch response.

In this case it comes from the Ark developers…

Anyway, the problem seems to come from the Manjaro’s mimetype "application/x-alpm-package" ( Ark doesn’t support this mimetype and doesn’t seem it will support it in the near future.

Is there any benefit for Manjaro to use this mimetype? For me it seems that there are only two options, to stop using this mimetype or to patch Ark in Manjaro’s end

1 Like

And one more note: I remember that Ark used to open *pkg.tar.xz files which we had before the adoption of zstd compression just fine. And now we have this issue.

Okay. This actually makes sense.

Pamac gained the ability to install .pkg.tar.* packages by double clicking on them, via mime-types.
This seem to have changed how the .pkg.tar.zst files are being handled by all applications to see it as an ALPM package, instead of a regular compressed archive.
Maybe @guinux can shed some light on this? :slight_smile:

No problem for me with ark 20.12

ps: I don’t have pamac installed. :thinking:

There’s already a bug opened in pamac gitlab. I didn’t have time to check yet.

Workaround 1: rename the package from “XXXXXX.pkg.tar.zst” to “XXXXXX.zst”. This must be done for every package ending in “.pkg.tar.*”

Workaround 2: delete the mime type: rm /usr/share/mime/packages/x-alpm-package.xml && update-mime-database /usr/share/mime

1 Like

Hi all, as a real dumb bum ‘old man’ trying to get my head around Linux, I cannot for the life of me see why there are so many ways programs are zipped up and each new one causes even more problems for people like me trying to install: portaudio-1_19.7.0-1-x86_64.pkg.tar.zst
Why is it so difficult to attach three lines giving the terminal commands required to install it?

Hi Jack, I renamed the package getting rid of the .PKG to portaudio-1_19.7.0-1-x86_64.tar.zst.
Tried unpacking it with: tar xvfz portaudio-1_19.7.0-1-x86_64.tar.zst but got this response:
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now.
Any other suggestions?

To install a local package you don’t need to extract it manually, use pacman -U /path to file/filename

Have you checked that this package isn’t in the AUR?

Just an FYI. Ark 21.08 can open .zst files. :slight_smile:
Previous version could not.

Thanks, I’ll try that.

Hi Strit, I tried this pacman -Qi Ark | grep “Version”
error: package ‘Ark’ was not found was the the outcome, but it is installed. Also, portaudio is installed, but not showing in the applications tab. pacman -Qi portaudio | grep “Version”
Version : 1:19.7.0-1

Thanks NGr, I tried that and it worked thanks, it was already showing as installed from AUR, but not in my Applications tab, so cannot run it from there.
There are broader issues I am trying to resolve running speech in python and get about 50 lines of errors about Alsa, Jack and slaves, all of which unfortunately mean nothing to me!