Ark(archiving tool) will not start

The ark (archiving tool) will not start and i cannot extract zips using the tool.
I have searched online if anybody had the same problem but couldnt find any examples.

If i try to start ark via the terminal with:
$ ark

I get the following error:

ark: symbol lookup error: /usr/lib/ undefined symbol: _ZN15KPluginMetaData16staticMetaObjectE

I have tried to search what the libkerfuffle is and tried to reinstall it but i couldnt find any info over. Apart that it is used by the ark package.

Does somebody might know where this error comes from. And how i can solve it?
Thanks in advance.

Did you do a full-upgrade (sudo pacman -Syu)?

No, I did it a some time ago. But after the full update my manjaro wouldnt boot anymore. So I had to use timeshift to rollback. I could try it again to see if they fixed it in the meantime.

Could this be related to ark?

A partial upgrade might result in a program trying to use a shared library which it was not compiled with, and that could result in errors like the one you see.

Ah oke. Shouldn’t this be prevented by depenceny checks? Or can this still sometimes happen?

Most packages don’t specify the required version of their dependencies.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.