Are my two video cards just anti-social?

I have a GTX760 and GTX660 OC. If I install either of them by itself, it works fine. If I install them both, only one works, and only one shows up in lspci output. I’ve tried swapping PCI-E slots and get the same result. I know I can’t SLI bridge different cards, and that isn’t what I’m trying to do. I just want Blender to have access to two discrete GPUs, and I thought it’d be nice to plug one monitor into each card.

Motherboard is an ASUS M4N75TD with an old, reliable Phenom II. The motherboard manual seems to indicate it should work with two different cards. I have an 850 watt power supply, so power shouldn’t be a factor.

It’s not necessarily imperative that I get this working; but it seems like I should be able to. Any ideas, anyone?

EDIT - Driver info:

mhwd -l -d
PCI Device: /devices/pci0000:00/0000:00:11.0/0000:03:00.0 (0300:10de:1187)
Display controller nVidia Corporation GK104 [GeForce GTX 760]

   NAME:	video-nvidia-430xx
   VERSION:	2019.10.25
   INFO:	Closed source NVIDIA drivers for linux.
   FREEDRIVER:	false

Yeah the automatic detection won’t really work for your case. Have you tried making a manual Xinerama configuration?

I haven’t, but it doesn’t really sound like what I’m looking for. I have 2 monitors working now, both connected to the GTX 760. I’m trying to figure out why only one of my video cards is recognized when both are installed. lspci only shows one of them and the onboard AMD VGA controller; the other NVIDIA card is nowhere to be found. I’m leaning toward this being a hardware issue rather than an OS issue.

I have certainly seen folks here with more than one nvidia card listed.
I dont think it ever really called for anything but besides selecting the driver profile in mhwd/msm
(and then whatever specifics they wanted to use like passthrough or whatever)
and the 2 cards were at least recognized by inxi and so on.

Oh sorry must have accidentally skipped over the lspci part.
Just to make sure, have you tested with only 1 card in the slot that doesn’t seem to work?

If I install either card by itself, in either PCI-E slot, it works normally. With both installed, only one is recognized.

Here is inxi -G:

inxi -G
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X] driver: radeon v: kernel 
           Device-2: NVIDIA GK104 [GeForce GTX 760] driver: nvidia v: 430.64 
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1: 3840x2160~60Hz 2: 1680x1050~60Hz 
           OpenGL: renderer: GeForce GTX 760/PCIe/SSE2 v: 4.6.0 NVIDIA 430.64

EDIT: The GTX 760 and 660 are both installed.

Well… then I’m pretty much out of ideas aswell.It is not a hardware issue since everything is crosstested. It ought not to be a driver issue since it does not even get detected as plugged in. The only thing i can think of where the problem could be, would be the bios. I just read through the manual regarding it and the only option that i noticed that might interfere in some freak accident could possibly be the Hybrid SLI option.

I should probably make sure Hybrid SLI isn’t enabled in BIOS. I’ll do that during next reboot.

Hybrid SLI wasn’t enabled, so that’s ruled out. Only one of the cards shows up in BIOS PCIe devices no matter how they’re installed. I’m going to assume this is a hardware or BIOS issue and give up, lol.

Try to backup and then remove/rename the /etc/X11/mhwd.d/nvidia.conf once you installed the proprietary driver. Then rename/remove the /etc/X11/xorg.conf.d/90-mhwd.conf (i usually use _BCK after the file extension), then reboot the system with nomodeset instead of quiet as kernel boot parameter.
Does it make a difference?

The BIOS doesn’t even show both cards installed, so I think I’m just going to give up on it for now.