Arduino Board not detected on USB using Arduino IDE (RPI4)

Hi all, I downloaded + installed the Arduino IDE (from ADD/REMOVE SOFTWARE) on my Manjaro running RPI4 (kernel 5.10.81-1), compiled an example script, no problem, but could not uploaded it to a board that I connected via USB because it does not appear to find it.

In the IDE, “Serial Ports” is greyed-out but /dev/ttyAMA0 is available and so that is what I selected to attempt connection.

The Arduino Uno has its power LED (red) on and it is running a simple blink sketch controlling its green LED that was coded into it previously on another machine, so the board is OK.

Has anyone got this working properly on the RPI4 under Manjaro?

Any advice?

Dont know if this help, but have you set the right board in the settings?

Tools → Board


Tools → Board → Boardmanager

you also can add different boards.

Hope this helps … if not Im out … dont know more about. :neutral_face:

Do you see the arduino if you run lsusb?
Bus 001 Device 007: ID 2341:0043 Arduino SA Uno R3 (CDC ACM)

My arduino (clone) works on my rpi4. uses port /dev/ttyACM0
crw-rw---- 1 root uucp 166, 0 Dec 13 21:59 /dev/ttyACM0

Add the uucp group to your account:
sudo usermod -a -G uucp [username] (without braces)

I set the port and the board from the tools menu, and it just works.

Edit: Originally, in the usermod command above, I failed to add -a. So the command would replace your secondary groups, not add. I have corrected the command. If you ran the original command, you should replace those secondary groups using the root account:

usermod -a -G sys,network,power,wheel,audio,input,lp,storage,video,users [username]

I believe these are the standard secondary groups for the install account.

1 Like

Hi [0n0w1c], thanks for replying.

I added the UUCP group, rebooted and lsusb found the board connected on Bus1 Device 10 and was able to select and program it as /dev/ttyACDM0. Also tried a Nano and it came up as a CH340 serial device on /dev/ttyUSB0 and programmed that using the old bootloader option, no problem.

I then tried a VISduino (meant to be fully compatible with an Uno R3) but that does not even appear on the lsusb list. I figured it might be damaged but it is running the pre-programmed flash-LED program OK so might be a compatibility thing.

So I then added the JSON configuration files for an ESP32 board (I have 2 here), setup an example, etc, and they too fail to appear on the lsusb list.

Have you tried either of the last two boards?

I think I’ll try loading-up the IDE and ESP32 configuration files on a PC running Manjaro next, just to note if it can see them. Will keep you posted.

Good news: it failed to see those last two boards also on the PC but then I tried another, thicker, cable (they both used the same cable) and they both came up on lsusb. So it all works!

I guess, be careful with thin USB cables, as some, I think, are meant for charging only and will not allow your machine to see the board you are connecting.

Time to code some new Xmas lights…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.