[Archived - Unresolved] - Manjaro unable to login to desktop, Login boots be back to login window

Hi There,

I have recently moved over to Manjaro from Fedora as I was looking for more control from my desktop. For this reason I have used the Manjaro Architect to complete the install. I have kept the home drive from my fedora install and have tried removing all of the config files that reference the desktop environment.

The issue that I am currently facing is that I am unable to login to the desktop environment every time I boot. I am able to SSH or TTY into the desktop and this works without issue. I have tried to follow the steps in both of the following issues;
manjaro forum article 21916
manjaro forum article 3904

The information here did not help me. I have found that I have been able to update everything and refreshed my pacman cache and still nothing.

Below is the information on my desktop environment
OS: Manjaro Linux x86_64 Kernel: 5.7.19-2-MANJARO Uptime: 16 mins Packages: 997 (pacman) Shell: zsh 5.8 Terminal: /dev/pts/0 CPU: AMD Ryzen 7 1800X (16) @ 3.600GHz GPU: NVIDIA GeForce GTX 1080 Ti Memory: 404MiB / 32103MiB

Any information that you need can be provided and

Hello and welcome,

Is not quite clean looking, isn’t it? And quite generic information :slight_smile:
Usually this is the kind of information we look for and the format to be provided be:

You mentioned architect install. Why not directly the preferred DE ISO ? That way you avoid most of the struggle or forgetting about some packages.
Each DE uses a default DM:
Gnome > GDM
XFCE > LightDM

So, depending what DE you installed, the service corresponding to the DM can be checked if active or not. Example:
systemctl status sddm
Because i see zsh and you mentioned Fedora, i can assume you installed Gnome. That means:
systemctl status gdm

if you have done an update ,
you have to check with /etc/pam.d/*

see this

So just ran an LS on psm.d/ and this was the result
ls /etc/pam.d/* /etc/pam.d/chage /etc/pam.d/lightdm-greeter /etc/pam.d/sudo /etc/pam.d/chfn /etc/pam.d/login /etc/pam.d/su-l /etc/pam.d/chgpasswd /etc/pam.d/newusers /etc/pam.d/system-auth /etc/pam.d/chpasswd /etc/pam.d/other /etc/pam.d/systemd-user /etc/pam.d/chsh /etc/pam.d/passwd /etc/pam.d/system-local-login /etc/pam.d/crond /etc/pam.d/polkit-1 /etc/pam.d/system-login /etc/pam.d/cups /etc/pam.d/rlogin /etc/pam.d/system-remote-login /etc/pam.d/groupadd /etc/pam.d/rsh /etc/pam.d/system-services /etc/pam.d/groupdel /etc/pam.d/runuser /etc/pam.d/useradd /etc/pam.d/groupmems /etc/pam.d/runuser-l /etc/pam.d/userdel /etc/pam.d/groupmod /etc/pam.d/shadow /etc/pam.d/usermod /etc/pam.d/lightdm /etc/pam.d/sshd /etc/pam.d/vlock /etc/pam.d/lightdm-autologin /etc/pam.d/su

Guess not
`systemctl status lightdm.service
● lightdm.service - Light Display Manager
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disable>
Active: active (running) since Fri 2020-09-11 17:53:41 AEST; 2h 11min ago
Docs: man:lightdm(1)
Main PID: 669 (lightdm)
Tasks: 5 (limit: 38424)
Memory: 45.7M
CGroup: /system.slice/lightdm.service
├─ 669 /usr/bin/lightdm
├─1334 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7>
└─1421 lightdm --session-child 12 19

Sep 11 17:53:39 brighttower systemd[1]: Starting Light Display Manager…
Sep 11 17:53:41 brighttower systemd[1]: Started Light Display Manager.
Sep 11 17:53:42 brighttower lightdm[1378]: pam_unix(lightdm-greeter:session): session opened >`

grep -E "pam_tally|pam_cracklib" /etc/pam.d/*

Here is the result
grep -E "pam_tally|pam_cracklib" /etc/pam.d/*

/etc/pam.d/passwd:#password required pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 retry=3

I get the same output on my system, but I’m not having any login problems. Still, there were no .pacnew files in /etc/pam.d/ for myself, so if pam_cracklib.so is deprecated, then what must it be replaced by? :thinking:

cracklib is old! for a long time this line is commented since it is announced obsolete, It was before this update. Some rare people with old manjaro who don’t manage .pacnews may have it without “#”.

1 Like

So I wasn’t able to get this working so I gave up and installed Manjaro XFCE however I am seeing the same issue. I will archive this case and open a new case with the new information under the correct pages.