Architect: Mounting ZFS?

After automatically partitioning the disk, and setting up ZFS, I can’t mount the partitions.

I tried making an additional (unformatted) boot partition, then automatically setting up ZFS, afterwards while mounting, there was brief success.

I’m unable to replicate that, mounting anything related to ZFS in Manjaro Architect. How is it supposed to work?

I decided to give up on a ZFS install, or even architect. Custom ZFS installation seemed to work somewhat, but architect gave errors about ZFS services not existing. There seemed to be additional errors, what I’d guess were due to it trying to install half of the things in the right location, another half on the live environment.

At some point, I had been troubleshooting for too long, and decided to install a normal system with architect. The first broken thing was sddm. Password entry was confusing at best. It started with RTL-styled entry, but on some nth characters didn’t accept some letters and so on. Unusable I’d say.
I could start wayland (x session was not available/installed at all?) after manually logging in via tty.

So I once again reinstalled, this time with the GUI installer. Worked fine enough, except it indeed is fairly basic.

have you checked this

Yes. I could probably install arch with zfs fine, I’m here to complain about Architect supposedly suplorting zfs, while being broken.
I’m looking to not do the installation by hand.