Apps stopped launching after update

I haven’t booted the PC in a few months. It was 500 updates pending, upgraded.
It changed the background, made the taskbar floating, and all installed apps stopped working - kind of.

In the task bar, all icons have turned to “white empty document”, and clicking them return: “Unknown application folder”
In the Application Launcher, if I search for an installed app, eg Konsole, it only show “Get Konsole…” and if I click that I get error “Could not read file appstream://org.kde.konsole.desktop.”

If I go into the Application drawer, the update place, don’t know the name, and click the app, it launches.
But it does not show up in in the Task Bar.

Other issues that came at the same time I’ve found so far:

  • saved “open with” seem to have been lost, e.g. .txt do not automatically use kate to open.

I now have DISTRIB_RELEASE=“24.0.0”, did not check what I had before update.

It doesn’t seem matter how I’ve installed the apps, pacman, flatpac, etc. Or premade binaries; those seem to not be able to open those at all anymore, even from dolphin.

In short, Manjaro is totally broken for me now. How can I fix?

edit: When I found another weird issue, concerning the binaries - app don’t start, but every time I click it a black square shows up. And wanting to upload screenshot here, so installed Gimp. When Gimp install completed the icons in task manager came back, for whatever reason. And I can click them (except binaries), and the file format seem to have been fixed as well. It’s like 2h after I rebooted after upgrade.

Can’t include links or pictures it seem, so black boxes in task bar between update icon and clipboard icon, now there’s 7 of them.

Will try a reboot again and see if it boots up “ok” or if it takes 2h again to fix itself.

I experienced an issue today while upgrading my system. As a result, my desktop is now broken and I am unable to launch applications or shortcuts from my menu bar. I find this situation ridiculous and it seems that my only option is to do a fresh install. Does anyone know how to revert back to the previous system version? As a workaround, I tried to use ‘mv ~/.config ~/.config.old’ command, but unfortunately, my system is now booting to the login screen which is quite frustrating.

I’ve rebooted mine again to see if the “fix” stayed after reboot, and it did. (The binaries issue is still there but I’ll fiddle with that and start a separate thread if I can’t find a solution)

  1. Updated. ← What initiated the issue.
  2. Rebooted. ← Didn’t help.
  3. Opened “Application Manager” (the shield icon in taskbar) and installed a random app (Gimp in my case). ← What randomly fixed it for me.

So, try that, quartet.

Perhaps some weird cashing issue.

2 Likes

I had to reboot my device multiple times before it started working again. After the second, third, and fourth reboot, it finally started working. It was frustrating.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.