Apps missing from Status Tray Plugin

Can anyone help in understanding why an app might be missing from XFCE’s Status Tray Plugin? For example Telegram shows up there, but Electron Mail (from flatpak) no longer does (it used to be there until a few weeks ago). The unexpected thing is that I still get notification from the app, eventhough it’s missing from the tray.

I don’t know where to even begin debugging this. Are there any logs I should look into?

Have a look in pamac to check which plugin is handling the systray, there are actually 2 of which AUR’s xfce4-statusnotifier-plugin is deprecated. There’s also the new xfce4-notifyd which has been introduced 9.02.'24 that may have caused the issue.

Not quite getting this either. Was recently trying to get an app to show and installed the packages @megavolt mentions below but this introduced another issue where pamac icon showed permanently even though there were no updates and icon was set to hide when up-to-date.

Must be related to the AppIndicator. I have already installed this and the indicator works:


Probably electron needs legacy libraries…

notifyd seems to be ok, because I can get notifications from Electron Mail and it shows up in the list of known applications in notifyd settings.

It seems like the issue is with Status Tray Plugin, which does not see a lot of applications that notifyd sees

Do you know which libraries that might be? All the ones in your list were already installed.

Telegram is Qt6 and Electron Mail is Electron. In recent versions of Electron, tray icons no longer need AppIndicator packages.

What legacy libraries? :thinking:

I tried it in a vm with xfce on stable branch and well it just works. You see the indicator icon.

Check the settings of the status tray extension. You may have hidden the icon. :man_shrugging:

:man_shrugging: No idea.

Other than that: Have you tried turning it off and on again? :smiley:

One more idea: could it be something related to permissions?

I installed Electron Mail from flatpak. Looking at flatseal, I see a bunch of permission related to indicators. Maybe it’s missing some.

All I did is installing Manjaro XFCE and then install ElectronMail via flatpak. Zero modifications. If you modfied something, then you must know what you did.

[test@test-vm ~]$ flatpak info --show-permissions com.github.vladimiry.ElectronMail 

[Session Bus Policy]

[System Bus Policy]


Something is really messed up with my tray. For example KDE Connect does not show up either, just like Electron Mail.

However, I installed the legacy Status Notifier Plugin. Interestingly it does not show Electron Mail either, but it does show KDE connect.

Not sure what’s going on, but it looks like the panel is messed up.

I managed to fix this, but I have no idea why it works.

There were two ayatana items in the startup applications. After disabling them the tray works fine and the status tray started working normally and all the missing tray applications returned.

No idea why it works, but it does now.