Apps menu not launching with Windows / Super key

I dont know how to make manjaro open the bottom left menu when I press the Windows/Super key, I tried to solve it myself, I tried to link this action to a shortcut by adding xfce4-whiskermenu-plugin to the key, but I get this error: Failed to execute the process xfce4-whiskermenu-plugin (The file or directory does not exist)

I’m new to GNU/Linux and I hope you can help me

The right command is

1 Like

Hi, thank you very much, I am very sorry, but I forgot to mention that xfce4-popup-applicationsmenu is also linked to my Super Key, but I dont see it listed in the keyboard shortcuts. How do I remove it? The problem now is that i can’t use the whisker menu since me applications menu launches right after. I also tried restoring the shortcuts to default.

Again thank you so much.

I also got that recently when i reinstalled on a new drive. I had to uncheck “Include applications menu on desktop right click” in the Desktop settings.
Don’t ask me why…

Sadly that doesn’t seem to solve it, the applications menu keeps launching. Is there an easier way to maybe “restore” xfce rather than having to reinstall?. I also messed up with my taskbar/panel, and I would like to have it the way it is by default.

Settings > Keyboard > Application Shortcuts >


This same information can be viewed and edited with the Settings Editor.

Or, with the command xfconf-query

xfconf-query --channel xfce4-keyboard-shortcuts --list --verbose | grep -i whisker

I find xfconf-query the easiest way to find a shortcut, and then work from there.

The text file (yeah text!) that is updated is $HOME/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml.

After using a GUI, I like to execute the command below to show me what file(s) was updated. I have an alias for it.

find -newermt "1 minute ago"

The default Manjaro XFCE installs and runs a program called xcape. It can be viewed in the GUI, Settings > Session and Startup > Application Autostart, or console, $HOME/.config/autostart/xcape.desktop. If you cat the file, the Exec line shows, 'Super_L=Alt_L|F1'. It takes the Left Super Key and turns it into Alt-F1. This corresponds to the original contents of xfce4-keyboard-shortcuts.xml for the whisker menu. I don’t run xcape and just configured the Super keys. I’m not sure what else xcape buys a user. Perhaps someone can fill use in.

Assuming the shortcut is correct, given the above, what do you get when you type:

# list files owned by pkg and remove non-executables from results 
pacman -Ql xfce4-whiskermenu-plugin | grep -Ev -e '(locale|icon|man|/$)' 

This should list 3 files.

Bottom-line: When xcape is running you should be able to type Alt-F1 or the Left Super key to bring up the Whisker menu. Without xcape, just configure the Super keys in the XFCE Settings.

I’m unaware of an official way of resetting XFCE, but when you create a new user, the files from /etc/skel/ (defined: /etc/default/useradd) are copied. I have never tried this, but it might be possible to “reset” XFCE if the files, some or all, were copied from xfce4 subdirectory, and then logoff/logon. Could also create a new user, and copy (or maybe just reference/diff/meld) the .config/xfce4 files. Sometimes “messed up” equals learning opportunity :slight_smile:

Back up everything before beginning. Since the $HOME/.config directory is so important, I keep a “fresh” copy taken right after an install, and then have regular backups too.

It is my current understanding that the XFCE Settings GUI doesn’t know anything about /etc/skel, so clicking “Reset to Defaults” might not do what we think. I would feel better if someone from Manjaro chimed in on that one.

I created a new user and compared the user’s $HOME directory with /etc/skel/ and it was confirmed, they are the same.

I then logged into a tty and compared home directories. $HOME/.config/user-dirs.dirs and user-dirs.locale were created, and the files in user-dirs.dirs were created (Desktop, Downloads, etc).

Last, I logged into the graphical environment to compare changes. Created or modified were: .cache, .config/pulse, .config/xfce4/desktop/icons.screen.latest.rc , under xfce-perchannel-xml - displays.xml, xfce4-desktop.xml, xfce4-panel.xml, xfwm4.xml, and .gnupg, .ICEauthority, .Xauthority, .dmrc and .xsessions-errors. Nothing earth shattering.

I used meld to compare directories.