Applications top bar has changed after update

After update the top bar of all applications, for instance the terminal application, tabs on firefox, etc appear in dark background and white letters as shown here:


Tabs in firefox:

Before the update they were grey and black letters which I became very used to.
How to go back to that behaviour?

Did you just now update from GNOME 41 to 42? That happened months ago. See:

It looks like you’re using Matcha (matcha-gtk-theme). It is not yet compatible with GNOME 42. Use a theme like Adw / Adw-dark (adw-gtk-theme) for consistent Gtk 3 & 4 theming.

Where? In the terminal text itself or elsewhere? The terminal theme is independent of the Gtk theme.

I have Extensions disabled (i.e. no dash to panel or dash to dock are interfering), but no icons are shown when I try to press window key and search for any application, e.g. “Extensions” I get the “searching” message but never appears any result

Please don’t create separate topics for every detail you notice. It’s obvious it’s been quite some time since you updated without reading any announcement posts.

@Yochanan Thank you for your answer and apologise for any inconvenience caused.

I’m using Gnome 42 since it was available. Current status:

$ gnome-shell --version
GNOME Shell 42.4

This problem appears after an update done today 27th September 2022. Which update?

$ grep -i upgraded /var/log/pacman.log
[2022-09-27T18:07:28+0200] [ALPM] upgraded firefox (104.0.2-1 -> 105.0-0.1)
[2022-09-27T18:08:09+0200] [ALPM] upgraded gnome-shell-extension-openweather (118-1 -> 119-1)
[2022-09-27T18:08:15+0200] [ALPM] upgraded gnome-shell-extension-unite (65-1 -> 67-1)
[2022-09-27T18:08:23+0200] [ALPM] upgraded jitsi-meet-desktop-bin (2022.8.1-1 -> 2022.9.1-1)
[2022-09-27T18:12:30+0200] [ALPM] upgraded libmagick6 ( ->
[2022-09-27T18:12:45+0200] [ALPM] upgraded slack-desktop (4.28.171-1 -> 4.28.182-1)
[2022-09-27T18:13:03+0200] [ALPM] upgraded teams ( ->

I’m not sure, but I think it may have something to do with
gnome-shell-extension-unite that apparently triggered this behaviour.

  1. You may see in the above screenshot that this is not in the terminal itself but in the top bar, or “title bar” sort to speak, i.e. the one that just reads david@david-pc:~
  1. In the other screenshot I show the firefox tabs which also have the same behaviour: white letters over black background.

Before the update, both situations were grey background and black letters which I became very much used to.

@Yochanan Using tweaks, I have set Themes > Icons to Adwaita (default) as well as Legacy Applications to Adwaita (default) which brings the terminal window and firefox to white background and dark letters recovering the behaviour I had before the update.

However, the second part of the problem (applications top bar), i.e. Dash to Panel extension does not work. I’ve disabled all Extensions and enabled just Dash to panel and AppIndicator but the dash to panel does not seem to work.

EDIT: The Home key + search for any application yields no results (a “searching” message that runs forever).

  1. I’ve disabled all Built-In and Manually Installed extensions.
  2. I’ve disabled the first button for “Extensions”
  3. Restart the computer
  4. Home key + search for any application yields results.
  5. Enable Dash to Panel and main Extensions buttom yields no dash to panel bar as well as no apps results when doing the search

Quite possibly.

At a fresh login run this command to watch the log:

journalctl -b | grep gnome-shell

Then enable Dash to Panel and see if there are any errors generated.

You can also do the same with other extensions to narrow down the cause of the problem.

@Yochanan I solved the problem, many thanks for the hints.

The problem escalated, so I uninstalled and installed again, also removing /home/david/.config/dconf/user.

The origin of all this started after the gnome-shell update, where the Themes and Legacy Applications settings changed, resulting in seeing all this in Matcha:

I’ve been finding this problem every now and then a gnome-shell package is updated, the settings are changed. @Manjaro-Team Is it possible to maintain the users’ gnome settings after the update the same with respect to those that were before the update? Many thanks for all the hard work keeping up this community. All the best.

Care to share how you did with the rest of the class?

What update? You still haven’t identified which package update caused your issue.

Hint: It was not gnome-shell.

The what settings? I already mentioned the Matcha theme may have issues. It hasn’t been updated since June.

No user settings will be changed with any package update regardless.

User settings never changes - but packages does - and the behavior of installed packages may change as well.

Settings which is no longer valid after updates - is your issue to solve.

Gnome themes and shell extensions may cause issues on updates and that is inevitable.

The general advise for a Gnome update is to disable your customizations before update and reapply after a successful update.

This approach paves for the best possible migration to a new gnome package set.

On a side note - the above applies for Plasma as well.

Thank you for your comment.

Not sure, according to this it may be some gnome - related:

I never used Matcha theme. I’m referring to these settings: