Applications Hijack Sound Output

I’ve got this issue where some applications take over the audio device, and it appears as unavailable in the device selection options, stopping all other sound sources.

Right now it’s Mixxx, but I’ve gotten it with an indie game as well. I haven’t found any articles describing my exact issue, but I’ve tried a couple things like commenting out Pulseaudio’s corking module to no effect.

Other programs do not make sound while Mixxx is running - Troubleshooting · mixxxdj/mixxx Wiki · GitHub

On GNU/Linux, running Mixxx from a GUI menu or from the launcher icon automatically suspends PulseAudio while Mixxx is running so Mixxx can use your sound card with ALSA directly.

To keep other programs playing sound, either they all need to use JACK, or you can try using the “pulse” virtual ALSA device with Mixxx when running Mixxx on the command line without pasuspender.

Refer to the Mixxx manual for more information about sound APIs.

If you use JACK and do not want Mixxx to pause PulseAudio, you can edit /usr/share/applications/mixxx.desktop to change the line:
Exec=sh -c "pasuspender -- mixxx || mixxx"

1 Like

This worked! Much appreciated!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.