Application installed via snap does not work

Hello Everyone,

I have an multiple issue, I like Manjaro but never been able to use it for a long time, and finally I have a computer where I want it to be my main Operation System.
I have 2 major problems which I want to fix first. First - short introduction, and then I will explain more about the problems. I have installed 3 times (clean install) Manjaro from USB. First time right a way I started to install my favorite applications via snap. Once I have been done with installation I decided to test them and try how they will work. There comes first problem:

  1. After installation of multiple snap packages I find out that most of the application simply won’t open. During testing what can be open and what cannot, I did some uninstall/install to try fix them and I was able to open few applications which lead to second problem:
  2. When i opened Applications (just 2 of them worked and opened) I found this:
  • Opera browser - worked normally (didn’t use it much just start - open 1-2 websites = worked)
  • If i remember there was GIMP the other program that was able to start, and there everything was “wrong (in a seconds you will see screenshot)”. Instead of alphabet I saw rectangles just like the once in this screenshot:

After the rectangles I though that I am doing something wrong, so again - clean install from USB.
This time I didn’t use terminal for installing the package but opened Software Update, there first I did refresh Mirror, after that I get to the snap tab and checked “Enable Snap support”.

After that I searched Opera in the program, and installed if from snap.

Once i installed it worked normally (finally I thought that I am out of problems and found why I had those 2 issues in a first place) and tried to Download a file, and I saw the first screenshot.

I haven’t yet install any new software since clean installation, only Opera. literally I haven’t do anything else on the OS except 2 reboots.

Also there is another problem not connected with snap but boot. I have on this PC another SSD with Windows 10. GRUB find the OS, but when I choose it says that there is no boot loader. I tried workaround - get to bios boot and pick the loader for windows from there - windows started normally.
After that i restart the PC, wait to load the GRUB, picked windows - This time worked…
I believe that if I restart the PC now (while using Manjaro) GRUB won’t be able to load Windows.

Do you think you can help me with those problem? Should I try flatpak instead?

Thank you in advance
Best Regards / Martin

1 Like

Ok, I cannot upload screenshots, sorry about that, I am not able to use links as well.

1 Like