Application Flashing/Flickring after updating to 5.9.16-1-MANJARO

Hi All,

I am using Manjaro XFCE on dell laptop.
after recent update i observed black horizontal line at the bottom of the screen and applications are also started flashing and flicking.
I am sharing output of inxi -Fxza --no-host as below …
Could you please help me with this issue?

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1
  parameters: BOOT_IMAGE=/vmlinuz-5.9-x86_64
  root=UUID=4a6f0cb1-6955-488a-b832-0eaba6d4be36 rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel, plank wm: xfwm4
  dm: LightDM 1.30.0 Distro: Manjaro Linux
  Type: Laptop System: Dell product: Latitude 7480 v: N/A serial: <filter>
  Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 00F6D3 v: A00 serial: <filter> UEFI [Legacy]: Dell
  v: 1.19.0 date: 07/26/2020
  ID-1: BAT0 charge: 35.3 Wh condition: 58.1/60.0 Wh (97%) volts: 7.4/7.6
  model: SMP DELL DW3WC64 type: Li-poly serial: <filter> status: Discharging
  Info: Dual Core model: Intel Core i7-7600U bits: 64 type: MT MCP
  arch: Amber/Kaby Lake note: check family: 6 model-id: 8E (142) stepping: 9
  microcode: DE L2 cache: 4 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 23209
  Speed: 900 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 900 2: 900
  3: 900 4: 900
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:5916 class ID: 0300
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
  bus ID: 1-5:2 chip ID: 0bda:58c7 class ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.10 driver: loaded: intel
  unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP1 res: 1920x1080 dpi: 157 size: 310x170mm (12.2x6.7")
  diag: 354mm (13.9")
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4
  direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3
  chip ID: 8086:9d71 class ID: 0403
  Sound Server: ALSA v: k5.9.16-1-MANJARO
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
  port: f040 bus ID: 00:1f.6 chip ID: 8086:15d7 class ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040
  bus ID: 02:00.0 chip ID: 8086:24fd class ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: br-fbadc3bc95fb state: down mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb
  v: 0.8 bus ID: 1-7:3 chip ID: 8087:0a2b class ID: e001
  Message: Required tool hciconfig not installed. Check --recommends
  Local Storage: total: 297.95 GiB used: 32.51 GiB (10.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SD64G size: 59.48 GiB block size:
  physical: 512 B logical: 512 B rotation: SSD serial: <filter> scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: X400 M.2 2280 256GB
  size: 238.47 GiB block size: physical: 512 B logical: 512 B
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 2012 scheme: GPT
  ID-1: / raw size: 97.66 GiB size: 95.62 GiB (97.92%)
  used: 20.67 GiB (21.6%) fs: ext4 dev: /dev/sda4 maj-min: 8:4
  ID-2: /boot raw size: 500 MiB size: 476.2 MiB (95.24%)
  used: 60.3 MiB (12.7%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw size: 140.32 GiB size: 137.12 GiB (97.72%)
  used: 11.78 GiB (8.6%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
  Alert: No Swap data was found.
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 257 Uptime: 1h 23m wakeups: 1 Memory: 15.29 GiB
  used: 2.78 GiB (18.2%) Init: systemd v: 247 Compilers: gcc: 10.2.0
  Packages: 1300 pacman: 1285 lib: 411 flatpak: 5 snap: 10 Shell: Zsh v: 5.8
  running in: alacritty inxi: 3.3.01

Hi @pbiraris,

I do not know if this’ll help or fix it.

I have noticed the kernel version you’re using and according to this Wikipedia article it is EOL (EOL = End Of Life.)

It it recommended that you use either 5.4, which is LTS (Long Term Support) or 5.10 (which is set to be the next LTS version.)


To install a newer kernel, open a terminal and run:

sudo mhwd-kernel -i linux54

to install the Linux kernel version 5.4, or:

sudo mwhd-kernel -i linux510

to install the Linux kernel version 5.10 and reboot.

Your computer should boot up/start up with the latest installed kernel, in this case 5.4 or 5.10 (whichever you chose to install.)

If successfully booted, remove the old kernel by starting the terminal and running:

sudo mhwd-kernel -r linux59

This should be more than enough, but if you just want to make sure everythings fine, you can reboot again.

Hope this helps!

Thank you @Mirdarthos,
As per your suggestion I have updated kernel to 5.10.15-1-MANJARO.
But issue is still there.

I have also created file with /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"

but no use still observing flashing on some applications like Mozila browser.

Well, as I said, I don’t know if it’ll solve your problem, but at least that’s ruled out, now.

@Mirdarthos Thanks I really appreciate your help and time.

You are very welcome.

I had this problem recently with my desktop (not a notebook)…

I noticed it was a bad contact in the hdmi cable, I suggest you to:

  • check your laptop hdmi flat cable integrity
  • reinstall your video driver

I also remember that XFCE has a composer issue with some integrated graphics, I also suggest:

  • turn off the composer of the xfwm4


Issue is resolved …I have followed below steps

  1. As mention before created /etc/X11/xorg.conf.d/20-intel.conf file
  2. @Mirdarthos as per your suggetion updating kernel 5.10.15.x does not helped so I updated to 5.11.0-1 it resolved flashing issue
  3. @chandlerkc I haven’t disabled compositor completely but there is one option show shadow under dock window after disabling this black horizontal line disappeared.

Thank you both of you for your time and help.

1 Like

Glad you managed! For interest’s sake, have you tried with kernel 5.10 again?

Because, if it does work, that’ll confirm that it’s not a kernel thing along with the shadow option and that the kernel doesn’t matter.

No I haven’t Tried … but after installing 5.10 disabled compositor completely but still there was flashing and little flickering while using applications like mozilla and brave browsers.

Still I will try to boot into 5.10 check again.

With the setting off it might be working, seeing as it’s a setting and not a kernel thing. And 5.10 is set to be the next LTS version, so that’s nice…

Tried once again with 5.10.15_1 but still observing flashing.

OK, pity. But at least there’s the other option for now.

Glad the issue has been solved, buddy!!

@pbiraris i dont know whether it is related, but do have a peek here;

Please see if this works for you