Application: "Bespoke" doesn't run

I downloaded a “linux” application and it doesn’t do anything when I double click on the binary.

here’s the app:

I tried running from command line and I get a python shared library error, but I don’t understand why a “linux” program that is as polished as this app wouldn’t be smart enough to sort out python.

What do you normally do when you try to launch a “linux” app and it doesn’t load? Lately I am also having problems getting WINE even to install .exe or .msi files as well. It’s like this week app installers just aren’t working out for me.

edit: aha? there seems to be a few dependencies in debian format apt-get. I suppose I can change ‘apt-get’ to ‘pacman -S’ ?

sudo apt-get -y install g++
sudo apt-get -y install libfreetype6-dev
sudo apt-get -y install libx11-dev
sudo apt-get -y install libxinerama-dev
sudo apt-get -y install libxrandr-dev
sudo apt-get -y install libxcursor-dev
sudo apt-get -y install mesa-common-dev
sudo apt-get -y install libasound2-dev
sudo apt-get -y install freeglut3-dev
sudo apt-get -y install libxcomposite-dev
sudo apt-get -y install libcurl4
sudo apt-get -y install libusb-1.0-0-dev
sudo apt-get -y install libgtk-3-dev
sudo apt-get -y install python3-dev
sudo apt-get -y install libcurl4-openssl-dev
sudo apt-get -y install libwebkit2gtk-4.0-dev
sudo apt-get -y install libjack-dev

Why didn’t you install it from the AUR? :arrow_down:

pamac build bespokesynth-git

Note: Third-party software for GNU/Linux usually comes in a format for .rpm- or .deb-based distributions. Manjaro is Arch-based and uses neither of those two formats.

hm, interesting, I didn’t see it in the package manager application, thanks.

I just saw this app for the first time today, went to package manager application in kde plasma, didn’t find anything for “bespoke” so went to the website, downloaded the archive, and de-arked it in the /bin folder, clicked on the binary, and got nothing.

I’ll just try the pamac thing. I need to take a class on pamac so I can understand what the difference is between that and pacman. new things, new things everywhere :wink:

whoops! a failure occurred in build

=> Starting build()…
Compiling Bespoke_CFMessaging.cpp
make: *** No rule to make target ‘…/…/Source/freeverb/allpass.cpp’, needed by ‘build/intermediate/Release/allpass_106bc017.o’. Stop.
==> ERROR: A failure occurred in build().

do I need to specify a target or is the following sufficient?

pamac build bespokesynth-git

  • pacman is the original Arch Linux package manager. It is a command-line-only tool, and in Manjaro, it can be used only in conjunction with the Manjaro mirrors, with locally stored packages, and with additional trusted mirrors if you wish to add those.

  • pamac uses the same package management databases, but also has a graphical front-end, and it supports the AUR.

The AUR itself does not contain packages but build scripts, which pull in the sources from elsewhere, and then those sources are compiled on your local computer. In some cases, the build scripts pull in a binary package instead, or they repackage something that was packaged for another distribution.

No, the command I gave you should suffice. The error you’re getting is from the compiler, telling you that there’s something missing in the source code.

This here is the GitHub page of the package. Perhaps you can contact the packager about this error?

I’ve got a couple tabs open, the Git page as well as the Aur page. I guess there’s a number of different problems on the part of some users who are trying to install. I’ll look for a way to join the Arch forum next and tell my tale.

I noticed the developer said the following is ‘the’ way to build for all platforms, in his words:

git clone https : // # replace this with your fork if you forked
cd BespokeSynth
git submodule update --init --recursive
cmake -Bignore/build
cmake --build ignore/build --parallel 4

These instructions worked, but the Aur method did not.

Well, try waiting a bit longer. This type of stuff can really take its time, depending on the size of the project. :frowning:

1 Like

as it turned out, the Aur didn’t work when Aur was enabled in the pamac-gui and BespokeSynth was attempted to be installed that way, but the Github instructions actually did work, and you’re right, it took some time.

1 Like

I was bored and fixed the PKGBUILD. See my comment on the AUR page.


wowie zowie!

I saw Chris from Airwindows demo this today and had to try it.

Since you took the trouble, I will give it another go by installing via pacman-aur :slight_smile:

hm, still getting the following error message (with some context)

CPU: 3484MHz Cores: 4 15429MB
Loading project: /var/tmp/pamac-build-username/bespokesynth-git/src/BespokeSynth/BespokeSynth.jucer
Re-saving file: /var/tmp/pamac-build-username/bespokesynth-git/src/BespokeSynth/BespokeSynth.jucer
Finished saving: Xcode (MacOSX)
Finished saving: Visual Studio 2015
Finished saving: Linux Makefile
==> Starting pkgver()…
==> Removing existing $pkgdir/ directory…
==> Starting build()…
Compiling Bespoke_CFMessaging.cpp
make: *** No rule to make target ‘…/…/Source/freeverb/allpass.cpp’, needed by ‘build/intermediate/Release/allpass_106bc017.o’. Stop.
==> ERROR: A failure occurred in build().

the interesting part is that the ‘generic’ build instructions at BespokeSynth’s github page worked. Took probably 20 or 30 minutes to build but it ended up working. (but powersave was my cpu-power profile so it could have been faster otherwise.)

It doesn’t look like you used my PKGBUILD.

let me refresh the databases and try again. i will remember to try that first next time.

now, i am assuming you have altered the PKGBUILD that is connected with pamac/Aur. Or am I supposed to download your PKGBUILD from the page that you linked to at your comment?

edit: ah, well reading your below comment I now understand. My knowledge level is around zero with regard to the meaning of Aur etc, only just this hour using Aur for the first time. But since the regular plain vanilla generic build installation instructions on the git page work, why not just copy that down as some kind of script and use that instead?

You’ll need to build it manually. See Installing from the AUR by hand. After cloning the bespokesynth-git repo, replace the PKGBUILD with mine and go from there.

1 Like

Yes, they do. That’s why I modified the PKGBUILD to use those instructions. :wink:

I downloaded your PKGBUILD, put it in the ~/BespokeSynth folder (where else should I put it?) and then executed ‘makepkg -s’ from command line within the folder. But it was named and makepkg was looking for a file called ‘PKGBUILD’ so i renamed the file that way and then I got an error ‘PKGBUILD contains CRLF characters and cannot be sourced.’ So now I’m going to the internet to find out why. (never heard of CRLF until just this minute)

here’s a page where it discusses the same error message and the ‘solution’ seems like gibberish to me:

point of ambiguity: is CRLF some kind of rich text invisible thing or is it some sort of scripting language syntax error? is it my fault? is it your fault? It’s just not clear.

I include a screenshot of the new PKGBUILD script, except where is the error of CRLF coming from?


Trying to follow the AUR instructions, I am not sure what makepkg is doing if the .sh script file already has what appears to be enough instructions to do the making. but the ‘how to manually install from Aur’ page gives me the instruction to clone from git, then run the command line program called ‘makepkg’. Is that wrong information? Is ‘PKGBUILD’ not the data that is cloned from git, but rather a script? If so, then either there is ambiguity or one of them is technically untrue:

I’m sure your ‘PKGBUILD’ would work, but I don’t know how I am supposed to insert that script into the list of instructions at the Arch User Repository website’s instructions on manual installation from AUR.


A PKGBUILD is a shell script containing the build information required by Arch Linux packages.

that’s great, so why does the instruction manual for installing from AUR say “Clone the PKGBUILD” ? Is this my mistake? Because a clone from git is not a shell script, but a big old folder full of folders and files. Unless the term PKGBUILD has several different meanings by context.


it feels like I am trying to write a really bad program, 19 edits later.

Oh my. You gave it a valiant effort, I commend you. :vulcan_salute:

Make sure prerequisites are installed (you already did that as the wiki instructed, right?)

sudo pacman -Syu --needed base-devel git

Clone the AUR files (in this case it’s just the PKGBUILD) anywhere, say ~/pkgbuilds or something and change directory to that folder:

git clone
cd bespokesynth-git

Now open the PKGBUILD in your favorite text editor and paste the contents of my PKGBUILD into it from my paste replacing the whole thing and save it.

Now build it–don’t do it in powersave mode, it’ll take at least twice as long :wink:

makepkg -srcif

it worked after i changed your PKGBUILD line 12:




but I spoke too soon. Error after all the cloning and validating and extracting:

==> Starting prepare()…
/home/username/bespokesynth-git/PKGBUILD: line 29: cd: /home/username/bespokesynth-git/src/BespokeSynth: No such file or directory
==> ERROR: A failure occurred in prepare().

There is a fundamental problem, and I’m not certain what references depend on this, but the AUR clone is called bespokesynth-git but really it needs to be called BespokeSynth because that is what the clone folder is called when you clone directly from the developer, and by the rules of cargo cult voodoo programming, AUR should call it exactly the same thing.

What happened following my above instructions?

Yes, that’s the name of the package repository in the AUR. That has nothing to do with the upstream source folder name. My PKGBUILD changes directory into that folder:

cd "$srcdir/BespokeSynth"

did you try your instructions sir?

I had to change some of your script otherwise it was stuck on “… is not a clone of …” error. I wrote above the line i had to change. and after the files were downloaded, the build stopped because “…/BespokeSynth” did not exist, as per my most recent comment on here.

It’s hard for me to keep track of the variables which include a wildcard’s worth of stuff i don’t know, so I don’t know how useful my attempt at using AUR can be since I don’t see myself writing the manual for it anytime soon.

I successfully built and ran the program using my PKGBUILD. Why would I share it if it didn’t work?

You’re haven’t provided enough information to find out what went wrong.

Remove ~/bespokesynth-git or wherever you cloned the AUR files to and start over. Do not edit my PKGBUILD. Copy the complete terminal output and paste it to a pastebin service and link it here.

ok here you go, here’s the error after erasing the folder /bespokesynth-git and following your instructions and using your PKGBUILD without editing it. spoiler alert: it didn’t work. (but earlier when i did in fact edit your script, i was able to cheat the system and get a build out of it and it did execute.)