Appimagelauncher not starting


a view days ago, i successfully integrated an .appimage via AppImage Launcher on my HP-Envy, running Manjaro Gnome. Everything works fine, but today i tried the same procedure on my older HP-laptop (EliteBook 8460p), but AppImageLauncher doesn’t schow up. I tried to open it via ‘AppimageLauncher %f’ in terminal and got this Error:

AppImageLauncher: error while loading shared libraries: cannot open shared object file: No such file or directory

Same issue with Settings ‘AppImageLauncherSettings %f’

As far as I know, all Dependencies are installed. Both machines are set up completely the same way. On both Laptops I changed Branch from Stable to Testing and then back to Stable, to get the new Gnome 40 Shell.

Does anyone know why it doesn’t work on the second laptop?

Best regards,

Probably some package mismatches (also known as partial update).
Switch the (non-workiing) laptop to testing again and to a fulll update:

$ sudo pacman-mirrors -aB testing
$ sudo pacman -Syyu
1 Like

Hi freggel.doe,

thank you very much, that worked!

I have already switched back to stable and AppImageLauncher still works.
I used these commands to switch branches:

sudo pacman-mirrors --api --set-branch {branch}

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.