AppArmor error on boot


When booting and shutting down, I get an error saying:
“[FAILED] Failed to start Load AppArmor Profiles.”
I have looked online, but can’t get any concrete results, or at least none my brain can understand. I think I would need to get a log from AppArmor, but not sure on where to go/how to do that, so if you need me to do that, I will. Any more info, I will be happy to get. Thanks for any help

System info:


Operating System: Manjaro Linux
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.16.18-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600 6-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1650/PCIe/SSE2

Sudo aa-status:


apparmor module is loaded.
8 profiles are loaded.
8 profiles are in enforce mode.
0 profiles are in complain mode.
0 profiles are in kill mode.
0 profiles are in unconfined mode.
0 processes have profiles defined.
0 processes are in enforce mode.
0 processes are in complain mode.
0 processes are unconfined but have a profile defined.
0 processes are in mixed mode.
0 processes are in kill mode.


I eventually found the command: journalctl -b -u apparmor.service that lets me see the errors with apparmor. It had something to do with the version of firefox I was using (firefox-ubuntu from the aur to get the global menu support, firefox-appmenu never worked for me).

I looked up the error, and came across this thread, which had the commands to fix it. After a reboot, it all works now. Just that my boot/startup screen still shows a bit of text, but that is nothing

cat << EOF | sudo tee /etc/apparmor.d/abstractions/ubuntu-browsers.d/firefox
# This file is updated by 'aa-update-browser' and may be overwritten on
# upgrades.
# For site-specific adjustments, please see /etc/apparmor.d/local/<binary>

#include <abstractions/ubuntu-browsers.d/plugins-common>
#include <abstractions/ubuntu-browsers.d/mailto>
#include <abstractions/ubuntu-browsers.d/multimedia>
#include <abstractions/ubuntu-browsers.d/productivity>
#include <abstractions/ubuntu-browsers.d/java>
#include <abstractions/ubuntu-browsers.d/kde>
#include <abstractions/ubuntu-browsers.d/text-editors>
#include <abstractions/ubuntu-browsers.d/ubuntu-integration>
#include <abstractions/ubuntu-browsers.d/user-files>

sudo touch /etc/apparmor.d/local/usr.bin.firefox
1 Like