App/Program to download files from Gdrive

I’m looking for a program that can mount my Gdrive/team drive in my directory so that i can copy those files through instead of downloading one by one through a manager.
Example: RaiDrive & airExplorer (Windows 10)

PS: should download on my ISP speed

There are some File Managers that let you login to your Google Drive account and access it from there. I think Thunar can’t, maybe there’s a plugin for it. I think Dolphin can do it, but you would have to look a bit.

What desktop are you using? There’s a guide for adding Googledrive to your file manager on cinnamon. It should work with any nemo file manager

Install the package gvfs-google and use gio

gio mount google-drive://

Search using pamac

pamac search google-drive

Eg. insync with integration for Thunar insync-thunar - not tested - just a search

Another search using another common shortname - nothing tested - just a search

pamac search gdrive
1 Like

rclone is also a good solution because it support a lot of providers.

One software fit (almost) all :yum:


Install kio-gdrive from the repository. It allows you to access your Google Drive from within Dolphin. :wink:


Will look into this,thanks :smiley:

I’m using this but the docs are kinda hard to understand how to mount it directory,
setup is pretty easy even used the GUI pretty neat tho loved it, will look into the docs again.

Already tried it the speed was pretty slow, so removed it :stuck_out_tongue:

this doesn’t work :frowning: says invalid mount spec

yup - you need a rather expensive package to make it work and to set it up.

sudo pacman -Syu gnome-control-center

Then launch from a terminal


Setup your google account - then thunar works by using the location bar CtrlL - and then open the URI


I have been otherwise occupied - but I think the gnome-control-center package can be removed as the authorization are stored in the gnome-keyring - but I have not yet verified it.

You could try verifying after you have successfully connected to your gdrive.

sudo pacman -Rns gnome-control-center

After setting up the account, I’m not able to open it and if i try to mount it i get this Location is unmountable

Just for the sake of this thread I have actually tested the setup - and I too ran into the same first error when I tried using gio mount account@gmail.

When I research what would be necessary to make this work - I found it was necessary to get gnome-control-center.

After installing the package - it did not show up in my menu system - but I was able to run it from terminal. After the launch it was fairly simple to setup the rest.

The gnome panel will connect to google and you will be presented with the permissions required - and they are everything you could possibly image - but that is how it is.

I then opened Thunar and entered in the address/navigation bar the address I described and connected I was - I tested creating folders and files - checking with googles webapp - no problem.

So I reckon you must be missing something - but I don’t know what - but I do know that it works using the steps I have described.

  1. Install gvfs-goa, gvfs-google and gnome-control-center

  2. Launch Gnome Control Center
    If you can’t find it - launch from terminal gnome-control-center

  3. Setup your Google account

  4. Mount your drive
    a. Use gio to mount

    $ gio mount google-drive://

    Mountpoint is found in /run/user/$UID/gvfs/google-drive: …

    b. Use the location bar of your file manager and enter the address

And that’s it.

Also tested if gvfs continues to work after removal of gnome-control-center - and good news - it works - it is only required during the initial load of your google account.

When you have verified you can connect using gvfs (gio mount) you can remove the package and all dependencies - (don’t remove the gvfs packages)

sudo pacman -Rns gnome-control-center
1 Like

For adventure there’s this Python Quickstart  |  Google Drive API  |  Google Developers

1 Like

i’m using “opendrive” - it’s a client like dropbox and works great so far. (i am using the flatpak version)

okay so it turns out gvfs-google wasn’t installed properly, so after that i was able to mount the gdrive :smiley: want to know after mount it doesn’t show shared device and shared with me folder, any way to get those?

after removing still work great thanks :+1:

If you use the terminal to mount you will have to navigate to the folder and Thunar will show the address in the left pane whether this tree style or shortcuts style.

example mount (replace youraccount with what is to the left of @ in your gmail account)

$ ~ ACCOUNT=youraccount
$ ~ gio mount google-drive://$
$ ~ cd /run/user/1000/gvfs/,user=$ACCOUNT
1 Like

Thanks will look into it :smiley: everything else works fine now.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.