Anyone else experiencing Intel AX200 Bluetooth being disabled in kernel515?

I don’t often use Bluetooth on my PC since KDE Connect works great over the LAN… but happened to notice some entries in journalctl that clued me into it’s not working on kernel 5.15.2 (currently available stable release 5.15 kernel).

$ journalctl -k --priority err
-- Journal begins at Tue 2021-07-13 15:47:15 CDT, ends at Fri 2021-12-10 11:28:12 CST. --
Dec 10 11:21:29 AM4-5600X-Linux kernel: Bluetooth: hci0: Reading Intel version command failed (-110)
Dec 10 11:21:29 AM4-5600X-Linux kernel: Bluetooth: hci0: command tx timeout

I checked KDE settings for bluetooth, it advised me “Bluetooth was disabled”, and it presented me with an “enable” button that didn’t seem to do anything.

I rebooted my PC to check the BIOS (which I’d recently flashed) and found no option to disable Bluetooth. Once I exited the BIOS, I decided to ask grub to load kernel 5.13… and instantly (post login) I could see the bluetooth icon in the “active” system tray, confirmed my cell connected via bluetooth within, and found the Bluetooth: hci0 error lines were now absent from journalctl -k --priority err.

I know kernel 5.15.2 is an early kernel, and assume newer kernel versions address this… but I wanted to check to see if maybe there’s another step I am unaware of that needs to be done to enable Bluetooth on kernel 5.15.

Note: The system detects the device on kernel 5.15… but has it disabled.

$ lsusb -s 1:2
Bus 001 Device 002: ID 8087:0029 Intel Corp. AX200 Bluetooth

Okay… this was unexpected.

After rebooting to go back to the 5.15 kernel… Bluetooth is now active again?

Hmm… I wonder if this was more related to:

  • My recent BIOS update moved me from AGESA => … and/or
  • I think there are still known AMD issues with “USB drop out”… and my Bluetooth falls under USB devices

If it’s not AGESA version related… I still suspect the BIOS update might have introduced some wrinkles that make the “USB dropout” now noticeable to me… as I have had a couple recent occurrences where upon reboot I had to unplug/replug my mouse in to get it recognized/working; and I never had to do that prior to the BIOS update :thinking:

EDIT: Accoding to AMD finally fixes USB bugs with Ryzen CPUs – but patch won’t roll out for a while yet | TechRadar, AGESA was AMD’s first kick at the USB drop out fix… which as far as i can tell was the introduction in my experience… the opposite.

EDIT 2: According to MSI Rolls Out AMD AGESA Patch C BETA BIOS Firmware For X570 & B550 Motherboards… both patch B and patch C continued working on usb dropout fixes. I generally stay away from “beta BIOS’s”… but I just might have to make an exception in this case.

I have Gigabyte board with the AX210 Intel M.2 with the AMD AGESA ComboV2 A

Kernel 5.15.2-2-Manjaro the wifi works fine, but hovering over the Bluetooth on system settings shows “No adaptors available.” I believe this is a kernel hiccup and so long as the wifi works I will be patient waiting for the fix.


Thanks for chiming in @Pcwolf !

Hmm, if AGESA still has issues, I don’t hold much hope for|C… I may wait to see if a kernel update helps… but it’s more likely that I may roll back to AGESA where I don’t recall experiencing USB drop outs.

EDIT: Just installed the latest Stable branch updates with kernel 5.15.6-2. Two reboots so far with no USB peripherals impacted by drop out (my issues seem to have always happened during boot). Will reserve any celebrations until I’ve rebooted at least a dozen times.

EDIT 2 (Dec 11): 3 more reboots… so, 5 reboots in and all is well so far on the new kernel

1 Like

Manjaro Stable Update just dropped and kernel 5.15.6-2 has Intel AX210 working as expected. Hoo-Ray!

I’ve been dealing with this exact issue. Just bumped to 5.15.6-2 so we’ll see how it goes.

let’s hope your celebration continues over the long haul with your reboots @Pcwolf .

I know since my BIOS/AGESA update the reboot to missing USB device (in hindsight) feels like 33% of boots for the mouse… but because I didn’t realize the BlueTooth drop outs until later (mouse was very noticeable), it’s hard to say, but I feel it could have been more frequent.

1 Like

If it works out for you @enrun , I’d be curious to learn what your AGESA version is in your BIOS

i had the same problem, my fix was to update the drivers, there are some Update firmware files for Intel Bluetooth AX200 here. kernel/git/firmware/linux-firmware.git - Repository of firmware blobs for use with the Linux kernel

I updated the system, and the problem appeared again, so i had to install the drivers, again. in future updates, check the firmware version before updating it… if the problem persists, maybe give it a try, fyi, you have to copy some files in the /lib/firmware/intel/ folder… need root acces

I’ll keep that in mind @guillopacheco ; however, in my case the dropout was oddly intermittent per boot, and was discovered that the USB dropout was flipping between dropping my mouse or the BlueTooth … so I think my issue is was less about drivers and more about the kernel. 5 reboots since kernel 5.15.6-2 and no USB dropouts so far @ boot.


Just a quick note to say that after updating to kernel 5.15.7-1, the initial reboot was good… no usb dropouts. Still waiting to see that a dozen reboots are good, and I’m half way there:

  • Kernel 5.15.6-2: 5 reboots without usb dropout
  • Kernel 5.15.7-1: 5 reboots without usb dropout
  • Kernel 5.15.12-1: 1 reboot (so far) without usb dropout
1 Like

having the same issue on 5.15. on 5.14 ax200 works perfectly. I’ve copied the updated firmware files that was referenced by guillopacheco but no luck.

When doing a “journalctl -b | egrep -i bluetooth” I get the below back:

Dec 30 15:33:11 kernel: Bluetooth: hci0: command 0xfc05 tx timeout
Dec 30 15:33:11 kernel: Bluetooth: hci0: Reading Intel version command failed (-110)

“lsusb | grep -i bluetooth returns”:

Bus 001 Device 004: ID 8087:0029 Intel Corp. AX200 Bluetooth

From what I can see it might have something to do with 215167 – Bluetooth: hci0: command 0xfc05 tx timeout with the potential fix to apply [PATCH] Bluetooth: Apply initial command workaround for more Intel chips - Takashi Iwai for 8087:0029 as well.

Unfortunately I have no idea how to test this.

PS I’m on Testing branch with Kernel 5.15.11-1

While there is no doubt kernel updates will improve things… I also think there is a BIOS interdependence.

I seem to be doing OK at the moment (speaking from the AMD perspective with their USB drop-out issue) on AGESA and Kernel 5.1.6|7… But I must confess I am not a high Bluetooth user. I occasionally connect my new Edifier W860NB aptx headset… but find they can’t really shine a candle to to their S360DB “big brother” shelf speakers I have connected optically; so I use the headset very infrequently.

My Bluetooth issues I think we more related to them being on a USB “channel”… and was experiencing the dropout lottery between them and my mouse… which seems to have now been resolved. Whether that was moving off Kernel 5.15.2, or updating to AGES, or the combination of the two.

I noticed there was an AGESA BIOS release for my mobo in the last week… but I’m hesitant to install it since everything seems to be going well right now :slight_smile:

Pretty much in the same boat on the usage hence why I’m only looking at it now while I’ve got some spare time. I use it primarily to route cellphone calls through the pc to the headset.

My AX200 is running ontop of a seperate gigabyte PCIE card in my desktop so not too sure if the bios is too blame here, and it seems to only affect the bluetooth, the WiFi part is working fine.

Was running fine for the past year up to kernel 5.14. Looking at the bugzilla thread it seems it is affecting numerous cards including adapters prior and after the AX200. Busy compiling a kernel with the patch to test (first time for everything so holding thumbs I don’t brake anything LOL). Will advise once done. and if it works will ask Manjaro devs to look into including it on the next build.

okay so some feedback as promised.

I cloned linux515 from manjaro gitlab: Files · master · Packages / Core / linux515 · GitLab. I then added a patch for the intel bluetooth adapters from the post shared above and altered it to include the AX200, changed the PKGBUILD, updated the checkums and then built and installed the kernel using makepkg.

I rebooted after the install and the original timeout error disappeared but was given a new error:
hci0 command 0x0c03 tx timeout (apparently a cold boot would have resolved this but I did not know this at the time). I then ran a “sudo rmmod btsub” followed by “sudo modprobe btusb” to force reload the btusb module. Rebooted again, had the same problem and hence reverted back to stock kernel 5.15.11.

Suddenly the problem was no longer appearing, I tried both cold starts (shutting down, clearing the caps by unplugging the power for a few minutes and then booting) as well as normal reboots but I can’t replicate the original problem and 0xfc05 tx timeout again.

As a side note I installed the custom 5.15.12 kernel again and lo and behold this too is working perfectly. So I’m honestly starting to feel as confused as a chameleon in a smarties box.

For now I will continue running the custom kernel to test, but I cannot say for certain that this resolved the issue or whether it was maybe the firmware as originally mentioned combined with the reload of the btusb module with “rmmod” and “modprobe”. The latter does seem to make a bit more sense though.

I have AX201 and since last year froze my linux-firmware package at version 20200817 because I kept having bluetooth coexistence issues with wifi. I think iwlwifi had some really weird commits around late 2020 or early 2021 that broke a lot of stuff. So far I have no issues with kernel 5.15.7.

Your experience sound s a bit familiar to when I reverted back to a 5.14 kernel, found things worked, then booted back into a 5.15 kernel and it worked again…

What this experience informed me was that I was suffering “USB dropout”… as each reboot would either be flawless… or my mouse or BT would not be working (things under USB).

I feel an updated BIOS firmware helped (AGESA => in my case), but I can’t discount the kernel updates helping either.