Anyone able to start and login to "World Of Warships" recently?

I was able to play this game using Lutris, but since last (or last few) updates, of the game or Lutris, i’m no longer able to get past the “loging in” notice at middle bottom of screen.
The music keeps playing with the game’s background image though and i can close the game, so…

Anyone have any ideas what could be the cause or where to look for troubles it has? :thinking:

I’m able to start and play the “World of Tanks - Blitz” game from the same “Wargaming Game Center” launcher, which has both installed in same wine prefix using Lutris.

I’m able to play the steam version ‘mostly’ fine, I haven’t tried the standalone version in a while but the issue was the same. Maybe 4/5 times the game starts normally but 1/5 it freezes at login.
The problem is where the game gets hung up on one of the particular processes it uses. It used to be something with the word “chromium” or “chrome” in it but when I had this issue a couple days ago it had changed.

The solution below assumes you don’t have the little DxDiag background window popped up, that also blocks the login until you click OK to dismiss it.

It’s a process of elimination to fix it, you can either use “ps aux | grep world” or some version of top to search for world, warships or similar (I usually do it with btop).
Start to terminate the various processes 1 at a time (not the actual worldofwarships64.exe) as that closes the game.
Ending the specific process that’s causing the issue makes the client instantly log in as usual and the hung program restarts itself in the background so you can use the armory and such.

I always had this popup and most times i just let it sit and it disappeared self after some time, it had np then…
PS: Same stuck issue happened in Steam version for me so… :woman_shrugging:

But ill try your idea to kill that browser thing of it and see :+1:


I think it became cef_subprocess.exe because i can’t find the other names you mentioned either.
Anyhow i tried with this script i just made for this occasion, but it still stays same…

  • WoW_unblocker
    #!/usr/bin/env bash
    # SPDX-License-Identifier: Unlicense
    # Kill the cef proccesses in World_of_Warships in an attempt to get it to login again.
    echo "This does NOT fix the issue yet...This line was put here on purpose..."; exit 123
    while true; do
    	mapfile pidsToKill < <(
    		ps -u "${UID}" -opid,args \
    		| sed -nE '
    			/^[ [:digit:]]+sed/ {d}
    			/World_of_Warships.*cef_subprocess/ {
    				s/^\s*([[:digit:]]+).*/\1/; p
    		' || true
    	test ${#pidsToKill[@]} -eq 0 && break
    	for i in "${pidsToKill[@]}"; do
    		echo "Killing PID: $((i))"
    		kill $((i))
    	sleep 2

I’m pretty sure it isn’t the cef_subprocess one, closing that never fixed it for me.
If the problem wasn’t so intermittent I could go through the processes on my end to find out which one I close, generally I only have to close the process once and the game works fine for days before it occurs again.

That’s where I am now, until it happens again I can’t find the offender for you.

When I run btop I tend to get all of the active stuff at the top of the process list so closing my browser leaves steam and the WOWS stuff, whatever I terminate is part of a long command string that trails off the end of the screen.
If I remember right it shows under part of the ‘Wine’ app type of format…so a z:/program_files/steam/steamapps/xxxxx type thing.

Well i’m not running the steam version so it might be different, ill try that in a few i hope.


  • Here is another script for the readers, this one will clean up all the logs in your wine prefix that get generated and grow in time…
    #!/usr/bin/env bash
    # SPDX-License-Identifier: Unlicense
    # Delete all log files and log dirs inside a wine prefix.
    find "$1" \
    	-regextype egrep \
    	-iregex '.*/drive_c/.*(/logs|\.log)$' \
    	-exec rm -vfr '{}' ';' \
  • Yea humans create weird stuff when they are bored… :rofl:
    Lets head back to a game…

@Cornwol which proton version have you set for compatibility?

I suspect you have manually ran the commands and they fail, but… that exit should not be there or none of the code below will be run, it exits with code 123…

I did that on purpose so ppl in future don’t try in fain…


1 Like

Currently Proton 5.13-6 for the Steam version, I was using a GE version for the standalone client when I last used it…that was quite a while back so I don’t remember which version.

Just want to make sure so if someone else just copy/paste it they are aware it doesn’t actually do anything else than print “This does NOT fix the issue yet…This line was put here on purpose…”, witch means the statement is 100% correct because of the exit. xD

Yea i try to be logical when coding :rofl:
I always use exit 123 as in yea yea blabla…
Read it as exit one-two-three :wink:

Yea im using the GE also in Lutris, but was wondering about the Steam one.
I had it set as proton-experimental, will try to switch and see…

Ehh, isn’t proton 8 the latest, proton 5 was… a while ago…

Yeah, it’s the version that has never broken for me. I used to use a more recent version and one of the WOWS updates tanked the fps from 100+ to ~20, I reverted to an older version of Proton and things were good.

It’s not my go-to version for everything, sometimes an older version just works better on a specific game.

Joys of Linux, if you check out the game on protondb you’ll see everyone on different proton versions.
Just a case of trial and error to see what your hardware is happiest with.

I rarely stay on proton-experimental personally, for whatever reason it doesn’t give me the best performance…my gpu isn’t the latest so that probably plays a huge part.

1 Like

I can finally play via Steam + proton 5.13-6 again, BUT it only allows me to use my steam account…

Now, how we get this working again on Lutris, where i can login into my other accounts… :wink:

Note to self: Don’t forget to post this on Lutris git, so they can fix…